Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Μάθετε περισσότερα

Major complaint by many! Can the Firefox code writers fix this?

  • 11 απαντήσεις
  • 2 έχουν αυτό το πρόβλημα
  • 1 προβολή
  • Τελευταία απάντηση από Chandler (scar)

more options

With the latest version of Firefox the menu, etc. have a font size that is TOO SMALL. There are many Mozilla posts about this problem.

https://support.mozilla.org/bm/questions/1260063 https://support.mozilla.org/mk/questions/1395315 https://support.mozilla.org/en-US/questions/1274586 https://support.mozilla.org/bm/questions/1268779

My wife cannot read them. I can barely read them. If this is not fixed soon, we will switch to another browser.

Can the Firefox code writers fix this?

With the latest version of Firefox the menu, etc. have a font size that is TOO SMALL. There are many Mozilla posts about this problem. https://support.mozilla.org/bm/questions/1260063 https://support.mozilla.org/mk/questions/1395315 https://support.mozilla.org/en-US/questions/1274586 https://support.mozilla.org/bm/questions/1268779 My wife cannot read them. I can barely read them. If this is not fixed soon, we will switch to another browser. Can the Firefox code writers fix this?

Επιλεγμένη λύση

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) in about:config. Adjust its value in 0.1 or 0.05 steps like 1.1 to enlarge or 0.9 to reduce until icons/text looks right. You may need values above 2.0 if you have a high resolution display but make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open about:config via the location/address bar. On the warning page, click "Accept the Risk and Continue" to open about:config.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (11)

more options

Can you upload a screenshot?

Does it still happen in Troubleshoot Mode?

Χρήσιμο;

more options

Delete,

Τροποποιήθηκε στις από το χρήστη bhs67

Χρήσιμο;

more options

I'll try again. This - https://snipboard.io/D3yTPB.jpg - is close to real life size.

Χρήσιμο;

more options

What is the native resolution of the monitor setup? Also is this default FF setup - no scripts or Addon? And is this URL font issue only Gmail or other sites as well?

Τροποποιήθηκε στις από το χρήστη markwarner22

Χρήσιμο;

more options

It is the menu font size, not the website contents. Last week's update resulted in a smaller font size.

The display resolution: 2560 x 1600. This is Firefox without scripts or Add-ons. Are there Add-ons that increase the Firefox menu font size?

I captured an image ... https://snipboard.io/hRo3ye.jpg ... but the image resolution is not as clear as the actual resolution. Using Microsoft Word, the Firefox menu font size is Arial Narrow 9.

The links listed in the initial post indicates others with the same problem.

Χρήσιμο;

more options

Does it still happen with the ESR version (115)?

Χρήσιμο;

more options

You can look at this thread:

  • /questions/1384204 Since the last update, the Firefox screen does not fit my system setting(125%)

If setting browser.display.os-zoom-behavior = 0 doesn't work for you then you can create a new Number pref in about:config and set its value to 100. Paste ui.textScaleFactor in the search bar and select the Number radio button and click the '+' button to add the new Number pref, enter the value (100) and click the blue OK button to confirm.

  • about:config => ui.textScaleFactor = 100

You can open about:config via the location/address bar. On the warning page, click "Accept the Risk and Continue" to open about:config.

Χρήσιμο;

more options

Thanks zeroknight and cor-el.

I did enter about:config, etc. None of them changed anything.

The Mozilla / Firefox code writers could make this easier by adding Tools > Settings > Language and Appearance > Menu Font Size. There would be no risk. This would help a lot of people!

Τροποποιήθηκε στις από το χρήστη bhs67

Χρήσιμο;

more options

Επιλεγμένη λύση

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) in about:config. Adjust its value in 0.1 or 0.05 steps like 1.1 to enlarge or 0.9 to reduce until icons/text looks right. You may need values above 2.0 if you have a high resolution display but make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open about:config via the location/address bar. On the warning page, click "Accept the Risk and Continue" to open about:config.

Χρήσιμο;

more options

The sequence --- about:config > yes to risk > layout.css.devPixelsPerPx > next line, edit [pencil icon] > 1.5 > save icon does work.

I had not realized I need to select the pencil icon on the next line.

Unfortunately, it also makes the spacing larger and icons larger ... not desired.

Is there a way to request this change? --- Mozilla / Firefox code writers, Add Tools > Settings > Language and Appearance > Menu Font Size.

Thanks!

Τροποποιήθηκε στις από το χρήστη bhs67

Χρήσιμο;

more options

I was having the same problem, I think, with the interface for Firefox using an abnormally small font.  This manifested in a brand new install of version 115.13.0esr (64-bit) and affected:

  • address bar
  • bookmarks toolbar
  • tab titles
  • main menus and right-click/context menus
  • Library window (history, bookmarks, downloads)
  • add bookmark popup

HOWEVER, the following WERE NOT affected and looked normal:

  • Main Settings (about:preferences)
  • Logins & Passwords (about:logins)
  • Recommendations / Extensions / Themes / Plugins (about:addons)
  • Advanced Prefs (about:config)
  • About About (about:about)

HOWEVER, the following about: pages WERE affected and font was too small:

  • Troubleshooting Info (about:support)
  • New Tab (about:newtab) but only partially: Row of Shortcuts (tiny), Recommended by Pocket cards (normal)

From all the others having this weird issue, I found three advanced prefs (about:config) that affected the interface font / scaling:

  • layout.css.devPixelsPerPx
  • ui.textScaleFactor
  • browser.display.os-zoom-behavior

The last one, browser.display.os-zoom-behavior, changes the way the first two work.  This was set to 1 by default.  With that behavior, layout.css.devPixelsPerPx (set to -1.0 by default) only had effects when set to values above 0.  Careful with small values, I tried 0.1 and I didn't truly know what small was until that point, that was like Antman small.  Push enter to edit the value and try 1.5.  This scaled everything within the interface together, so now I had oversized text and buttons.  I reset that back to -1.0.

ui.textScaleFactor did not exist by default, but can be added as a new number defaulting to 0 or disabled.  100 refers to 100% and had no visible change, so I tried 150.  This scaled the text and toolbar buttons and tab icons that didn't need to be scaled and were already an appropriate size.  So now I had oversized text in those places and in about:config but the address bar, tab titles, menu, etc. remained the same, small size.  I set that back to 100.

Then I went back and set browser.display.os-zoom-behavior to 0.  With this behavior, I set layout.css.devPixelsPerPx to 1.5 again.  Actually this looked the same as with the previous behavior, and confirmed by changing the behavior back to 1.  So the browser.display.os-zoom-behavior seems to only alter the way ui.textScaleFactor works.  With browser.display.os-zoom-behavior back to 0, I found setting ui.textScaleFactor to 60 finally produced a uniform interface across all the above mentioned pages and menus, but large!  I went back and reset layout.css.devPixelsPerPx to -1.0 and I was finally seeing the Firefox I loved and could work with again.  Some final fine tuning of the ScaleFactor and Pixels and we live happily ever after again, until the next OS/Font/Window Manager/Firefox/Add-on update breaks it again...

Best Regards and Good Luck

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.