Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Half of images on certain websites suddenly won't load. Displaying as plain gray color.

  • 5 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 25 προβολές
  • Τελευταία απάντηση από sothajsil

more options

This morning, I found out a selection of my discord server's icons had vanished and emoticons were not loading. I thought it was a discord bug but it's the same for youtube thumbnails. So far they are the only affected websites.

I have tried to no avail:

  • Updating extensions
  • Updating Firefox
  • Clearing site cookies and cache
  • Disabling hardware acceleration
  • Troubleshoot mode
  • Disabling my ad blocker
  • Using Web Tools to locate blocked content

Getting a bit desperate, haha! xD It's not my internet connection, my phone works fine.

Some notes: On youtube, only thumbnails seem to be affected and not all of them - about 2/3, seemingly random. On discord, server icons that are animated show up when moused over (animation) but not when static. When I noticed the issue it was only in a few servers. After doing the described troubleshooting all images are gone. Media sent in chat displays as normal.

If you have any help you are welcome.

This morning, I found out a selection of my discord server's icons had vanished and emoticons were not loading. I thought it was a discord bug but it's the same for youtube thumbnails. So far they are the only affected websites. I have tried to no avail: * Updating extensions * Updating Firefox * Clearing site cookies and cache * Disabling hardware acceleration * Troubleshoot mode * Disabling my ad blocker * Using Web Tools to locate blocked content Getting a bit desperate, haha! xD It's not my internet connection, my phone works fine. Some notes: On youtube, only thumbnails seem to be affected and not all of them - about 2/3, seemingly random. On discord, server icons that are animated show up when moused over (animation) but not when static. When I noticed the issue it was only in a few servers. After doing the described troubleshooting all images are gone. Media sent in chat displays as normal. If you have any help you are welcome.

Επιλεγμένη λύση

Thank you for the comprehensive report.

I'm not familiar with Discord, but one reason for YouTube thumbnails not to display is if you disabled webp images in the about:config preferences editor. If you want to check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default setting, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste image.webp.enabled and pause while the list is filtered

(3) If the preference is bolded and has a value of false, double-click it to restore the default value of true

The next time you reload the page, Firefox should load and display the webp images.


If it's not that, hmm, does it make any difference disabling tracking protection on the site? Click the shield icon at the left end of the address bar (next to the lock) and click the slider switch at the top of the panel to switch it off.

Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (5)

more options

Επιλεγμένη λύση

Thank you for the comprehensive report.

I'm not familiar with Discord, but one reason for YouTube thumbnails not to display is if you disabled webp images in the about:config preferences editor. If you want to check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default setting, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste image.webp.enabled and pause while the list is filtered

(3) If the preference is bolded and has a value of false, double-click it to restore the default value of true

The next time you reload the page, Firefox should load and display the webp images.


If it's not that, hmm, does it make any difference disabling tracking protection on the site? Click the shield icon at the left end of the address bar (next to the lock) and click the slider switch at the top of the panel to switch it off.

Χρήσιμο;

more options

Do you have enabled "Resist Fingerprinting" if you check this pref on the about:config page?

Χρήσιμο;

more options

jscher2000 - Support Volunteer said

I'm not familiar with Discord, but one reason for YouTube thumbnails not to display is if you disabled webp images in the about:config preferences editor.

This was the issue, thank you! Seems images were only displaying when cached, and by clearing my cache with webp disabled, it erased the rest. I hate that format and disabled it on purpose, is there a way to auto-convert to PNGs or other formats so I can display my images without seeing it? Thank you!

Χρήσιμο;

more options

I have some add-ons related to webp images. You could take a look if you're interested.

One simply strips webp from the list of accepted formats Firefox sends to sites. That discourages sites from replacing large JPEGs and PNGs with webp, but doesn't prevent sites like YouTube that ONLY offer webp from sending webp.

The others convert the image when saving, which can't restore the original quality. They also have the option to re-request the image disguised as Internet Explorer 11, in case the server serves an older format in that situation. (You need that for animated GIFs on Tumblr, for example.) They have a totally different interfaces from one another:

Χρήσιμο;

more options

Thank you so much for your help. Installing the first extension and re-enabling wepb in config. Bless the guys who make these extensions! Have a nice day.

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.