Search Support

I can't get to my library's log in page unless I refresh Firefox, but I prefer not to refresh.

  • 8 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 40 προβολές
  • Τελευταία απάντηση από Rahin

more options

The title of my question is a bit hard to understand. Let me try to explain.

My library gives me electronic access to the Oxford English Dictionary (my favorite dictionary, with all those helpful quotes/example sentences!)

What I should get:

1. Go to http://www.vpl.ca/digital-library/oxford-english-dictionary

2. Click the "Access Now" button (link to https://www.vpl.ca/extDB/login.remoteDB?OxfordEnglishDictionary)

3. I'm taken to a page that says "VPL Electronic Resource Authentication", where I enter my library card number and PIN.

4. I enter my card number and PIN, then press the Authenticate button

5. I'm taken to to a page that says "Your login was successful." I then press the "Continue ➡️"

6. I'm taken to https://www.oed.com/ where i can now happily use the dictionary


What I experience:

1. Go to http://www.vpl.ca/digital-library/oxford-english-dictionary

2. Click the "Access Now" button (link to https://www.vpl.ca/extDB/login.remoteDB?OxfordEnglishDictionary)

3. I'm taken to http://www.vpl.ca/digitallibrary

4. If I go to oed.com directly, it shows that I'm not logged in /authenticated.

Τροποποιήθηκε στις από το χρήστη Rahin

Επιλεγμένη λύση

I removed the cookies for vpl.ca and www.vpl.ca and now I see the log-in screen. Thanks, cor-el and jscher2000.

Ανάγνωση απάντησης σε πλαίσιο 👍 1

All Replies (8)

more options

Are you using your own Firefox, meaning, you completely control the configuration? If it's a public PC, what I'm about to describe might not be possible.

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like Nov2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Nov2019 will remain available for future testing.)

more options

Hi, jscher2000. Thanks for your reply. Yes, I'm using my own Firefox. I own this laptop computer, and I can do whatever I want to it.

I created a new profile (which I called "TestingLibrary". The problem site works as it should in the new profile.

more options

Okay, that suggests the issue is a setting or add-on. It's just not always easy to figure out which one it is! Perhaps something related to privacy, though, since some data needs to pass between the site where you signed in and the dictionary to verify that you are authorized.

more options

delete

Τροποποιήθηκε στις από το χρήστη tailonfire

more options

jscher, I thought it may be something to do with addons too. But even when I restart Firefox with addons disabled (by going to Help>Restart Addons with Addons Disabled), the problem persists. In other words, I have the same, four-step experience as I write about in my OP.

more options

Did you check for issues caused by extensions?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


This issue can be caused by corrupted cookies or cookies that are blocked.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

cor-el, I initially suspected it may have something to do with addons too. But even when I restart Firefox with all addons disabled (by going to Help>Restart Addons with Addons Disabled), the problem persists. In other words, I have the same, four-step experience as I write about in my OP.

Now i'll check corrupted cookies/ cache, as you advised in the 2nd half of your post. One moment please.

Τροποποιήθηκε στις από το χρήστη Rahin

more options

Επιλεγμένη λύση

I removed the cookies for vpl.ca and www.vpl.ca and now I see the log-in screen. Thanks, cor-el and jscher2000.