Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

FireFox 19.02 Cookie Handling Changes prevent users from blocking or allowing cookies?

  • 8 Antworten
  • 9 haben dieses Problem
  • 2815 Aufrufe
  • Letzte Antwort von user832823

more options

Prior to 19.0.2, I could specifically decide exactly how a site deposited cookies on my machine. When I visited a 'new' site, FireFox sprung open a pop-up window that allowed me to choose "Block", "Allow for Session" or "Allow". That doesn't appear anymore.

Also, for at least one site, FireFox won't adhere to my chosen handling preference: "Twitter dot com" will not accept the "Allow For Session" designator. I've NEVER allowed any site to set cookies past session's end, and prior to 19.0.2 Twitter had the "Allow for Session" designation. Now, however, Twitter FORCES FireFox to "ALLOW" cookies; when I manually enter "Allow for session" Firefox won't take it! FireFox immediately changes that to "ALLOW" status.

Why was the very nice pop-up cookie handling routine disabled in FireFox 19.0.2, and is there any way to get it back? This new FireFox is making me unhappy.

Alle Antworten (8)

more options

Are you running Firefox in Private Browsing mode?

You can inspect and manage the permissions for all domains on the about:permissions page.

more options

hey you can change your cookie setting here


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Geändert am von Amit Kumar Thakur

more options

I am not running in Private Browsing mode. Should I use that mode primarily?

more options

I have my preferences set to "clear all history" and "delete all cookies" when I close my browser. No cookie should remain after I close; and no persistent cookies should be in the system after I restart.

I found and downloaded a plugin, Cookie Controller 1.6, which gives me a bit more control over these pesky little things.

Oh, and I found today that g00gle.com had also managed to work a change to my cookie handling preferences: from "Allow for Session" to "Allow".

How does a site manage to do that? Is FireFox submitting to a website's demands that persistent cookies be kept? That's got to be a security hole big enough to throw a cat through!

Thanks for your replies, and Cheers!

more options

you can use private browsing mode to be safe .

more options

Thanks!

The Big Question remains:

Why did FireFox change the Cookie handling routine? I want my decision-making pop-up Cookie-handling box back!

"Allow This Site to Set Cookies?" [Click Option] "Block" "Allow" "Allow for Session" Also, a tiny check box: "Remember this setting"

Taking that away? Bad form, FireFox!

more options
more options

Hi Villiam,

you could try an Add-on like toggle-cookies which will let you handle cookies as you wish. This is primarily for people who like to keep cookies disabled and probably have the "Ask me every time" option selected to control exceptions like a whitelist.
Hope that helped you!