Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

frequent crashes of firefox running on fedora 38 workstation

  • 6 Antworten
  • 0 haben dieses Problem
  • 25 Aufrufe
  • Letzte Antwort von cor-el

more options
As the title says, after a certain update(I'm not sure which, probably within the last few months or so), firefox on my machine starts crashing randomly. Some crash reports: https://crash-stats.mozilla.org/report/index/bp-3c8ccdac-bf09-41af-a459-a5e0c0240204 https://crash-stats.mozilla.org/report/index/bp-a5d887f3-3d75-4e09-a4af-823a20240204 https://crash-stats.mozilla.org/report/index/bp-1cb416ff-e338-445c-9ff3-016f30240204 https://crash-stats.mozilla.org/report/index/bp-3da43a7e-5952-4715-83cf-512aa0240204 https://crash-stats.mozilla.org/report/index/bp-c6778172-5281-482b-b815-ebf840240204 https://crash-stats.mozilla.org/report/index/bp-54dd6c03-a99c-4a08-8a7c-4c80d0240204 I'm using Fedora 38 workstation, GNOME as the desktop environment, and Mutter as the wm.

Geändert am von Bee Rath

Alle Antworten (6)

more options

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release X11 or Wayland? I assume you already tried running your distro version in Safe Mode?

Hilfreich?

more options

This doesn't look to me like a distro version.

You can try to disable http3 via about:config.

  • about:config => network.http.http3.enable => false

Hilfreich?

more options

cor-el said

This doesn't look to me like a distro version. You can try to disable http3 via about:config.
  • about:config => network.http.http3.enable => false

this seems to fix the issue, thanks!

Hilfreich?

more options

cor-el said

This doesn't look to me like a distro version. You can try to disable http3 via about:config.
  • about:config => network.http.http3.enable => false

Wondering how to let the developer team know this and fix this issue properly? I want to use those HTTP/3 features :( (though a browser that is not crashing but does not support HTTP/3 is better than a unusable crashing one)

Geändert am von Bee Rath

Hilfreich?

more options

Does it still happen with the flatpak version?

Hilfreich?

more options

There are quite a few http3 prefs and I don't know if disabling one or more of the other http3 prefs instead of fully disabling http3 would stop the crashes.

There is a bug linked to the crash report and a GitHub link:

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.