Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

New Firefox GPC 120 setting causes problems on Xfinity community forum

  • 9 Antworten
  • 1 hat dieses Problem
  • 36 Aufrufe
  • Letzte Antwort von zeroknight

more options

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forums (https://forums.xfinity.com/) . It causes a banner on top showing they recognize the setting. There is an "X" in the corner, and some text that says "Hide this banner", but they are not active. Plus, I cannot make a new post or do a general reply (that weird forum software has both local replies to a particular post and general replies to the general thread.)

Is this a bug in Firefox, or a bug in their forum software? I attached a picture of the message it gives.

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forums ([https://forums.xfinity.com/ https://forums.xfinity.com/]) . It causes a banner on top showing they recognize the setting. There is an "X" in the corner, and some text that says "Hide this banner", but they are not active. Plus, I cannot make a new post or do a general reply (that weird forum software has both local replies to a particular post and general replies to the general thread.) Is this a bug in Firefox, or a bug in their forum software? I attached a picture of the message it gives.
Angefügte Screenshots

Geändert am von andyross

Alle Antworten (9)

more options

I'm not seeing this banner with either or both DNT:1 and Sec-GPC:1 enabled.

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

I tried clearing cache and cookies. No change. Even worse, I had to re-clear them and log back in again because the reply box was missing again.

more options
more options

On another computer, with a FRESH install of Firefox and a FRESH profile with NO add-ons or other changes, I get the same thing. I don't think it's really Firefox related as much as Comcast/Xfinity not handling the flag properly.

more options

Hello this is Don. I am using Win10 with Firefox 120.0 64 Bit as my default browser I am having the same problem but my problem is with The Sony Community Forum. I enter my email as my Sign in ID then enter and it goes to the spinning grey circle on a white screen. My Memory and CPU gets high and my browser locks up and I have to go to task manager and End Task for all Firefox processes to unlock it. I have no problem with MS Edge but I hate using it but I have to in order to sign in to Sony Community Forum and help users. I have scanned for malware with Norton, MSERT, Malwarebytes and Windows Defender. I have done a REFRESH of Firefox and I have even uninstalled and re-installed Firefox and nothing helps. I have it set to auto clear everything under History including Cache and Cookies. There is something about these Forums and Firefox. I have used Firefox for years and do not want to have to go to something else.

Respectfully, Don

Geändert am von new_aged2perfection

more options

The new setting is NOT enabled by default. If it is off, then there is something else going on.

more options

@ new_aged2perfection

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed add-ons.

You can check for issues with Total Cookie Protection.

more options

You can try a New Private Window.

more options

The banner only seems to appear for IP addresses located in regions where GPC applies. The close button adds the "hide-banner" class but it does not have any associated style so it remains visible. I see the same on Chrome with a GPC enabler extension, it seems to be an untested configuration for this site.