Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Garbled font in Firefox on macOS Monterey

  • 2 Antworten
  • 0 haben dieses Problem
  • 22 Aufrufe
  • Letzte Antwort von kaffepanna

more options

Hi. I have experienced some font encoding problem occurring in the latest version of Firefox, not in previous versions. My system is Mac OS Monterey 12.3.1 and Firefox version 107.0

On some sites the fonts looks totally garbled (see provided screenshots). Disabling "Allow pages to choose their own fonts, instead of my selections above" in Firefox settings fixes the problem, but then all websites I visit displays with default fonts and not as intended. Moreover, I'm a web designer working with the built in web developer tools, and I need to see the correct fonts when developing.

Hoping to get some help with this issue.

Br, Magnus

Hi. I have experienced some font encoding problem occurring in the latest version of Firefox, not in previous versions. My system is Mac OS Monterey 12.3.1 and Firefox version 107.0 On some sites the fonts looks totally garbled (see provided screenshots). Disabling "Allow pages to choose their own fonts, instead of my selections above" in Firefox settings fixes the problem, but then all websites I visit displays with default fonts and not as intended. Moreover, I'm a web designer working with the built in web developer tools, and I need to see the correct fonts when developing. Hoping to get some help with this issue. Br, Magnus
Angefügte Screenshots

Ausgewählte Lösung

That is likely nor an encoding problem but a problem with a specific font like an Arial font.

You can check in Font Book for font issues like corrupted and duplicate fonts.

This can be caused by a problem with fonts you have installed locally and that might be corrupted or are missing variants. You will have to identify and remove corrupted font(s).

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Note that you shouldn't disable "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons (you may see text labels instead of icons).

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (2)

more options

Ausgewählte Lösung

That is likely nor an encoding problem but a problem with a specific font like an Arial font.

You can check in Font Book for font issues like corrupted and duplicate fonts.

This can be caused by a problem with fonts you have installed locally and that might be corrupted or are missing variants. You will have to identify and remove corrupted font(s).

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Note that you shouldn't disable "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons (you may see text labels instead of icons).

Geändert am von cor-el

Hilfreich?

more options

Thanks for your answer. I let Font book check for corrupt fonts or duplicates but the search came up empty handed, no duplicates or critical errors. However, after the scan the problem disappeared, as if the scan itself fixed the problem. Conclusion, you're absolutely right. It clearly had to do with one/some of my installed fonts, and simply scanning them fixed the problem somehow :) Again, thank you, and merry Christmas!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.