X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

No add ons, themes, extensions showing in "add ons" menu

Veröffentlicht

After installing v65, when I go to the addons menu, no items are showing. Evidence exist they are there 1/ I have addons working quite well with this version, I tried a new theme which after a few re-starts, eventually took hold 2/ when I do open add ons menu, there is evidence that there is a list there, but they are only place holders. My mouse shows a blue line around the entire field, but absolutely nothing inside... like a white out. So I can't uninstall themes, even though I have installed a trial one... nothing at all appears. HELP!

After installing v65, when I go to the addons menu, no items are showing. Evidence exist they are there 1/ I have addons working quite well with this version, I tried a new theme which after a few re-starts, eventually took hold 2/ when I do open add ons menu, there is evidence that there is a list there, but they are only place holders. My mouse shows a blue line around the entire field, but absolutely nothing inside... like a white out. So I can't uninstall themes, even though I have installed a trial one... nothing at all appears. HELP!

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Weitere Informationen

Veröffentlicht

Fragesteller

Wow! Now that's think from left of field! How do see if that is so?

Wow! Now that's think from left of field! How do see if that is so?
Veröffentlicht

Fragesteller

See attached menu picture... I've selected "use system colors" after your idea... but nul effect

See attached menu picture... I've selected "use system colors" after your idea... but nul effect
Veröffentlicht

Fragesteller

For what it's worth, after removing ~a dozen themes and leaving just the basics (in Safe mode), if you look carefully at the attached screenshot, it now shows just 3 "blank" placeholders, so FF is picking up something. I have tried to copy the blank and paste into Notepad (which oughtn't be influenced by formatting, I guess) in the hope it may show some text... It doesn't. Couldn't really copy whatever may have been there (in white) anyhow.

For what it's worth, after removing ~a dozen themes and leaving just the basics (in Safe mode), if you look carefully at the attached screenshot, it now shows just 3 "blank" placeholders, so FF is picking up something. I have tried to copy the blank and paste into Notepad (which oughtn't be influenced by formatting, I guess) in the hope it may show some text... It doesn't. Couldn't really copy whatever may have been there (in white) anyhow.
FredMcD
  • Top 10 Contributor
4222 Lösungen 58926 Antworten
Veröffentlicht

Switch to the default theme. Then restart Firefox.

Switch to the default theme. Then restart Firefox.
Veröffentlicht

Fragesteller

Well, yes, of course. That's why, to be sure, I deleted all other themes, thus showing, when restarted that there were only 3 placeholders indicating 1/ default 2/light and 3/ dark themes available, though not visible in "normal" mode.

See the before and after pictures in attached photos

Well, yes, of course. That's why, to be sure, I deleted all other themes, thus showing, when restarted that there were only 3 placeholders indicating 1/ default 2/light and 3/ dark themes available, though not visible in "normal" mode. See the before and after pictures in attached photos
Veröffentlicht

Fragesteller

I have also rebooted the PC- several times and restarted FF between each fiddle with a consistently nul result

I have also rebooted the PC- several times and restarted FF between each fiddle with a consistently nul result
FredMcD
  • Top 10 Contributor
4222 Lösungen 58926 Antworten
Veröffentlicht
Well, we tried to fix this, but no go. Use these links to create a new profile. Use this new profile '''as is. ''' Is the problem still there? https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type '''about:profiles'''<enter> in the address bar.
Veröffentlicht

Fragesteller

Thanks for that, I'll give it a shot a little later today... Somewhat despondent over lack of progress in resolving the issue, though I guess we have eliminated the obvious at least... I appreciate your patience, thank you

Thanks for that, I'll give it a shot a little later today... Somewhat despondent over lack of progress in resolving the issue, though I guess we have eliminated the obvious at least... I appreciate your patience, thank you
cor-el
  • Top 10 Contributor
  • Moderator
17413 Lösungen 157294 Antworten
Veröffentlicht

It is possible that there is a problem with files in the profile folder that store the extensions registry.

Delete the extensions.* files (extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder with Firefox closed to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

You can check if there is a update available in case of issues.

  • click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates"

If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

It is possible that there is a problem with files in the profile folder that store the extensions registry. Delete the extensions.* files (extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder with Firefox closed to reset the extensions registry. *https://support.mozilla.org/en-US/kb/Profiles New files will be created when required. See "Corrupt extension files": *https://support.mozilla.org/en-US/kb/unable-install-add-ons-extensions-or-themes You can check if there is a update available in case of issues. *click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates" If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Veröffentlicht

Fragesteller

Well, I've given it a week to draw breath. Vain hope that FF65.0.1 might magically resolve my invisible add on etc page. It doesn't. Deleting extensions.* files while FF is closed makes no difference... are we fresh out of ideas? Peter

Well, I've given it a week to draw breath. Vain hope that FF65.0.1 might magically resolve my invisible add on etc page. It doesn't. Deleting extensions.* files while FF is closed makes no difference... are we fresh out of ideas? Peter
cor-el
  • Top 10 Contributor
  • Moderator
17413 Lösungen 157294 Antworten
Veröffentlicht

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
JayShankar 0 Lösungen 3 Antworten
Veröffentlicht

Hilfreiche Antwort

This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully.

The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal.

I hope this helps anyone who might have the same problem originating in the chrome folder.

This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully. The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal. I hope this helps anyone who might have the same problem originating in the chrome folder.
FredMcD
  • Top 10 Contributor
4222 Lösungen 58926 Antworten
Veröffentlicht

Thank you for your insight.

Thank you for your insight.
Veröffentlicht

Fragesteller

Awesome, simply awesome! Thank you... after all the hand wringing it was as simple as you suggest. Re-started Firefox and there are all my add ons in their glory! You deserve a pay rise, Thanks, Peter

Awesome, simply awesome! Thank you... after all the hand wringing it was as simple as you suggest. Re-started Firefox and there are all my add ons in their glory! You deserve a pay rise, Thanks, Peter
JayShankar 0 Lösungen 3 Antworten
Veröffentlicht

pik94 said

Awesome, simply awesome! Thank you... after all the hand wringing it was as simple as you suggest. Re-started Firefox and there are all my add ons in their glory! You deserve a pay rise, Thanks, Peter

Thanks, happy it helped ... but I'm not an employee, just a poor punter like yourself. Cheers!

''pik94 [[#answer-1209674|said]]'' <blockquote> Awesome, simply awesome! Thank you... after all the hand wringing it was as simple as you suggest. Re-started Firefox and there are all my add ons in their glory! You deserve a pay rise, Thanks, Peter </blockquote> Thanks, happy it helped ... but I'm not an employee, just a poor punter like yourself. Cheers!
FredMcD
  • Top 10 Contributor
4222 Lösungen 58926 Antworten
Veröffentlicht

pik94 You marked my response as the solution. Please remove that and mark the https://support.mozilla.org/en-US/questions/1248470?page=2#answer-1209667 response as Solved Problem.

'''pik94''' You marked my response as the solution. Please remove that and mark the https://support.mozilla.org/en-US/questions/1248470?page=2#answer-1209667 response as '''Solved Problem.'''