Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Denne tråd blev lukket og arkiveret. Stil et nyt spørgsmål, hvis du har brug for hjælp.

How do I move the Bookmarks Toolbar above the tabs in 29.0?

  • 24 svar
  • 89 har dette problem
  • 18020 visninger
  • Seneste svar af the-edmeister

more options

Before the update, I was able to use Stylish to get this functionality. However, something is broken with how -moz-box-ordinal-group functions. The only valid entries are 0 (places it above the Menu Bar) or !0 (places it at the very bottom).

Neither of those two places are what I desire. Here is what I'm aiming for, from top to bottom:

Menu Bar
Bookmarks Toolbar
Tabs
Address Bar

See this Stylish for a picture of what I used to have:
http://userstyles.org/styles/46274/firefox-4-bookmarks-toolbar-above-tabs-enhanced

So, my question here is, how can I restore this functionality? Having bookmarks below the address bar does not follow logic, in my mind. And this "now things are easy to customize how you want it!" thing that Australis is supposed to allow... doesn't let me customize it how I want it.

Any help would be appreciated, be it a config setting, a plugin, or some CSS I can plug into Stylish.

Ændret af cor-el den

Valgt løsning

wyrenth wrote:

Menu Bar Bookmarks Toolbar Tabs Address Bar

The following will work, provided other user styles don't interfere.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#TabsToolbar { -moz-box-ordinal-group: 2 !important }
#nav-bar { -moz-box-ordinal-group: 3 !important }

Læs dette svar i sammenhæng 👍 3

Alle svar (4)

more options

No it's not full screen, it's a maximized window. Sliding it doesn't change the view at all. The reduced window shows tabs cut off at the top. With the add-on, tabs are below the bookmark toolbar where they were before the update.

more options

go to about:config Click "I'll be careful, I promise" In the search bar type: "browser.tabs.onTop" Change Value to: false

more options

Simply:

go to about:config Click "I'll be careful, I promise" In the search bar type: "browser.tabs.onTop" Change Value to: false

more options

locking this thread after selecting the first correct solution

Ændret af the-edmeister den

  1. 1
  2. 2