Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I have my homepage be on every new tab instead of a blank page?

  • 8 svar
  • 38 har dette problem
  • 125241 visninger
  • Seneste svar af heylicky

more options

Hi ~ Not to compare Firefox to my past browser, but when I opened a new tab, it opened my homepage. Can I get it to work that way here? Thanks

Valgt løsning

You can modify the browser.newtab.url pref and change the value to http://foxnews.com
Also make sure that the new tab page is enabled, the browser.newtabpage.enabled should be true.


Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean
Læs dette svar i sammenhæng 👍 19

Alle svar (8)

more options

You can modify the browser.newtab.url pref on the about:config page and set its value to the home page.

See also this article about the New Tab page (about:newtab):

more options

Thanks for answering.

I saw the page about new tabs - but I must live in another dimension because I don't have anything it talks about. No websites are displayed on a new tab - it is blank. No 'bookmark' icon is on the upper right side. I don't have sites to rearrange. I don't have a toggle button to hide new tab page. And, I am totally confused on the 'about:config page'

Now what?!

more options

Which page do you want to set as the home page?

more options

Foxnews.com Does that matter?

more options

Valgt løsning

You can modify the browser.newtab.url pref and change the value to http://foxnews.com
Also make sure that the new tab page is enabled, the browser.newtabpage.enabled should be true.


Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean
more options

It worked! Thank YOU!

Can you do the same magic and make 'history' show more than just today?!

You're the best!

more options

In case you are using "Clear history when Firefox closes":

  • do not clear the Browsing History

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.


Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
more options

Tools --> Add-ons. Search for ' new tab homepage '. Install it. When you open a new tab, you get the same page you've set in preferences as your homepage

Ændret af heylicky den