Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Denne tråd blev lukket og arkiveret. Stil et nyt spørgsmål, hvis du har brug for hjælp.

Can't download files because Firefox keeps asking for consent and there isn't an ALLOW button anywhere

  • 87 svar
  • 469 har dette problem
  • 282 visninger
  • Seneste svar af the-edmeister

more options

Everytime I try to download a "large" file Firefox keeps asking me:

Firefox needs your consent to download large files. Please click ALLOW to continue your transfer.

If you cannot see the request, please click on the icon next to the address bar.

I didn't have this kind of troubles before until the new version, I'm so frustrated that I'm really thinking to switch to Chrome instead.

And in case someone wonders, there isn't a request icon at ALL.

Everytime I try to download a "large" file Firefox keeps asking me: Firefox needs your consent to download large files. Please click ALLOW to continue your transfer. If you cannot see the request, please click on the icon next to the address bar. I didn't have this kind of troubles before until the new version, I'm so frustrated that I'm really thinking to switch to Chrome instead. And in case someone wonders, there isn't a request icon at ALL.

Ændret af NoahSUMO den

Valgt løsning

Pls check out the following article dealing with this topic, well worth reading imo:


Læs dette svar i sammenhæng 👍 1

Alle svar (20)

more options

Firefox doesn't ask for such a confirmation.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Of course it does, the pop up even shows the Firefox logo. Besides that...

I just strip clean the hard drive and did a complete format on it so I'm working inside a brand new environment, it has nothing but the antivirus and the Firefox browser so no spybot, rookit or else, unless they came with the new firefox version installer.

The browser it's at the default theme, no add-ons, hardware accelerators or anything else for that matter. Its the vanilla version.

Safe mode doesn't help either.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

The pop-up comes with some graphic instructions about where to "Allow" the download, but that option is non existent, oh and now, every time I write something at the search bar some kind of DOS windows pop up and vanish in less than a second.

Is there a way to install the old version? and where can i find it?

Thanks in advance

more options

Any news on this or should I stick to Chrome?

more options

The Firefox logo is only meant to identify which program needs this confirmation.
Firefox would do this in this way, but would use other ways.

I can't think of any reason for Firefox doing this or you may have set some quota setting in Windows.

Did you try to boot Windows in Safe Mode?

more options

That's an overlay from the page trying to convince you to allow an unusually large amount of site-specific data storage. I've never seen this request from any other sites, so I don't know what is the justification for it. Maybe it's their installer technology??? I think it would make sense to ask the site what it's for since you do not normally need to allow local data storage in order to just download a file.

more options

Mega use indexdb to store the files. What you are actually doing is transferring the data from Mega to your local system in indexdb. That requires (on Firefox) permission from the user if it's more than 50MB.

Firefox does this to prevent malicious sites from using up all your disk space.

more options

If you do not have the blue-circle-question-mark icon, you might have chosen the "Never for This Site" option at one point. This prevents Firefox from prompting you to allow in the future.

I couldn't find a way just to clear that one decision without clearing all settings and history for the site using the "Forget about this site" feature. Someone might know a shortcut that allows you to preserve history and perhaps more importantly for this site, past files downloaded to local storage.

If you don't find another way, open the Library dialog to your History using either

  • History > Show All History
  • Ctrl+Shift+h

Then right-click an entry for that site and choose Forget About This Site. Do not be alarmed if this takes a minute or two, since Firefox is going through history and cache to clear all references to the site. Your next visit will be as though it were your first.

Ændret af jscher2000 - Support Volunteer den

more options

To expand a bit, Mega keeps the data encrypted on the server. The data is decrypted in JavaScript. It does this be decrypting and writing to IndexDB so it doesn't need to keep the entire file in memory. Once the decryption is complete the file is 'downloaded' from IndexDB to the users Download directory. To handle files greater than 50MB it requires permission from the user as this is the limit imposed by Firefox.

more options

It's a brand new installation after formatting the disk, so no cuota or anything like that.

more options

As you can see in the uploaded image, the file is less than 10 mb, not even close to 50mb.

About the "never for this site". Nop, as I said before, its a new installation with no adjustments made at the standard procedure. Besides that, one of the first thing I actually change is to set the options to never store data and clean history at closing and I didn't have the chance when I found this annoying "bug"? feature? or I don't know how to call it.

Thanks for the answers anyway.

more options

Hi Redsteel, I wasn't able to test with a file that small. Try reducing the maximum size so you get prompted. To do that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste offline and pause while the list is filtered

(3) Double-click offline-apps.quota.warn and change the value from 51200 (50 MB) to 5120 (5 MB). OK that and try the download again.

Does that cause Firefox to display the permission prompt?

more options

You can inspect and manage the permissions for all domains on the about:permissions page or for the current domain via the ""Site Identity Button" (globe/padlock) on location bar" and click "More Information" to open "Page Info" and go to the Permissions tab.

You can delete the permissions.sqlite file to reset all permissions.

more options

I have the same problem when using private browsing mode. The reason might be that IndexedDB is disabled in private browsing mode.

more options

Thanks to all for their contributions, but none of that solves the problem. No question mark appears per the message. Mega has nowhere to go to find help on this subject.

I have tried increasing offline-apps.quota.warn from 50MB to 500mb without success.

This is a NEW issue with Firefox & Mega - did not happen in pre 20 firefox.

Does anyone know an actual setting/workaround or is firefox unusable for Mega backups?

Ændret af brownieb den

more options

So, you do get the allow button in normal mode, but not in Private Browsing mode?

If this is the case then you will have to visit the website in normal mode.

more options

Hi brownieb, I suggested decreasing the quota; did you try that?

Here's my reasoning: it appears that you need to get prompted, and in order to get prompted, your warning quota needs to be smaller than the file you are trying to download.

Steps in this post: https://support.mozilla.org/questions/960444#answer-440456

Note: I've been testing with this image file: https://mega.co.nz/#!iNtX0JyI!QEKMfyd6KQfNfRV8CaAhOiSLEGoorrZG8iYeDXsYIIE

Ændret af jscher2000 - Support Volunteer den

more options

No - the question mark doesn't show at all regardless of mode

Also, any link of direct connection to Mega defaults immediately to https.

more options

OK - This fixes it: - (see attached image)

1) Left Click on the lock image in the address bar (next to the https://), then click the "More Information" button that pops up.

2) Select the Permissions tab.

3) On the "Maintain Offline Storage" section, leave 'Use Default' clicked and 'Allow' radio button selected, but click the "Clear Storage" button.

4) On your next Mega download, you'll get asked about storing locally - say Yes and that fixed it here. In fact, as you go over the 50 MB limit, it will ask again as in the second image.

Hope that helps everyone with this.

Ændret af brownieb den

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5