Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox refuses to show downloaded font on initial page

  • 7 svar
  • 1 har dette problem
  • 40 visninger
  • Seneste svar af naena

more options

The first of the following web sites is a hand written web site and the next is a WordPress blog: http://www.lovatasinhala.com http://www.ahangama.com They both use a downloaded Open Type font. It is a Singhala smartfont. (The first and only smartfont for any written language).

Firefox 3.0 is the first browser that displayed the ligatures in the font according to Open Type. Since of late, when you use Firefox to go to these sites, the pages are shown in the default font (Arial). The author specified font is not shown even after the page is refreshed. However, if you click another menu (or a blog page), the font shows.

I tested these pages in Safari, Chrome/Chromium, Arora, Opera and IE. All of them display the font as soon as you call up the web site except, of course, IE that does not understand Open Type.

In 2006, there was a unfounded fear that rendering thousands of ligatures would grind the computer to a halt. It was due to a misunderstanding of how an Open Type font is processed. Later, the Bugzilla engineers of Mozilla tested this issue and found that the difference between rendering a non-ligatured font and my font is 2%, which I think is within the margin of error.

I think the old legend has entered the minds of the Mozilla engineers.

Please fix this problem as Firefox is by far the most popular browser in South Asia among users of Windows XP and Linux, and this solution for complex scripts is the only way Indic languages could be elevated to same level as European languages that use the Latin script.

Thanks.

The first of the following web sites is a hand written web site and the next is a WordPress blog: http://www.lovatasinhala.com http://www.ahangama.com They both use a downloaded Open Type font. It is a Singhala smartfont. (The first and only smartfont for any written language). Firefox 3.0 is the first browser that displayed the ligatures in the font according to Open Type. Since of late, when you use Firefox to go to these sites, the pages are shown in the default font (Arial). The author specified font is not shown even after the page is refreshed. However, if you click another menu (or a blog page), the font shows. I tested these pages in Safari, Chrome/Chromium, Arora, Opera and IE. All of them display the font as soon as you call up the web site except, of course, IE that does not understand Open Type. In 2006, there was a unfounded fear that rendering thousands of ligatures would grind the computer to a halt. It was due to a misunderstanding of how an Open Type font is processed. Later, the Bugzilla engineers of Mozilla tested this issue and found that the difference between rendering a non-ligatured font and my font is 2%, which I think is within the margin of error. I think the old legend has entered the minds of the Mozilla engineers. Please fix this problem as Firefox is by far the most popular browser in South Asia among users of Windows XP and Linux, and this solution for complex scripts is the only way Indic languages could be elevated to same level as European languages that use the Latin script. Thanks.

Ændret af naena den

Alle svar (7)

more options

Some more info. The relevant CSS for the downloaded font:

@font-face { font-family:samagana;src:url(/avazyabadu/samagana.woff) format("woff"),url(/avazyabadu/samagana.ttf) format("opentype"); }

Thanks.

.sinhala { font-family:samagana,sumangala, sans-serif; text-rendering:geometricPrecision; }

more options

Works for me in Firefox 9.0.1 on Linux and also with a Windows version that runs under Wine.

Do you see that the font is requested if you open the Web Console (Ctrl+Shift+K)?

Ændret af cor-el den

more options

cor-el,

Thank you for trying to help.

I do not understand what you expect me to see after doing Ctrl+Shift+K. What I get is a blank area and a prompt to type something just below it

I tested V9 in my Puppy Linux machine and it showed the page as expected using the smartfont. The problem is in Windows XP and 7. In both of those, the page is shown as Romanized Singhala. If you try to refresh the page, it does not switch to the font that is already downloaded in the background. Only way to trigger it to show the Singhala font is to click on another menu and come back.

Please see the two screenshots sent. They are of the identical page, but in two different fonts. One is in Romanized Singhala because it is displayed in the default Latin font. The other one is in the downloaded Singhala script.

All other browsers (not IE) wait for the font to finish downloading to display the page in that font. This is the behavior of V3.6. Now it shows the default font forgetting the downloaded font. This may be due to a misconception regarding display delay.

Ændret af naena den

more options

I see the downloaded Singhala script in Firefox 9.0.1 on WinXP. It appears immediately on 9.0.1, but with Firefox 3.6.25 it initially displays the Romanized Singhala version and then very quickly reloads it correctly.

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

I now have V10 on XP. The problem persists. The problem existed in Win 7 too. What is most frustrating is that it worked all the way till version 9, and not all other browsers (Not IE) show the smartfont as the page loads.

You are right that in the earlier versions, it shows the romanized form until the font has downloaded and then it repaints the page with the smart font.

more options

I just tested Win XP and Win 7 both that have V10. This machine is Puppy Linux with V9.

Linux shows the smartfont, but both Win Xp and 7 with V10 refuse to show the font with regular Refesh, F5, Shift-Refresh, Ctrl-Refresh.

Th is a program bug and I prey that a FF engineers sees this report. (Has Mozilla become like M$ leaving the public to sort it out? That's sad).

Ændret af naena den