X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Fonts totally messed up on some sites

Skrevet

Since upgrading to 6.0, some sites can't be read at all. Instead of regular fonts, there are symbol fonts. Below is only one example. It doesn't happen on every site, only some. I've tried everything on the support page for "web pages not loading properly" (or whatever it's called). Could it be a plug-in problem?

Since upgrading to 6.0, some sites can't be read at all. Instead of regular fonts, there are symbol fonts. Below is only one example. It doesn't happen on every site, only some. I've tried everything on the support page for "web pages not loading properly" (or whatever it's called). Could it be a plug-in problem?

Yderligere systemdetaljer

Berørte websteder

https://www.richters.com/Web_store/display.cgi?page=./Html/delivery_details_form.html&cart_id=9793472.17465

Installerede plugins

  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Web Player version 1.4.0.233
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0

Yderligere information

I've run Disk Utility & reloaded affected pages, but no change.

Luk
finitarry 251 løsninger 3421 svar

One other thing: have you checked the font settings in Preferences > Content > Fonts & Colours > Advanced? Are the fonts set as Western? What happens if you change the default fonts? The order form uses a serif font, so what is your default serif font? I am using Times. Do things correct themselves if you uncheck "Allow pages to use their own fonts"?

One other thing: have you checked the font settings in Preferences > Content > Fonts & Colours > Advanced? Are the fonts set as Western? What happens if you change the default fonts? The order form uses a serif font, so what is your default serif font? I am using Times. Do things correct themselves if you uncheck "Allow pages to use their own fonts"?

Spørgsmålsstiller

Yes, I've checked those settings. I have Times as my default serif, too. I hadn't disallowed "pages to use their own fonts" before, but just did, and guess what? This page was then garbled! I re-checked to allow pages...

Yes, I've checked those settings. I have Times as my default serif, too. I hadn't disallowed "pages to use their own fonts" before, but just did, and guess what? This page was then garbled! I re-checked to allow pages...

Spørgsmålsstiller

PS: Thanks, finitarry, for your perseverance. As six other people have said they have the same problem, you'd think the folks at Firefox would do something! There are probably lots more. The only change I've made is updating to 6.0 and now 6.0.1. I also double-checked that plug-ins and add-ons are okay - even deleted a couple that I don't really use. I've loved Firefox & appreciate that it's a Mozilla app!

PS: Thanks, finitarry, for your perseverance. As six other people have said they have the same problem, you'd think the folks at Firefox would do something! There are probably lots more. The only change I've made is updating to 6.0 and now 6.0.1. I also double-checked that plug-ins and add-ons are okay - even deleted a couple that I don't really use. I've loved Firefox & appreciate that it's a Mozilla app!
Outtacontext 0 løsninger 3 svar

I'm having this problem too. Just on some sites, but more than one. I'm on a Mac OS 10.6.8 and Firefox 6. Never happened before.

Here's a pic of the strange font I get.

I'm having this problem too. Just on some sites, but more than one. I'm on a Mac OS 10.6.8 and Firefox 6. Never happened before. Here's a pic of the strange font I get.

Spørgsmålsstiller

Now 9 other people have the same problem! The strange font I get is a 'music' font.

Now 9 other people have the same problem! The strange font I get is a 'music' font.
finitarry 251 løsninger 3421 svar

Try starting Firefox in safe mode and see if the problem is still there. It might be an extension messing up things. http://kb.mozillazine.org/Safe_mode

Try starting Firefox in safe mode and see if the problem is still there. It might be an extension messing up things. http://kb.mozillazine.org/Safe_mode
cor-el
  • Top 10 Contributor
  • Moderator
17874 løsninger 161723 svar

You can do a check for corrupted fonts and other font issues:

You can do a check for corrupted fonts and other font issues: *http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts *http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Spørgsmålsstiller

I've already done everything that's been suggested so far, to no avail. Thanks anyway! (I've posted the problem on the Firefox Facebook page, too.)

I've already done everything that's been suggested so far, to no avail. Thanks anyway! (I've posted the problem on the Firefox Facebook page, too.)
johnhalldesign 0 løsninger 1 svar

Same problem, started right after I upgraded to 6. Random characters all over the place turn into black blobs. Its also happening in the dashboard interface to my Blogger blog, so I can't even see what I'm typing. Have had to switch to Safari, cause its pretty much unusable. 6.0.1 upgrade didn't help.

Same problem, started right after I upgraded to 6. Random characters all over the place turn into black blobs. Its also happening in the dashboard interface to my Blogger blog, so I can't even see what I'm typing. Have had to switch to Safari, cause its pretty much unusable. 6.0.1 upgrade didn't help.
finitarry 251 løsninger 3421 svar

I think it is time to try something more drastic.

I think it is time to try something more drastic. * http://kb.mozillazine.org/Standard_diagnostic_%28Firefox%29 * That would include making a new profile if nothing else works.

Ændret af finitarry den

raisinsawdust 0 løsninger 3 svar

Do like I am doing - switch to Chrome!

Do like I am doing - switch to Chrome!

Spørgsmålsstiller

Thanks again, finitarry, but I don't have any more time to mess around with this. I'll just stick with Safari until Firefox fixes this.

Thanks again, finitarry, but I don't have any more time to mess around with this. I'll just stick with Safari until Firefox fixes this.
cor-el
  • Top 10 Contributor
  • Moderator
17874 løsninger 161723 svar

You can try a font test to see if you can identify the font that is causing the problem.

You can try a font test to see if you can identify the font that is causing the problem. * http://browserspy.dk/fonts-flash.php?detail=1 Fonts Information - Detected via Flash
tricia2525 0 løsninger 1 svar

I'm having same problem - but only with firefox and only certain sites - not musical notes though more of a mad rock'n roll script but totally illegible.

I'm having same problem - but only with firefox and only certain sites - not musical notes though more of a mad rock'n roll script but totally illegible.
ralphglennobrien 0 løsninger 1 svar

I've had this same awful font substitution problem on my MacBook Pro running 10.6.8 with FF 6.0. Many bad URLs and not the whole page on a given URL will have the problem. I've even had crazy font substitutions re-reading a thread of gmails, where one message that I sent on some day showed up fine and another message that I sent the same day from the day computer showed up garbled by a strange font substitution.

If I copy the unreadable text and put it into BBedit, it's fine, so I know it's just a font substitution issue. It happens in no other applications on this Mac, including Safari and Chrome, so I've switched everything to Chrome and am doing fine. I wanted to support the Mozilla mission, but I've wasted too much time.

I've had this same awful font substitution problem on my MacBook Pro running 10.6.8 with FF 6.0. Many bad URLs and not the whole page on a given URL will have the problem. I've even had crazy font substitutions re-reading a thread of gmails, where one message that I sent on some day showed up fine and another message that I sent the same day from the day computer showed up garbled by a strange font substitution. If I copy the unreadable text and put it into BBedit, it's fine, so I know it's just a font substitution issue. It happens in no other applications on this Mac, including Safari and Chrome, so I've switched everything to Chrome and am doing fine. I wanted to support the Mozilla mission, but I've wasted too much time.

Spørgsmålsstiller

Agreed, ralphglennobrie!

Agreed, ralphglennobrie!
David McRitchie 320 løsninger 3092 svar

You might see if the solution in the following solves your problem, I guess there are only two settings for that variable true or false, but I don't understand it. I think the purpose is to eliminate or reduce fonts so that Firefox comes up faster but that is just a guess based on large number of fonts is something that does slow down startup.

@ Pywakket and janeisgreen (Owner)

The example web page was not visible in the original question which did include "Below is only one example." and there was no example in that original question. That is why I asked if a picture was intended to be included. The statement "some sites can't be read at all" that Pywakket seems to think covers the problem is not adequate for people to work with.

I asked a friend on a dual boot Mac to check this question on OS X and on Windows 7 same results. But he told me the HTML was bad on the page and that led me to the "More system details..." which is where that example link was hidden from view, so technically it is part of the original question but not a visible part.


I bookmarked the page in Cor-els reply for viewing installed fonts, but your problem is probably that other fonts are being substituted if the asked for font is not available.


You might try this bring up about:config from the Location Bar

filter: fonts
just look at the variables that contain fonts in their name and ignore those beginning with "extensions." or "print." reset anything else to default after making a note of what you change. Then use File > Exit to close Firefox properly, Then restart Firefox.

If it works tell us what you changed to fix your problem.

You might see if the solution in the following solves your problem, I guess there are only two settings for that variable true or false, but I don't understand it. I think the purpose is to eliminate or reduce fonts so that Firefox comes up faster but that is just a guess based on large number of fonts is something that does slow down startup. *https://support.mozilla.com/en-US/questions/863157?page=2#answer-237917 @ Pywakket and janeisgreen (Owner) :The example web page was not visible in the original question which did include "Below is only one example." and there was no example in that original question. That is why I asked if a picture was intended to be included. The statement "some sites can't be read at all" that Pywakket seems to think covers the problem is not adequate for people to work with. I asked a friend on a dual boot Mac to check this question on OS X and on Windows 7 same results. But he told me the HTML was bad on the page and that led me to the "More system details..." which is where that example link was hidden from view, so technically it is part of the original question but not a visible part. ---- I bookmarked the page in Cor-els reply for viewing installed fonts, but your problem is probably that other fonts are being substituted if the asked for font is not available. ---- You might try this bring up '''about:config''' from the Location Bar :filter: fonts :just look at the variables that contain '''fonts''' in their name and ignore those beginning with "extensions." or "print." reset anything else to default after making a note of what you change. Then use File > Exit to close Firefox properly, Then restart Firefox. If it works tell us what you changed to fix your problem.

Ændret af David McRitchie den

Outtacontext 0 løsninger 3 svar

I looked at my about:config file and all the appropriate settings are set to "default." So that didn't help. :-(

I looked at my about:config file and all the appropriate settings are set to "default." So that didn't help. :-(
David McRitchie 320 løsninger 3092 svar

@ Outtacontext

Try setting this one to non default value --
gfx.downloadable_fonts.sanitize to false

That might be what that solved question was saying, can't figure out way something marked as solved has the only showing of Persian characters in the replies.

After making the change, restart Firefox with "Ctrl+Shift+R" if you installed the "Restartless Restart " extension. You won't even have to take Firefox down to install that extension.

@ Outtacontext :Try setting this one to non default value -- :'''gfx.downloadable_fonts.sanitize''' to '''false''' That might be what that solved question was saying, can't figure out way something marked as solved has the only showing of Persian characters in the replies. After making the change, restart Firefox with "Ctrl+Shift+R" if you installed the "[https://addons.mozilla.org/firefox/addon/restartless-restart/ Restartless Restart] " extension. You won't even have to take Firefox down to install that extension.
Hamid Moazzami 14 løsninger 86 svar

Oh, in that topic (mine) someone came up with a Persian solution. So I translated it to English (And I couldn't choose my own answer as a solution, that's why. Don't blame me!). You can see the translated solution there... (Why not suggesting the translated post? Here it is. )

dmcritchie is right. It is to change the value of gfx.downloadable_fonts.sanitize to false.

Oh, in that topic (mine) someone came up with a Persian solution. So I translated it to English (And I couldn't choose my own answer as a solution, that's why. Don't blame me!). You can see the translated solution there... (Why not suggesting the translated post? [https://support.mozilla.com/en-US/questions/863157?page=2#answer-237965 Here it is.] ) '''dmcritchie''' is right. It is to change the value of '''gfx.downloadable_fonts.sanitize''' to '''false'''.

Ændret af Hamid Moazzami den