Search Support

I want to search a few add ons that compatible with Mozilla Firefox version 2.0.

more options

want to search a few add ons that compatible with Mozilla Firefox version 2.0. why can I no longer search it with this URL https://addons.mozilla.org/en-US/firefox/advancedsearh,

pls give me a clue, so I can search the add ons that compatible with my earlier firefox

Regards Goerchka

All Replies (2)

more options

Firefox 2 hasn't been supported in a couple of years now, and it has been removed from the "search" page.
https://addons.mozilla.org/en-US/firefox/search/
Left-side of that page, under Compatible with. I you select All versions you will see the add-ons that are compatible with Firefox 2.

more options

Correct the spelling of search on your link to

https://addons.mozilla.org/en-US/firefox/advancedsearch
and it would appear that the search would work, use the little dropdown underneath the big green arrow to actually pull up the advanced search you asked for, and it appears to work, I didn't actually bring up any of the results.