Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Version 89 ????? Why does it suck so bad ????

  • 12 svar
  • 10 har dette problem
  • 96 visninger
  • Seneste svar af trev

more options

Anyone crack the method to revert back to Version 88? Version 89 is horrible

Alle svar (12)

more options

i hate this new update.

Nyttig?

more options

Hi johnmase68, old versions of Firefox are always available, but not recommended. There's more info in this article: Install an older version of Firefox.

Since "horrible" isn't very specific, could you list out the parts of the UI you would like to modify? For example:

  • the tab bar redesign => change floating buttons back to connected tabs
  • the theme => restore dark background behind tabs
  • spacing between menu items => reduce to previous spacing
  • wireframe graphics style => change the artwork to...
  • something else

Then we'll be in a better position to suggest workarounds.

Nyttig?

more options

-spacing between menu items => reduce to previous spacing -the tab bar redesign => change floating buttons back to connected tabs -add back "about" where I could remove updates -separate security fixes from changes to how the page looks -remove extra spacing from favorites lists -reset typeface size to something less shocking -make "workarounds" one step in options menu (we're not all IT whizzes) -IF IT AIN'T BROKE, DON'T FIX IT - and it wasn't broke (except "hiding popups - FAIL)

Nyttig?

more options

For these three, I have temporary workarounds for you:

-spacing between menu items => reduce to previous spacing -the tab bar redesign => change floating buttons back to connected tabs -remove extra spacing from favorites lists


Menu item spacing: I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix

For testing purposes, there is a preference to switch between new style and old style menus. It helps with the spacing, but might be a tad bit glitchy:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window.

Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

I'm sure we'll refine that during the course of the month so when the temporary preference is removed, it will be airtight.


Tab styling: I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix

For testing purposes, there is a preference to switch the tab bar and address bar between new style and old style. This is not expected to continue in Firefox 90, but maybe you want to use it for now.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

Longer Term Community Workaround

This involves setting up a userChrome.css file. I have a rules builder that will get more features throughout the month. By the time the above preference is removed, it should be mature. If you want to take a sneak peek now:


For this one, I don't recall ever having this:

-add back "about" where I could remove updates

What do you mean by shocking -- too large? too small?

-reset typeface size to something less shocking

Nyttig?

more options

This is something new today in version 88: Oh, duh. MS Snip & Paste doesn't work here. I stopped using the FF version because it doesn't work well across all platforms. Anyway, there is now an extra "idiot" line at top of screen that tells me where I am, and now contain minimize/maximize/close tab.

So the mess at top of screen now has three lines: 1- Version 89? etc., minimize maximize close tab 2- bar showing the two tabs I have open 3- menu bar, AGAIN telling me where I am (https/support/etc.), my search box etc.

I do not need that extra bar at the top! I hate screen clutter, and this is redundant.

I see why the place I could formerly remove updates is gone. It was under Help / About FF.

By SHOCKING I mean that the entire presentation on the screen has changed. I'm still set to Arial 16 pt, but the type is slightly smaller and there is too much empty space added everywhere. This requires more scrolling, and, as someone else mentioned, my Favorites list is spaced too far apart in height. It needs to be more compact. If I need to see something larger, I can zoom it. The extra space between lines does not make readability any better - it makes it worse. Again, more scrolling.

My first post last night disappeared. I have loved FF from the day I switched to it - until now.

Nyttig?

more options

delete

Ændret af ch5richards den

Nyttig?

more options

fidservant said

Anyway, there is now an extra "idiot" line at top of screen that tells me where I am, and now contain minimize/maximize/close tab. So the mess at top of screen now has three lines: 1- Version 89? etc., minimize maximize close tab 2- bar showing the two tabs I have open 3- menu bar, AGAIN telling me where I am (https/support/etc.), my search box etc.

Check the Customize panel, lower left. If the box is checked for Title Bar, uncheck it.

Customize Firefox controls, buttons and toolbars

Nyttig?

more options

jscher2000 THANK YOU so much for this little tidbit! Whew, that is a relief. :-)

Nyttig?

more options

I don't know why I can't see let alone update my previous reply but @fidservant I found a fix in the about:config file that reverts the look and spacing of proton(FF89) to that of photon(FF88) - see attached.

WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed.

If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue.

Ændret af Chris Ilias den

Nyttig?

more options

My issue is more functional - tabs are not loading at all. If I click on Gmail, it opens fine.. then now I click on a link within it.. it's loading.. loading.. blames my internet connection. Another example is on Facebook, where it pops up but then it doesn't refresh the Notifications boxes or anything.

I'm searching on how to fix this and can't figure it out. In the meantime, I'm using alternative browsers to do my work, but I realize how well I have Firefox configured and don't want to switch. Please advise on how to fix this in 89 or be able to revert to 88.

Thanks!

Nyttig?

more options

AJD10 said

My issue is more functional - tabs are not loading at all. If I click on Gmail, it opens fine.. then now I click on a link within it.. it's loading.. loading.. blames my internet connection. Another example is on Facebook, where it pops up but then it doesn't refresh the Notifications boxes or anything.

Could you start a new question for this:

https://support.mozilla.org/questions/new/desktop/form

Also, you can try "the usual":

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe/Troubleshoot Mode: In this mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Nyttig?

more options

Version 89 ????? Why does it suck so bad ???? , how long have you got ?

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.