Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DuckDuckGo search entry flips into address bar after upgrade to 89.0

  • 5 svar
  • 3 har dette problem
  • 19 visninger
  • Seneste svar af fasteredie

more options

DuckDuckGo is my default search engine. When I open a new tab a DuckDuckGo search box comes up as part of the new tab layout.

After I upgraded to 89.0 I find that if I enter text into the DuckDuckGo search box the text automatically switches into the address bar and looks through the URL history instead of being entered into the DuckDuckGo search box. I can't use the DuckDuckGo search box at all, I can only choose a search option that (sometimes) comes up in the address bar instead.

Is this supposed to work like this? It's very inefficient.

Alle svar (5)

more options

BTW - I have tried unchecking the box in settings for "Show search suggestions in address bar results" and it has no impact. It's not specific to DuckDuckGo either, it affects any search engine.

Ændret af mail1074 den

Nyttig?

more options

This looks like the same issue as https://support.mozilla.org/en-US/questions/1338067.

Let's hope the Firefox UI team will take a hint that this is a major issue.

Nyttig?

more options

I believe it was done so firefox could track what I search for, and the point of having duckduckgo is not to be tracked. I have posted the question on how to fix this also.

Nyttig?

more options

I read the solution reply in the link that the wonderful Pete Batard included. However... Where is this wonderful about:config place? I've had this issue for several months. Soon as I type anything or paste it comes up in the URL bar. I am not tech savvy at all, I tried to look for this beautiful about:config place but can't find it. Really sorry if this is a goofball question for you guys, but here is a beginner in action. Thank you!

Nyttig?

more options

fasteredie said

I read the solution reply in the link that the wonderful Pete Batard included. However... Where is this wonderful about:config place? I've had this issue for several months. Soon as I type anything or paste it comes up in the URL bar. I am not tech savvy at all, I tried to look for this beautiful about:config place but can't find it. Really sorry if this is a goofball question for you guys, but here is a beginner in action. Thank you!

fasteredie said

Where is this wonderful about:config place? I've had this issue for several months. Soon as I type anything or paste it comes up in the URL bar. I am not tech savvy at all, I tried to look for this beautiful about:config place but can't find it. Really sorry if this is a goofball question for you guys, but here is a beginner in action. Thank you!

OK, I figured it out.

1-While in Firefox, you enter into the address bar: about:config click go or return... and 2-you get a window with a warning:

Proceed with Caution Changing advanced configuration preferences can impact Firefox performance or security. Warn me when I attempt to access these preferences

3-You accept or agree by clicking the box.

4-Then, into a field that becomes available, you paste: browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar

5-Magically, a thing appears with that text in BOLD and the word "true" behind it. To the right there's a symbol that I guess represents ON/OFF or TRUE/FALSE switch or something of the kind.

!-You click that, and now the word "true" replaces "false"

Then you open another new tab with the DuckDuckGo search bar like you've been used to. Search for what you're searching for (I was looking for my local post office hours of operation because I'm a middle-aged guy and that's what we do). And BAM!!! The sweet smell of success.

This feels good. I guess I'm a tech wizard now. Putting that on my resume! Good luck.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.