X
Tryk her for at gå til webstedets mobilversion.

Supportforum

custom search settings

Skrevet

DDG has been set as my default engine. This (v.63) FF setting is reliable and consistent. i.e. it sticks.

Alas, changing the 'Privacy and Security' Settings in FF wipes out the default DDG Search settings. (and no, this never used to happen).

For example, clicking on DDG's Search Results no longer open in a new tab and all the DDG Search settings are reset to their default. This is consistent, repeatable and happens after customizing Cookies and Trackers in FF Settings. (I have no idea about any other Search Engines)

Yes, I deleted all the .sqlite files and .js files and re-installed FF. Generally I 'pulled my hair out' trying to find the cause. Even add-on offed Privacy Badger, uMatrix & uBlockOrigin (to no avail.)

I don't like to be bald and hope FF will buy me a wig for my travails.

Solution? Keep FF 'Privacy and Security' Settings at their defaults....

Hope this helps someone else as it took me a few weeks... Devs? Hah!

DDG has been set as my default engine. This (v.63) FF setting is reliable and consistent. i.e. it sticks. Alas, changing the 'Privacy and Security' Settings in FF wipes out the default DDG Search settings. (and no, this never used to happen). For example, clicking on DDG's Search Results no longer open in a new tab and all the DDG Search settings are reset to their default. This is consistent, repeatable and happens after customizing Cookies and Trackers in FF Settings. (I have no idea about any other Search Engines) Yes, I deleted all the .sqlite files and .js files and re-installed FF. Generally I 'pulled my hair out' trying to find the cause. Even add-on offed Privacy Badger, uMatrix & uBlockOrigin (to no avail.) I don't like to be bald and hope FF will buy me a wig for my travails. Solution? Keep FF 'Privacy and Security' Settings at their defaults.... Hope this helps someone else as it took me a few weeks... Devs? Hah!

Ændret af Northumbrian den

Valgt løsning

jscher2000 said

Hi Northumbrian, what settings changes were you making? Firefox 63 now has multiple settings for third-party cookies, which I don't think would affect DDG, but I haven't tried them myself. Did you try adding this to the Exceptions list in the Cookies and Site Data section (i.e., paste and click Allow): https://duckduckgo.com

There are some other settings that will override cookie exceptions

Yo thanks..... certainly adding http(s)://duckduckgo to cookie exceptions is a way to go.

me? I'll just keep FF at her defaults and use my add-ons.

Thank you for your fast 'n accurate response. Appreciated.

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Installerede plugins

uMatrix uBlock Origin Privacy Badger.

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Yderligere information

Luk
jscher2000
  • Top 10 Contributor
8894 løsninger 72782 svar

Nyttigt svar

Hi Northumbrian, what settings changes were you making?

Firefox 63 now has multiple settings for third-party cookies, which I don't think would affect DDG, but I haven't tried them myself.

Did you try adding this to the Exceptions list in the Cookies and Site Data section (i.e., paste and click Allow):

https://duckduckgo.com

(Note that Firefox only understands that exact format of protocol + //host name)


There are some other settings that will override cookie exceptions so that even sites that are allowed to set persistent cookies will not have them. These include:

(A) Automatic Private Browsing

This is invoked in the History section by setting either:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + a check mark for "Always use private browsing mode"

(B) Clearing History when Firefox closes

This is an option in the History section if you have the "Use custom settings for history" setting. Either:

  • Do not check the box for "Clear history when Firefox closes"
  • If you check the box for "Clear history when Firefox closes" then click the "Settings" button to the right of it and make sure Cookies are NOT set to be cleared

I don't know if any of those were settings you were trying to use. If you need alternatives, let us know what you would like to accomplish and we can see whether we know of a way to do it.

Hi Northumbrian, what settings changes were you making? Firefox 63 now has multiple settings for third-party cookies, which I don't think would affect DDG, but I haven't tried them myself. Did you try adding this to the Exceptions list in the Cookies and Site Data section (i.e., paste and click Allow): https://duckduckgo.com (Note that Firefox only understands that exact format of protocol + //host name) ---- There are some other settings that will override cookie exceptions so that even sites that are allowed to set persistent cookies will not have them. These include: (A) Automatic Private Browsing This is invoked in the History section by setting either: * Firefox will: Never remember history * Firefox will: Use custom settings for history + a check mark for "Always use private browsing mode" (B) Clearing History when Firefox closes This is an option in the History section if you have the "Use custom settings for history" setting. Either: * Do not check the box for "Clear history when Firefox closes" * If you check the box for "Clear history when Firefox closes" then click the "Settings" button to the right of it and make sure Cookies are NOT set to be cleared I don't know if any of those were settings you were trying to use. If you need alternatives, let us know what you would like to accomplish and we can see whether we know of a way to do it.

Valgt løsning

jscher2000 said

Hi Northumbrian, what settings changes were you making? Firefox 63 now has multiple settings for third-party cookies, which I don't think would affect DDG, but I haven't tried them myself. Did you try adding this to the Exceptions list in the Cookies and Site Data section (i.e., paste and click Allow): https://duckduckgo.com

There are some other settings that will override cookie exceptions

Yo thanks..... certainly adding http(s)://duckduckgo to cookie exceptions is a way to go.

me? I'll just keep FF at her defaults and use my add-ons.

Thank you for your fast 'n accurate response. Appreciated.

''jscher2000 [[#answer-1167213|said]]'' <blockquote> Hi Northumbrian, what settings changes were you making? Firefox 63 now has multiple settings for third-party cookies, which I don't think would affect DDG, but I haven't tried them myself. Did you try adding this to the Exceptions list in the Cookies and Site Data section (i.e., paste and click Allow): https://duckduckgo.com ---- ''There are some other settings that will override cookie exceptions'' </blockquote> Yo thanks..... certainly adding http(s)://duckduckgo to cookie exceptions is a way to go. me? I'll just keep FF at her defaults and use my add-ons. Thank you for your fast 'n accurate response. Appreciated.

Ændret af Northumbrian den