X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Formatting problem when posting on overunity.com only when using Firefox.

Skrevet

When posting a message on overunity.com the formatting is not working properly. When I hit the enter key twice to add a space between lines I don't get the space added unless I hit the enter key a third time. Or if I want to add something on the next line If I hit the enter key one time, whatever I type still ends up on the same line. Everything looks normal until I go to do a preview of my post. The preview then shows that apparently the first time I hit the enter key I do NOT get the normal response of a carriage return that you would expect.

I have tried both Opera and Chrome with overunity.com and they work fine with no problem. Also Firefox seems to work fine on other forums I belong to and post on. It seems very strange that only the combination of overunity.com and Firefox have this problem. I have also been in contact with two other people that also use Firefox and they also have the same problem with posting on overunity.com. As I post there fairly often I would really like to see a solution to this problem. Or a way to work around it if possible. I can get my posts to look okay as long as I remember to add an extra hit of the enter key when posting but I don't consider that to be a good solution.

Thanks for any help someone can give, Carroll

When posting a message on overunity.com the formatting is not working properly. When I hit the enter key twice to add a space between lines I don't get the space added unless I hit the enter key a third time. Or if I want to add something on the next line If I hit the enter key one time, whatever I type still ends up on the same line. Everything looks normal until I go to do a preview of my post. The preview then shows that apparently the first time I hit the enter key I do NOT get the normal response of a carriage return that you would expect. I have tried both Opera and Chrome with overunity.com and they work fine with no problem. Also Firefox seems to work fine on other forums I belong to and post on. It seems very strange that only the combination of overunity.com and Firefox have this problem. I have also been in contact with two other people that also use Firefox and they also have the same problem with posting on overunity.com. As I post there fairly often I would really like to see a solution to this problem. Or a way to work around it if possible. I can get my posts to look okay as long as I remember to add an extra hit of the enter key when posting but I don't consider that to be a good solution. Thanks for any help someone can give, Carroll
Citér

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 29.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

Yderligere information

Luk
Pkshadow
  • Top 10 Contributor
831 løsninger 10392 svar

Hi, please try : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, please try : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?
Fandt du dette nyttigt?
Citér
FredMcD
  • Top 10 Contributor
3643 løsninger 49948 svar

Some websites use special formatting codes. Check with its support.

Some websites use special formatting codes. Check with its support.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

I tried "safe Mode" and that did not solve the problem. I have not gotten any answer from the forum support yet, but Opera, Chrome and IE all work fine on that forum. I am running Windows 7 on my laptop and desktop and Firefox has this problem on both of them. I have been in contact with 3 other people that have the same problem only with Firefox and that forum. One of them is running Fedora and Firefox 60 and also has the same problem with the formatting only on that forum.

The problem appears to have something to do with that forum software not recognizing the first carriage return but then recognizing the ones after that. If I hit the enter key once for a carriage return it shows a normal response in the text window I am typing in, but when I preview my post it shows the text as if I had not hit the enter key for a carriage return. In other words the text after the carriage return is still on the same line as the text before the carriage return, but only in the preview window and of course in the final post if I post it without correcting the missing carriage returns.

I believe the forum software is called SMF 2.0.15 I am not a programmer or computer guru so I might be wrong about that.

Thanks FredMcD. I just edited this post and that corrected the lack of word wrap in this post.

Carroll

I tried "safe Mode" and that did not solve the problem. I have not gotten any answer from the forum support yet, but Opera, Chrome and IE all work fine on that forum. I am running Windows 7 on my laptop and desktop and Firefox has this problem on both of them. I have been in contact with 3 other people that have the same problem only with Firefox and that forum. One of them is running Fedora and Firefox 60 and also has the same problem with the formatting only on that forum. The problem appears to have something to do with that forum software not recognizing the first carriage return but then recognizing the ones after that. If I hit the enter key once for a carriage return it shows a normal response in the text window I am typing in, but when I preview my post it shows the text as if I had not hit the enter key for a carriage return. In other words the text after the carriage return is still on the same line as the text before the carriage return, but only in the preview window and of course in the final post if I post it without correcting the missing carriage returns. I believe the forum software is called SMF 2.0.15 I am not a programmer or computer guru so I might be wrong about that. Thanks FredMcD. I just edited this post and that corrected the lack of word wrap in this post. Carroll

Ændret af citfta den

Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

I just saw my above reply now has a strange paragraph in it where the word wrap appears to not have worked. I have no idea how that happened. More strange behavior.

Carroll

I just saw my above reply now has a strange paragraph in it where the word wrap appears to not have worked. I have no idea how that happened. More strange behavior. Carroll
Fandt du dette nyttigt?
Citér
FredMcD
  • Top 10 Contributor
3643 løsninger 49948 svar

Starting a sentence with a space is a special edit command on this forum.

Example;

To install Firefox on a Windows XP system, because of Windows restrictions, the user will have to download Firefox 43.0.1 and then update to the current releas
Starting a sentence with a space is a special edit command on this forum. Example; To install Firefox on a Windows XP system, because of Windows restrictions, the user will have to download Firefox 43.0.1 and then update to the current releas
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Hi FredMcD,

Thanks for your reply, Your explanation for what happened to my reply on this forum was very helpful but I still would like to know how to get my replies on overunity.com to format like they should.

Thanks, Carroll

Hi FredMcD, Thanks for your reply, Your explanation for what happened to my reply on this forum was very helpful but I still would like to know how to get my replies on overunity.com to format like they should. Thanks, Carroll
Fandt du dette nyttigt?
Citér
FredMcD
  • Top 10 Contributor
3643 løsninger 49948 svar

FredMcD said

Some websites use special formatting codes. Check with its support.
''FredMcD [[#answer-1115093|said]]'' <blockquote> Some websites use special formatting codes. Check with its support. </blockquote>
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
16321 løsninger 147278 svar

Could be a problem with how the website interprets white space.

I assume that this is a rich text editor and not a plain text editor like this forum uses?

Does using Shift+Enter produce any code?

Could be a problem with how the website interprets white space. I assume that this is a rich text editor and not a plain text editor like this forum uses? Does using Shift+Enter produce any code?
Fandt du dette nyttigt?
Citér
Pj 1 løsninger 51 svar

cor-el said

Could be a problem with how the website interprets white space. I assume that this is a rich text editor and not a plain text editor like this forum uses?

I noticed this also on www.AVSforum.com since FF 60.xx. I made a change in about:Config to 'correct' it. It's just FireFox users reporting the 'problem'.


-Pj
''cor-el [[#answer-1115556|said]]'' <blockquote> Could be a problem with how the website interprets white space. I assume that this is a rich text editor and not a plain text editor like this forum uses? </blockquote> I noticed this also on www.AVSforum.com since FF 60.xx. I made a change in about:Config to 'correct' it. It's just FireFox users reporting the 'problem'. -Pj
Fandt du dette nyttigt?
Citér
FredMcD
  • Top 10 Contributor
3643 løsninger 49948 svar

Pj said

I made a change in about:Config to 'correct' it

What change did you make?

''Pj [[#answer-1122085|said]]'' <blockquote> I made a change in about:Config to 'correct' it </blockquote> What change did you make?
Fandt du dette nyttigt?
Citér
jscher2000
  • Top 10 Contributor
7361 løsninger 59929 svar

Nyttigt svar

Well, Shift+Enter is an option on many editors, but it is an extra finger...

Could you take a look at this change made in Firefox 60:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste newline and pause while the list is filtered

(3) Double-click the editor.use_div_for_default_newlines preference to switch the value from true to false (was false in Firefox 57-59)

Does that have any effect?


This change was made for compatibility with Chrome, but if sites have scripts that handle Firefox and Chrome differently, then those sites will have a broken behavior in Firefox with this change. The following article is for sites that need to adjust to the new behavior:

https://www.fxsitecompat.com/en-CA/docs/2018/rich-text-editor-s-newline-behaviour-has-been-changed-now-generates-div-instead-of-br/

Well, Shift+Enter is an option on many editors, but it is an extra finger... Could you take a look at this change made in Firefox 60: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''newline''' and pause while the list is filtered (3) Double-click the '''editor.use_div_for_default_newlines''' preference to switch the value from true to false (was false in Firefox 57-59) Does that have any effect? ---- This change was made for compatibility with Chrome, but if sites have scripts that handle Firefox and Chrome differently, then those sites will have a broken behavior in Firefox with this change. The following article is for sites that need to adjust to the new behavior: https://www.fxsitecompat.com/en-CA/docs/2018/rich-text-editor-s-newline-behaviour-has-been-changed-now-generates-div-instead-of-br/
Fandt du dette nyttigt? 1
Citér
jscher2000
  • Top 10 Contributor
7361 løsninger 59929 svar

Pj said

I noticed this also on www.AVSforum.com since FF 60.xx.

Yes, this issue with old versions of the vBulletin software have popped up in two earlier threads here:

Seems quite a few sites have not updated their vBulletin in 6+ years.

''Pj [[#answer-1122085|said]]'' <blockquote> I noticed this also on www.AVSforum.com since FF 60.xx. </blockquote> Yes, this issue with old versions of the vBulletin software have popped up in two earlier threads here: * [https://support.mozilla.org/questions/1200370 Why does my cursor skip down 2 lines when I hit 'enter' ?] * [https://support.mozilla.org/questions/1220274 Extra blank line added when posting on a VBulletin forum. Only in Firefox] Seems quite a few sites have not updated their vBulletin in 6+ years.
Fandt du dette nyttigt?
Citér
Pj 1 løsninger 51 svar

FredMcD said

Pj said
I made a change in about:Config to 'correct' it

What change did you make?


I entered About:Config and copy-n-pasted

 editor.use_div_for_default_newlines 

in the Search Box and double-clicked on it to change it to False.

-Pj 
( AVSforum Thread Here.)
''FredMcD [[#answer-1122087|said]]'' <blockquote> ''Pj [[#answer-1122085|said]]'' <blockquote> I made a change in about:Config to 'correct' it </blockquote> What change did you make? </blockquote> I entered '''About:Config''' and copy-n-pasted '''editor.use_div_for_default_newlines''' in the Search Box and double-clicked on it to change it to '''False'''. -Pj ( [http://www.avsforum.com/forum/43-forum-operations-center/2978674-extra-blank-line-s-crlf-new-posts.html#post56254292 AVSforum Thread Here].)
Fandt du dette nyttigt?
Citér
FredMcD
  • Top 10 Contributor
3643 løsninger 49948 svar

Pj said

editor.use_div_for_default_newlines

Thank you Pj

''Pj [[#answer-1122144|said]]'' <blockquote> '''editor.use_div_for_default_newlines''' </blockquote> Thank you''' Pj'''
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.