Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox starting up freezes computer and uses way too much CPU

  • 2 svar
  • 2 har dette problem
  • 17 visninger
  • Seneste svar af Daniel554

more options

Hello everyone!

I have been experiencing some problems recently with Firefox:

1. Upon startup of the browser, my computer completely freezes for about half a second and then it's all fine. It's just when opening the browser, even after a full restart of my computer.

I have opened Firefox in safe mode (Holding Shift when opening and clicking "Start Safe Mode" - the browser still freezes my computer but does it later than if it wasn't safe mode. So instead of it happening the moment google loads normally, it happens roughly 1-2 seconds after it loads google.


2. Firefox has way too much CPU usage for no reason.

This one as well is baffling me. I have a screenshot of Firefox when I just open it and let it sit with Kongregate.com and Google.com open for 10 minutes. https://i.imgur.com/zfkHdnt.png

When I start up Firefox in safe mode, it's fine! I have low RAM usage and CPU stays around 2% usage. But I can't have that the entire time and I'm hoping there's something you all can help with.

When I visit other sites like Imgur, Yahoo, or Youtube, Firefox freezes or slows to a crawl. But it's weird, you're able to click on each tab, but the actual top part of the page is frozen such that you can't see which tab you're on and eventually it stops you being able to go through each tab and have to End Process through task manager.

The add-ons I have enabled: Adblock Plus / Ghostery / HTTPS Everywhere / LastPass / Low Quality Flash / NoScript / SQLite Manager / Stylish / VTzilla / XMarks

I'd say flash, but that's a plugin and doesn't get disabled on Safe Mode. I have tried disabling each item separately and none of them individually are causing the problem. Safe Mode disabling all of them fixes it, but what's the point of a browser without add-ons?

I have tried these things from other sites: browser.cache.memory.enable - Boolean True browser.cache.memory.capacity - set to 24576 config.trim_on_minimize - set to True All doing nothing to fix the problem of course.

Browser: FireFox 50.1.0 - I'm not able to update past this version as it breaks everything I play. Any flash games become jagged and unable to be played normally. I've tested each version up to 56.0.2 and none of them are as stable as 50.1.0 for flash games.

System Specs: Windows 10 Pro / 32 GB RAM / Intel i7-7700HQ 2.8GHz CPU [quad core dual thread] / 256 GB SATA SSD

The browser never crashes so I don't have a log to post for this.

Thank you for all your help!

Ændret af Daniel554 den

Alle svar (2)

more options

1st I have no idea which one you are using :

adapterDescription: Intel(R) HD Graphics 630

adapterDescription2: NVIDIA GeForce GTX 1070 Would think this one

Since I see this then you must have in Bios Intel turned on. Turn it off driverDate: 6-16-2017 driverDate2: 5-1-2017 Keep Ibm updated, google for the drivers : search term : Intel(R) HD Graphics 630 and save them as never know when other card will toast out and if do not update and save will have out dated drivers and no support.

I see a bunch of Video Card Errors which cause a wide range of errors and crashes This is why you are having errors when update past. These are new 2017 Drivers I see. Or what the info tells me.........that's sent. Dual Core can you get to 52 the ESR Version, https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018. Have you tried ?

No idea why using so much cpu other than it is not drawing from your Video card so It's the video card as far as I can tell.

Please let us know if this solved your issue or if need further assistance.

more options

Thanks for the quick reply!

Pkshadow said

1st I have no idea which one you are using : adapterDescription: Intel(R) HD Graphics 630 adapterDescription2: NVIDIA GeForce GTX 1070 Would think this one Since I see this then you must have in Bios Intel turned on. Turn it off driverDate: 6-16-2017 driverDate2: 5-1-2017 Keep Ibm updated, google for the drivers : search term : Intel(R) HD Graphics 630 and save them as never know when other card will toast out and if do not update and save will have out dated drivers and no support.

I'm on a laptop and use the Intel Graphics HD 630 by default, if I had the nvidia card enabled by default my laptop would be running hot pretty much all the time.

I've updated both of my cards to their most recent versions: Intel Graphics HD 630 - 15.60.0.4849 [11/7/2017] Nvidia GTX 1070 - 388.31 [11/15/2017]

Neither has changed what firefox is doing. I never had this problem on my previous computer and this only started about a 3 weeks ago.

Pkshadow said

Dual Core can you get to 52 the ESR Version, https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018. Have you tried ?

I have not tried ESR versions, just the release versions. What differences do they give in ESR versus Release?