Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I disable autofill so it does NOT autofill the address bar, the search bar or anything else?

  • 7 svar
  • 1 har dette problem
  • 1 visning
  • Seneste svar af CallyCat

more options

I found instructions here: https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms

Here's what it says:

"If you don't want Firefox to remember what you've entered into form fields, you can turn off the auto form fill feature:

   Click the menu button New Fx Menu and choose Preferences.
   Select the Privacy panel.
   In the drop-down menu next to Firefox will:, choose Use custom settings for history.
   Remove the check mark next to Remember search and form history.
   Close the about:preferences page. Any changes you've made will automatically be saved. 

Disabling form history also prevents Firefox from storing search history for the Search bar in the Navigation Toolbar."

Unfortunately, v.48 doesn't have "remember search and form history."

So, I unchecked the three options under Location Bar. All that did was to stop the autofilling in the address bar. Then I opened up the clear history settings & unchecked everything but "form & search history." I rechecked 'clear history when ff closes.'

But any time I start typing in a search, it still not only tries to autofill, but it also does it right over where I'm typing so I cannot see what I'm typing!

Oh, and BTW, when the help says to Click the menu button (3 bar button) I don't get preferences like it says I will. (And I never have in any version.) Instead, I get what you see in the attached screen shot. So I go to firefox at the top left corner and choose preferences.

Vedhæftede skærmbilleder

Alle svar (7)

more options

Do the following:

  1. Enter about:config in the Firefox address bar
  2. Bypass the warning, if prompted
  3. Locate the browser.urlbar.autocomplete.enabled boolean
  4. Change the value to false

This should give you the behavior that you are looking for.

Note: You may need to restart Firefox for the changes to take effect.
more options

Ok, I just found the search & form history, but not where the instructions said it would be. Apparently "preferences" are different depending on where you access them. Which, to me, makes no sense whatsoever.  :-/ So, I guess my problem is solved... at least for the moment.

But I'd still like to know whty my 3 bar menu doesn't offer preferences, and why it's cut off. As a matter of fact everything in v. 48 is cut off and doesn't work right. Any drop down options now can't be clicked on. I have to hover the cursor over the option (which is cut in half) and use my arrow keys to select and then hit the enter key. Can't select w/the mouse any more. What a pain in the butt!

more options

Thank you, Wesley. We must have been typing at the same time.  :-)

Would you by any chance happen to know how I can get my tabs to populate before I click on them?

more options

CallyCat said

Apparently "preferences" are different depending on where you access them. Which, to me, makes no sense whatsoever.  :-/

The Firefox options page is intended for basic users. The about:config contains more advanced settings and virtually full control over Firefox. That is intended for more advanced users. That is why we hide some settings within the about:config page.

CallyCat said

But I'd still like to know whty my 3 bar menu doesn't offer preferences, and why it's cut off. As a matter of fact everything in v. 48 is cut off and doesn't work right. Any drop down options now can't be clicked on. I have to hover the cursor over the option (which is cut in half) and use my arrow keys to select and then hit the enter key. Can't select w/the mouse any more. What a pain in the butt!

That's not normal Firefox behavior. The main menu should contain a gear icon that says Options. You may need to customize the Firefox user interface in order to see this button.

If you are having issues with the Firefox display, please try restoring the Firefox user interface layout, as described in the article linked in the paragraph above. If the issue continues, try running Firefox in Safe Mode to see if the issue continues in that mode.

CallyCat said

Would you by any chance happen to know how I can get my tabs to populate before I click on them?

I am unsure what you asking. Can you please describe this issue/question in more detail? Thanks.

more options

Thanks, Wesley.

I only do the about:config in firefox if someone in the forum suggests it. I get that the about:config would be different than the basic stuff on the FF toolbar, but why would the the 3 bar, the gear (which either just showed up in the newest update or I just never noticed it before) and the preference options be different? I don't think the menu bar has ever shown preferences, at least not since I've had a mac (almost 2 yrs). I'm a DOS baby so using a mac is still driving me nuts, lol. What I've done w/FF is to always click on "firefox" in the upper left corner & select preferences. Every time they update, they take more options away.

I will read the links you provided sometime this w/e & let you know.

I wasn't having any issues with firefox display until it arbitrarily upgraded itself w/o my permission to v. 48. And, I just noticed it apparently updated itself tonight to 48.0.2 while I was changing some other settings & closing & reopening FF.  :-(( This is despite the fact that I have the updates turned off! (I just checked to be sure it was still turned off and it is.) I'm seriously thinking about reverting back to v.45.


To answer your last question, there used to be an option in preferences to uncheck "Don't load tabs until selected." Now there isn't even a tabs preferences section. (I guess I'll have to look for an add-on.) What happens is that I always have several tabs open and all of them, except the one I'm on, apparently close out to a blank page until I click on each tab and then I have to wait for it to open. (Just one more annoying thing about v.48) I would like to the tabs to stay loaded even when I'm not on them.

This [is the link about tab settings ]. explains what I'm referring to and makes it seem that its still an option.

When you copy/quote me, how do you get it to appear in the gray box?

more options

CallyCat said

To answer your last question, there used to be an option in preferences to uncheck "Don't load tabs until selected." Now there isn't even a tabs preferences section. (I guess I'll have to look for an add-on.) What happens is that I always have several tabs open and all of them, except the one I'm on, apparently close out to a blank page until I click on each tab and then I have to wait for it to open. (Just one more annoying thing about v.48) I would like to the tabs to stay loaded even when I'm not on them.

This [is the link about tab settings ]. explains what I'm referring to and makes it seem that its still an option.

The specific preference that you are referring to was removed from Firefox because it was causing performance issues with some newer features.

As for the unloading tabs, I believe that you may be running Firefox's new e10s feature. This feature is designed to improve performance, security and stability. Some users may experience a loading wheel when changing between multiple tabs.

Please try entering about:support and check to see if the Multiprocess Windows value shows 1/1. If it does, then you are using that feature and I can walk you through how to opt out of it if you would like.

CallyCat said

When you copy/quote me, how do you get it to appear in the gray box?

These are called blockquotes. You can click the Quote button under the response that you wish to copy or you can type <blockquote> at the start of the quote and </blockquote> at the end of the quote.

more options

Thank you, Wesley, for taking the time to explain everything, including the blockquote info.

I checked multiprocess windows and this is the status: 0/2 (Disabled by add-ons)