Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashing on certain websites

  • 10 svar
  • 5 har dette problem
  • 70 visninger
  • Seneste svar af Mosura

more options

Firefox is crashing on certain websites. This is on a Windows 7 desktop. By "crashing" I mean it freezes up, and when I look at it in Windows Task Manager it says that it's "not responding". I have to click "end task" and then restart Firefox. I've noticed this happening really a lot on chicagotribune.com in the last few days. I have Firefox 41.0. I don't know if this has anything to do with Flash, but I have the latest version of the Flash Player plugin, 19.0.0.185. I also changed the Flash settings to disable hardware acceleration. When I view the same website using Chrome, I'm not having a problem, although I haven't spent a lot of time doing that. Also, many other websites seem perfectly fine -- Wikipedia, for example. But I'm pretty sure I've had the "not responding" problem on some other websites, I just can't remember which ones. Thanks in advance for any help. I'm a long time Firefox user but this is my first time posting on the support forum.

Alle svar (10)

more options

Hi Mosura, I'm sorry to hear about the freezing. We do have this general article: Firefox hangs or is not responding - How to fix.

Unfortunately, when Firefox is terminated through the Task Manager or the Windows crash dialog, it seldom captures any useful information. Still, you might check this article to see whether it points to any crash report IDs that might be relevant: [Firefox crashes - asking for support].


Since you mentioned Flash, to minimize potential issues with Flash and browser hangs, I suggest two things:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

jscher2000, thanks for the quick response. I just set Flash to "ask to activate", as you suggested. I'll see how that goes for a while, and then post back here.

more options

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

FredMcD, thanks. I forgot to mention, I did check for updates to my video driver. (To do this I did Start --> right-click on Computer --> Properties --> Device Manager --> Display Adapters --> Intel (R) HD Graphics --> Update Software Driver. I had Windows search the internet for the device driver. After some time, and some apparent downloading activity, it said that I already had the latest driver.)

Also, I did disable hardware acceleration for Flash. I didn't disable protected mode though. I might try that, depending on how things go.

more options

Also, how do I stop getting emails whenever someone posts in this thread? By removing the thread from my Watch List? (I'm not sure if I actually want to do this, but I'd like to have the option. I looked around a bit but I don't see an explanation.)

more options

Mosura said

Also, how do I stop getting emails whenever someone posts in this thread?

Oh, no, it's for life. ;-)

To the right of your question, under Question Tools, see "Stop Email Updates". I don't know if posting a new reply turns it back on.

more options

jscher2000 said

Mosura said
Also, how do I stop getting emails whenever someone posts in this thread?

Oh, no, it's for life. ;-)

To the right of your question, under Question Tools, see "Stop Email Updates". I don't know if posting a new reply turns it back on.

Cool, thanks.

more options

Note that you can set the defaults in your SUMO user profile (Edit Settings).

more options

jscher2000 said

I don't know if posting a new reply turns it back on.

It does.

more options

For the last five or six days I've been using Firefox three different ways -- with Flash set to "ask to activate", with the Flashblock extension turned on, or with Flash running unblocked. I'm pretty sure that the crashes I was getting were related to Flash. They stopped happening as soon as I set Flash to "ask to activate", but things aren't totally straightforward, because now the Chicago Tribune website isn't crashing Firefox for me, even with Flash running. Possibly that website was doing something "funny" for a while and then got fixed, but that's just a guess.

Anyway, I'm glad to have two different ways to block and unblock Flash, and I can't say that I miss it much when it's blocked. And when it's not blocked, it still sometimes seems to slow down Firefox, especially with multiple tabs opened. Looking at Windows Task Manager when that's happening, I can see that the Firefox task, and sometimes the Flash task, are using a lot of memory.

Can Firefox be enhanced so that Flash doesn't affect it so much? Has work been done on that already? I gather that Flash is not universally loved as a technology, and may be used less in the future, which I guess could affect the priorities of Firefox developers.

Ændret af Mosura den