Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google on Firefox gets my location wrong (Chrome and Edge are fine)

  • 3 svar
  • 10 har dette problem
  • 2063 visninger
  • Seneste svar af Username1234

more options

Ever since upgrading to Windows 10, I have been having location issues when using Firefox. When I search anything in Google, I only get US results (we are located in Canada). However, Chrome and Edge both display proper Canadian results. I have checked the location of my IP address, and it shows Toronto (as it always has).

This has only been a problem since upgrading to Windows 10. When I was setting up Windows 10, I know I turned off location services because I don't trust Microsoft with any personal information. However, thinking this might be the cause of my problems, I eventually relented and turned the service back on. However, it did not fix the issue.

I have tried modifying the privacy settings for Google by clicking the little pad lock and setting location access to "allow" but that didn't fix anything either.

I'm at a loss. Firefox has been my primary browser for over a decade, but this is a deal breaker. I am currently working on an SEO project and I need my search results to be location specific.

Valgt løsning

Many Canadian and U.K. users are reporting that Google no longer redirects the searches that Firefox sends to google.com to the local country site. Is that what is happening to you, you are getting results on google.com instead of google.ca?

I have not yet seen any explanation for the change, or any quick fix. What I suggest is installing a google.ca-specific search plugin and making that your default.

For example, this page has four Google Canada options:

http://mycroftproject.com/google-search-plugins.html

When installing, you should be offered the option to make the new search plugin your default. You can try that for a while and see whether you like the results and, if not, you can change your default using the Search section of the Options page:

"3-bar" menu button (or Tools menu) > Options > Search

Does that help?

Læs dette svar i sammenhæng 👍 2

Alle svar (3)

more options

you can use google dorks if you need specific location based search.

more options

Valgt løsning

Many Canadian and U.K. users are reporting that Google no longer redirects the searches that Firefox sends to google.com to the local country site. Is that what is happening to you, you are getting results on google.com instead of google.ca?

I have not yet seen any explanation for the change, or any quick fix. What I suggest is installing a google.ca-specific search plugin and making that your default.

For example, this page has four Google Canada options:

http://mycroftproject.com/google-search-plugins.html

When installing, you should be offered the option to make the new search plugin your default. You can try that for a while and see whether you like the results and, if not, you can change your default using the Search section of the Options page:

"3-bar" menu button (or Tools menu) > Options > Search

Does that help?

more options

jscher2000 said

Many Canadian and U.K. users are reporting that Google no longer redirects the searches that Firefox sends to google.com to the local country site. Is that what is happening to you, you are getting results on google.com instead of google.ca? I have not yet seen any explanation for the change, or any quick fix. What I suggest is installing a google.ca-specific search plugin and making that your default. For example, this page has four Google Canada options: http://mycroftproject.com/google-search-plugins.html When installing, you should be offered the option to make the new search plugin your default. You can try that for a while and see whether you like the results and, if not, you can change your default using the Search section of the Options page: "3-bar" menu button (or Tools menu) > Options > Search Does that help?

I was just looking into this! Worked perfectly.

Thanks a lot.