Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

“Don’t enable HTTPS-Only Mode” being overridden

  • 3 odpovědi
  • 1 má tento problém
  • 25 zobrazení
  • Poslední odpověď od Peanuts_2424

more options

I’ve had this problem since I upgraded Firefox to Version 91.0 and above. When I go to a trusted website with a URL prefix of HTTP:// that I visit every day, I’m now getting a screen displayed saying the site does not support HTTPS:// and tries to redirect me to the HTTP:// . I say “tries” because Firefox seems to go into a loop about every 10 seconds redisplaying the website does not support HTTPS:// screen and then being redirecting to HTTP:// There is nothing wrong with the website and it specifically states it DOES NOT support “HTTPS://" My settings under Tools==>Settings=>Privacy and Security for - History Against the ‘Firefox will’ text I’ve have selected the “Never remember History” option - HTTPS-Only Mode I have selected “Don’t enable HTTPS-Only Mode” option

It appears to me that under Firefox versions 91.0 and above that the ‘Don’t enable HTTPS Only Mode’ is being ignored/overridden and that Firefox is changing the HTTP:// URL prefix to “HTTPS://”, when you set up, under the “History” either the “Never remember history” option or select “Use custom settings for history” option and then select “Always use private browsing mode” I can get around this by either - Method 1 o Selecting “Use custom settings for history” option For me this totally unacceptable as OR - Method 2 o Selecting “Use custom settings for history” option o Unchecking the ““Always use private browsing mode” o After Firefox has restarted > Untick “Remember browsing and download history” > Untick “Remember search and form history” > Tick “Clear history when Firefox closes”

Is this a bug with versions 91.0 and above?????

I’ve had this problem since I upgraded Firefox to Version 91.0 and above. When I go to a trusted website with a URL prefix of HTTP:// that I visit every day, I’m now getting a screen displayed saying the site does not support HTTPS:// and tries to redirect me to the HTTP:// . I say “tries” because Firefox seems to go into a loop about every 10 seconds redisplaying the website does not support HTTPS:// screen and then being redirecting to HTTP:// There is nothing wrong with the website and it specifically states it DOES NOT support “HTTPS://" My settings under Tools==>Settings=>Privacy and Security for - History Against the ‘Firefox will’ text I’ve have selected the “Never remember History” option - HTTPS-Only Mode I have selected “Don’t enable HTTPS-Only Mode” option It appears to me that under Firefox versions 91.0 and above that the ‘Don’t enable HTTPS Only Mode’ is being ignored/overridden and that Firefox is changing the HTTP:// URL prefix to “HTTPS://”, when you set up, under the “History” either the “Never remember history” option or select “Use custom settings for history” option and then select “Always use private browsing mode” I can get around this by either - Method 1 o Selecting “Use custom settings for history” option For me this totally unacceptable as OR - Method 2 o Selecting “Use custom settings for history” option o Unchecking the ““Always use private browsing mode” o After Firefox has restarted > Untick “Remember browsing and download history” > Untick “Remember search and form history” > Tick “Clear history when Firefox closes” Is this a bug with versions 91.0 and above?????

Všechny odpovědi (3)

more options

You can click the padlock icon and change the HTTPS-Only setting from 'On' to 'Off'. See "Turn off HTTPS-Only Mode for certain sites".

more options

If you use a bookmark to access a specific page then instead navigate to this page starting with the main page or with the sign in page in case there is a problem with this bookmark.

more options

Hi cor-el, thank you for your replies. My query is, is the issue I'm experiencing, a bug with version 91.0 and above or is it an undocumented change in how Firefox works now? As per my original post, I have found work arounds for the issue.

I have downgraded back to version 90.0.2 and don't have the issue with the following settings Tools==>Settings=>Privacy and Security==> History ===> Against the ‘Firefox will’ set to “Never remember History” Tools==>Settings=>Privacy and Security==> HTTPS-Only Mode ==> set to “Don’t enable HTTPS-Only Mode”

If I upgrade to version 91.0.1 without any changes to my settings the issue comes back.

In regards to your bookmark suggestion, When I had ver 91.0 installed I've tried and still get the issue after - clicking on the bookmark with the link to main page of the web site i.e. HTTP://www.etc - manually typing the URL with both the HTTP:// and HTTPS:// for the main page and the sub page that I wish to go to. If it helps the website I'm linking to is http://www.bom.gov.au/vic/forecasts/melbourne.shtml