Prohledat stránky podpory

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable auto refresh (specific page or overall website)

  • 1 odpověď
  • 1 má tento problém
  • 5 zobrazení
  • Poslední odpověď od cor-el

more options

I am on a website page that continually refreshes after 4 or 5 seconds. I am using what I believe is the latest version of Firefox (July 2020 update) in a Windows 10 32 bit environment. I found a few answers that mention how to disable the auto refresh but those options do not seem to appear in the current version. Perhaps the wordings or options have changed but I cannot find the "Warn me when web pages try to refresh" checkbox. Thanks.

I would like to know if there are options to disable auto refresh for (a) a single webpage or (b) all pages on a website.

Všechny odpovědi (1)

more options

If a web page refreshes that often then something else is wrong. If a web page refreshes automatically then this is usually once every three or four minutes and is done via JavaScript. The block autorefresh feature that Firefox had in the past (and still has as a hidden feature) wouldn't help in such a case and enabling this accessibility feature can cause issues with websites that have (multiple) redirects, so it is recommended to leave this off.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Pomohla vám tato odpověď?

Položit otázku

Pro přidání odpovědi se musíte přihlásit ke svému účtu. Pokud dosud nemáte účet, položte novou otázku.