Změna programu spouštěného po klepnutí na e-mailový odkaz

K odeslání e-mailové zprávy Firefox využívá poštovní program, který je v systému nastaven jako výchozí. Tento článek vysvětluje, jak změnit program, který se spouští po klepnutí na:

  • položku Odeslat odkaz... pod tlačítkem Firefox (v nabídce Soubor ve Windows XP)v nabídce Soubor.
  • položku Odeslat odkaz... v kontextové nabídce Firefoxu (klepnutí pravým tlačítkem myšiCtrl+klepnutí myši).
  • "mailto" neboli na e-mailový odkaz na stránce (např. priklad@priklad.cz).
  • položku Odeslat odkaz... pod tlačítkem Firefox (v nabídce Soubor ve Windows XP)v nabídce Soubor.
  • "mailto" neboli na e-mailový odkaz na stránce (např. priklad@priklad.cz).

Nastavení poštovního klienta Firefoxu

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox a poté na položku MožnostiV horní části okna Firefoxu klepněte na nabídku Nástroje a v ní zvolte položku MožnostiNa liště s nabídkou klepněte na nabídku Firefox a v ní na položku Předvolby...V horní části okna Firefoxu klepněte na nabídku Úpravy a v ní zvolte položku Předvolby.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte MožnostiPředvolby.

  2. Přejděte do sekce Aplikace.
  3. Do vyhledávacího pole zadejte slovo mailto a klepněte na nalezenou položku.
  4. Klepněte na rozbalovací nabídku ve sloupci Akce a vyberte požadovanou akci.

    moznosti-aplikace-mailto


    Fx4MacAppPanel-mailto
    • Vždy se dotázat: budete pokaždé vyzváni ke zvolení programu nebo služby, která se má použít.
    • Použít <Program> (výchozí): automaticky se spustí v systému nainstalovaný poštovní program (např. Thunderbird, Windows Live Mail, Outlook, Evolution, KMail), v okně psaní nové zprávy. Jak nastavit jiný poštovní program jako výchozí v operačním systému se dozvíte v následující kapitole.
    • Použít <Webová služba>: do okna Firefoxu se načte stránka pro napsání nové zprávy náležející příslušné webové poštovní službě. Více se o používání webových poštovních služeb dozvíte v kapitole Použití webových poštovních služeb.
    • Použít jinou...: umožní vybrat externí program, který má Firefox automaticky používat.
    • Podrobnosti o aplikaci...: zobrazí informace o webové poštovní službě nacházející se v seznamu spolu s možností jejího odstranění.
  5. Klepnutím na tlačítko OK zavřete dialogové okno MožnostiKlepnutím na tlačítko Zavřít zavřete dialogové okno PředvolbyZavřete dialogové okno Předvolby.

Nastavení výchozího poštovního programu operačního systému

Ve výchozím nastavení používá Firefox k odeslání e-mailové zprávy poštovní program, který je v operačním systému nastaven jako výchozí. Chcete-li změnit výchozí poštovní program systému, postupujte podle následujících instrukcí:

Windows 7 a Vista

  1. Klepněte na tlačítko Start a poté na položku Výchozí programy.
  2. Klepněte na Nastavení výchozích programů.
  3. Ve sloupci Programy klepněte na poštovní program, který si přejete používat (např. Thunderbird, Windows Live Mail, Outlook).
  4. Klepněte na Nastavit tento program jako výchozí.
  5. Klepněte na tlačítko OK ve spodní části okna.

Windows XP

  1. Klepněte na tlačítko Start a poté na položku Ovládací panely.
  2. Klepněte na ikonu Přidat nebo odebrat programy.
  3. V levé části okna klepněte na sekci Přístup a výchozí nastavení programů.
  4. Zaškrtněte políčko Vlastní, přičemž se tato kategorie rozbalí.
  5. V sekci Vyberte výchozí emailový program zaškrtněte program, který si přejete používat (např. Thunderbird, Windows Live Mail, Outlook).
  6. Klepněte na tlačítko OK at the bottom of the window.
  1. Ze složky Applications (Aplikace) spusťte program Mail.
  2. Klepněte na nabídku Mail a poté na položku Preferences (Předvolby).
  3. Přejděte do sekce General (Obecné).
  4. Z rozbalovací nabídky u položky Default email reader vyberte nový výchozí poštovní program (např. Thunderbird, Outlook).
Poznámka: Následující postupy jsou pro některé běžné linuxové distribuce. Je možné, že vaše distribuce používá jiné uživatelské rozhraní.

Gnome

Mezi distribuce, jejichž výchozím desktopovým prostředím je Gnome, patří Ubuntu, openSUSE, Fedora, Red Hat Enterprise Linux a další.

  1. Otevřete okno Preferované aplikace (Preferred Applications):
    • (Ubuntu) V nabídce spouštěče aplikací klepněte na nabídku Systém, dále na Předvolby (Preferences) a zvolte položku Preferované aplikace (Preferred Applications).
    • Klepněte na nabídku Aplikace (Applications), dále na Nastavení prostředí pracovní plochy (Desktop Preferences), poté na Rozšířené (Advanced) a nakonec na Preferované aplikace (Preferred Applications).
  2. Z rozbalovací nabídky v sekci E-mailový klient (Mail Reader) vyberte výchozí poštovní program (např. Thunderbird, Evolution).
  3. Klepnutím na tlačítko Zavřít (Close) zavřete okno Preferované aplikace.

KDE

Mezi distribuce, jejichž výchozím desktopovým prostředím je KDE, patří Kubuntu, Mandriva Linux, PCLinuxOS a další.

  1. Spusťte Ovládací centrum KDE (KDE Control Center) klepnutím na tlačítko spouštěče aplikací K a poté na položku Ovládací centrum (Control Center).
  2. V levém sloupci rozbalte klepnutím sekci Komponenty (KDE Components).
  3. V rozbalené nabídce klepněte na Výběr komponent (Component Chooser).
  4. Klepněte na E-mailový klient (Email Client).
  5. Klepněte na přepínač Použít jiný e-mailový klient (Use a different email client).
  6. Zadejte úplnou cestu k poštovnímu programu, který chcete používat (např. /usr/bin/thunderbird).
  7. Klepnutím na Použít (Apply) zavřete Ovládací centrum a uložíte provedené změny.

Použití webových poštovních služeb

Firefox umožňuje k odeslání e-mailové zprávy používat webové poštovní služby (např. Gmail, Yahoo! Mail atd.). Popis příslušného nastavení naleznete v kapitole Nastavení poštovního klienta Firefoxu.

Jestliže se v seznamu nabízených programů a služeb ve zmíněném nastavení Firefoxu nenachází služba, kterou byste si přáli používat, je možné ji tam přidat prostřednictvím rozšíření:

  • Na stránce Doplňky aplikace Firefox můžete zkusit vyhledat potřebné rozšíření.



Založeno na informacích z článků Default mail client (mozillaZine KB), Change the default e-mail program (Microsoft.com Support), How to change the default web browser or email application (Apple.com Support), The KDE Control Center (KDE.org) a Select Preferred Applications in Ubuntu (DebianAdmin.com).



Sdílet tento článek: http://mzl.la/LhUKxb

Byl tento článek srozumitelný? Počkejte prosím...

Tito lidé pomohli se sepsáním tohoto článku: soucet. Můžete též pomoci - přečtěte si jak.