Řešení problémů s tiskem stránek ve Firefoxu

Tento článek se zabývá řešením problémů s tiskem stránek ve Firefoxu.

Kontrola nastavení stránky

Jestliže se stránka ve Firefoxu nevytiskne správně:

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox, najeďte myší nad nabídku Tisk... (ve Windows XP klepněte na nabídku Soubor) a zvolte položku Náhled tisku. Zobrazí se okno s předtiskovým náhledem stránky.
  2. Ujistěte se, že měřítko je nastaveno na Na šířku stránky.
  3. Ujistěte se, že orientace stránky je Na výšku.
  4. Klepněte na tlačítko Vzhled stránky.... Otevře se okno Vzhled stránky.
  5. Klepněte na kartu Okraje, záhlaví a zápatí.
  6. Ujistěte se, že jsou správně nastaveny okraje stránky (výchozí hodnota je 12.7 mm či 0.5 in).
  7. Klepnutím na tlačítko OK zavřete okno Vzhled stránky a vrátíte se do okna s náhledem stránky.
  8. Klepněte na tlačítko Tisk. Zobrazí se okno Tisk.
  9. Ujistěte se, že z vysouvací nabídky Název je vybrána správná tiskárna.
  10. Ujistěte se, že není zaškrtnuta volba Tisk do souboru.

Provedli-li jste nějaké změny, klepněte na tlačítko OK a pokuste se stránku vytisknout znovu. Pokud jste žádné změny neprovedli, pokračujte další kapitolou.

Kontrola nastavení stránky

Jestliže se stránka ve Firefoxu nevytiskne správně:

  1. Na liště s nabídkou klepněte na nabídku Soubor a zvolte položku Náhled tisku. Zobrazí se okno s předtiskovým náhledem stránky.
  2. Ujistěte se, že měřítko je nastaveno na Na šířku stránky.
  3. Ujistěte se, že orientace stránky je Na výšku.
  4. Klepněte na tlačítko Tisk. Zobrazí se okno Tisk.
  5. Ujistěte se, že z vysouvací nabídky Název je vybrána správná tiskárna.
  6. Klepněte na kartu Page Setup. Ujistěte se, že jsou správně nastaveny okraje stránky (výchozí hodnota je 12.7 mm či 0.5 in).

Provedli-li jste nějaké změny, klepněte na tlačítko Print a pokuste se stránku vytisknout znovu. Pokud jste žádné změny neprovedli, pokračujte další kapitolou.

Vyzkoušení jiného prohlížeče a tiskárny

Je možné zjistit, zda je příčinou problému Firefox, tiskárna, nebo samotná webová stránka:

  • Vyzkoušejte, zda se stránka vytiskne správně v jiném prohlížeči (např. v Internet ExploreruSafariEpiphany)

Nevytiskne-li se stránka správně ani v jiném prohlížeči:

  • Problém by mohl být na straně tiskárny: můžete-li použít jinou tiskárnu, zkuste stránku vytisknout na ni. Pokud se stránka vytiskne správně, aktualizujte ovladač původní tiskárny z webových stránek výrobce.
  • Problém by mohl být na straně webové stránky. Kontaktujte administrátora webových stránek.

Pokud se stránka v jiném prohlížeči vytiskne správně, postupujte podle instrukcí v další kapitole.

Obnovení výchozího nastavení tiskárny ve Firefoxu

Mnohé potíže s tiskárnou lze vyřešit obnovením výchozího nastavení tiskárny v předvolbách Firefoxu:

  1. Do adresního řádku zadejte about:config a stiskněte klávesu EnterReturn.

    • Při vstupu se může zobrazit upozornění "Vstup jen na vlastní nebezpečí". Pokračovat na stránku about:config budete po klepnutí na tlačítko Budu opatrný, slibuji!.
  2. Do pole FiltrHledat zadejte print_printer.
  3. Klepněte pravým tlačítkem myšiPodržte klávesu Ctrl a klepněte na předvolbu print_printer a z nabídky zvolte Obnovit.
  4. V horní části okna Firefoxu klepněte na tlačítko Firefox, kde zvolte položku UkončitV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku UkončitNa liště s hlavní nabídkou klepněte na nabídku Firefox, kde zvolte položku Ukončit FirefoxV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku Ukončit.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a v ní klepněte na Ukončit Close 29 .

Po opětovném spuštění Firefoxu zkuste vytisknout stránku na tiskárně, na které se stránka netiskla správně.

Poznámka: Ve Firefoxu verze 5.0 a dřívějších měla tato předvolba název print.print_printer. Pokud byl váš současný profil používán již ve zmíněných verzích, mohou se v předvolbách Firefoxu vyskytovat obě předvolby, tedy jak stará tak nová. Starou předvolbu print.print_printer je možné odstranit tak, že ji obnovíte, restartujete Firefox a poté něco vytisknete — předvolba se již neobjeví a zůstane pouze ta nová.

Obnovení výchozího nastavení všech tiskáren ve Firefoxu

Jestliže předchozí postup problém nevyřešil, můžete zkusit obnovit v předvolbách Firefoxu výchozí nastavení všech tiskáren:

  1. Otevřete svou složku s profilem:

    V horní části okna Firefoxu klepněte na tlačítko Firefox, přejeďte do nabídky NápovědaNa liště s nabídkou klepněte na nabídku NápovědaV horní části okna Firefoxu klepněte na nabídku Nápověda a zvolte položku Technické informace.... Otevře se panel Technické informace.Zobrazte nabídku klepnutím na tlačítko New Fx Menu , v ní klepněte na Help-29 a zvolte Technické informace. Otevře se panel Technické informace.

  2. V sekci Stručně o aplikaci klepněte na tlačítko Zobrazit složkuZobrazit ve FinderuOtevřít adresář. Otevře se okno se soubory vašeho profilusložkou s vaším profilem.
  3. Poznámka: Pokud nemůžete spustit či použít Firefox, postupujte dle instrukcí v článku Nalezní profilu bez otevření Firefoxu.

  4. V horní části okna Firefoxu klepněte na tlačítko Firefox, kde zvolte položku UkončitV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku UkončitNa liště s hlavní nabídkou klepněte na nabídku Firefox, kde zvolte položku Ukončit FirefoxV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku Ukončit.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a v ní klepněte na Ukončit Close 29 .

  5. Ve složce s vaším profilem vytvořte zálohu souboru prefs.js tak, že jej zkopírujete do jiné složky.
  6. Otevřete původní soubor prefs.js v textovém editoru (např. ve Wordpaduv TextEdituv Emacsu).
  7. Vymažte všechny řádky, které začínají na print_ a poté uložte soubor.

Pokud se při následném spuštění Firefoxu vyskytne nějaký problém, ukončete Firefox a soubor prefs.js nahraďte jeho zálohou.

Změna výchozího typu písma

Je možné, že vaše tiskárna nerozpozná písmo Time New Roman. Nahraďte proto výchozí typ písma nějakým podobným typem, např. písmem Trebuchet MS:

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox a poté na položku MožnostiV horní části okna Firefoxu klepněte na nabídku Nástroje a v ní zvolte položku MožnostiNa liště s nabídkou klepněte na nabídku Firefox a v ní na položku Předvolby...V horní části okna Firefoxu klepněte na nabídku Úpravy a v ní zvolte položku Předvolby.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte MožnostiPředvolby.

  2. Přejděte do sekce Obsah.
  3. V podsekci Písma a barvy vyberte jako výchozí písmo Trebuchet MS.
  4. Klepnutím na tlačítko OK zavřete dialogové okno MožnostiKlepnutím na tlačítko Zavřít zavřete dialogové okno PředvolbyZavřete dialogové okno Předvolby.



Sdílet tento článek: http://mzl.la/MCCq7H

Byl tento článek srozumitelný? Počkejte prosím...

Tito lidé pomohli se sepsáním tohoto článku: soucet. Můžete též pomoci - přečtěte si jak.