X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't get browser.cache.disk.parent_directory to work

Posted

I've tried to use the browser.cache.disk.parent_directory method to move my disk cache, but this isn't working.

Details:

I did a clean install of Firefox 22 on Vista, and then, following instructions, went into about:config, created the browser.cache.disk.parent_directory key, and gave it the value of a directory I had created.

I then visited many different sites (no, not in private browsing mode), and noticed nothing was being saved there. In fact, the new directory is absolutely empty (no hidden folders either).

Looking at about:cache, I am informed:

Offline cache device Number of entries: 0 Maximum storage size: 512000 KiB Storage in use: 0 KiB Cache Directory: C:\Users\XXX\AppData\Local\Mozilla\Firefox\Profiles\XXX.default\OfflineCache

And yes, browser.cache.disk.enable is set to true.

This is true regardless of whether I am using my admin account with no extensions or my standard user account with several extensions.

Advice?

Chosen solution

Final entry:

Almost by coincidence, I found the following information from cor-el: "In case you are using 'Clear history when Firefox closes': do not clear Cache because Firefox will disable the disk cache in such a case".

There are some use-cases for which this is obviously appropriate behavior, but for this to be the default (and perhaps unchangeable) policy is baffling to me.

Anyhow, my original question seems answered, even if I highly dislike the answer: regardless of where your cache is located, if you choose to automatically clear your cache when Firefox closes, Firefox will completely disable the cache.

Thanks to cor-el and to the responders on this thread.

Read this answer in context 7

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

finitarry 157 solutions 2175 answers

I noticed that the cache saved to the hard drive was the offline cache unless I set its size to 0. That forced the use of the disk cache. I also had to enable both caches (disk & offline) for anything to be saved to the hard drive at all. That was several Firefox versions ago, but maybe the same setup is still necessary.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

See if this helps you -
http://kb.mozillazine.org/Browser.cache.disk.parent_directory

Question owner

Thanks for the response, finitarry. Unfortunately, while it's the kind of esoteric procedure that seems promising, it didn't work for me. When I tried it, the only change was that about:cache displayed only the memory cache and nothing else.

Helpful Reply

the-edmeister, I carefully read the material in your link before making the changes, and then again before posting this question, and yet again now. I hate to be snide, but can you point out what there is in this link that addresses my question? (And yes, browser.cache.disk.capacity is obviously set to a positive value.)

If it helps, I'm attaching a screencap from about:config.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

It doesn't directly address your question, which is why I said - See if this helps you. You didn't mention using that KB page as a reference for that change.

I trust that you know changes made in about:config are per Profile, so that the change needs to be made in all user accounts - admin and standard.

How about a screenshot of the about:cache page?

Or, on the about:cache page does the Disk cache device show the T:\firefox path?

Question owner

I've been switching back and forth between the accounts, making changes in both, testing both, and double-checking both.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

Disk cache device is missing. It should appear in about:cache and I can't see a reason it is missing. Did you manually create that T:\firefox folder? I vaguely recall having to create the folder specified in the "Path".


My cache becomes relocated out of the \Local\ path as a result of having my Profile not "relative" (to the profiles.ini file), see my screenshots.

Question owner

Disk cache device is missing. It should appear in about:cache and I can't see a reason it is missing."

Me neither. :-)

Yes, I manually created the new folder.

I'm not sure I understand your second paragraph.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

Something is wrong, you should have a Disk Cache Device entry - it's like it is disabled, but appears to be enabled in your about:config screenshot.

My advice is to create a new Profile and do those mods again in a fresh Profile.

Question owner

I have now found the definite "cause" for my problem, which I have reproduced in both directions:

Telling Firefox to "remember history" causes the cache to work properly. However, setting a custom configuration (see screencap) causes the problem I described.

I don't see any reason for this behaviour, but this is what happens.

Chosen Solution

Final entry:

Almost by coincidence, I found the following information from cor-el: "In case you are using 'Clear history when Firefox closes': do not clear Cache because Firefox will disable the disk cache in such a case".

There are some use-cases for which this is obviously appropriate behavior, but for this to be the default (and perhaps unchangeable) policy is baffling to me.

Anyhow, my original question seems answered, even if I highly dislike the answer: regardless of where your cache is located, if you choose to automatically clear your cache when Firefox closes, Firefox will completely disable the cache.

Thanks to cor-el and to the responders on this thread.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You're welcome.

  • bug 709262 - Disable disk cache for users who have "Clear private data at shutdown"

Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

finitarry 157 solutions 2175 answers

That does not apply to use of "Clear Recent History" in the History menu, does it? I have that set to clear the cache as well as other data and I use that at the end of every browsing session. It has not disabled my disk cache. There is content in there right now.

The solution would seem to be to use the item in the History menu rather than in the Preferences/Options.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

No, this only applies to "Clear history when Firefox closes" to clear the cache automatically.

Clearing the disk cache can be done at any time via other means (Clear Recent History or via Options > Advanced > Network).

sjh953 0 solutions 1 answers

At least for my system, I think I found a solution of not being able to get cache written to the enabled directory:

I did a search for 'cache' in about:config.

For some reason, the listing "browser.cache.disk.enable' was flagged as 'false'. I set it to 'true' -- and instantly I could see that the cache was being written into the directory I'd set in preferences.

For me, that seems to have solved the issue.