Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening a site from Bookmark Toolbar in a new tab steals focus eventhough all new tab behaviors are set to not steal focus.

  • 2 replies
  • 2 have this problem
  • 31 views
  • Last reply by meboz

more options

When I open a site from my [Bookmarks Toolbar] (feeds) in a new tab, the site is opened in a new tab and FF switches to it. I have already unchecked [Options]~>[Tabs]~>["When I open a link in a new tab, switch to it immediately."]. I have also set [browser.tabs.loadBookmarksInBackground] to true.

The bookmarks/feeds open new tabs in the background properly, but opening the site from the bookmark toolbar does not.

Is this a bug? Is there a setting I am missing to fix this?

Example of what is happening now: {Left Click} [Bookmarks Toolbar] {Mouseover} [xkcd.com] (expand feed folder) {Middle Click} [Open "xkcd.com"] (at top of list of feed links) xkcd.com site now opens in a new tab and FF switches to it.

I want the site to open the in a new tab in the background like the feed links already do with my settings.

When I open a site from my [Bookmarks Toolbar] (feeds) in a new tab, the site is opened in a new tab and FF switches to it. I have already unchecked [Options]~>[Tabs]~>["When I open a link in a new tab, switch to it immediately."]. I have also set [browser.tabs.loadBookmarksInBackground] to true. The bookmarks/feeds open new tabs in the background properly, but opening the site from the bookmark toolbar does not. Is this a bug? Is there a setting I am missing to fix this? Example of what is happening now: {Left Click} [Bookmarks Toolbar] {Mouseover} [xkcd.com] (expand feed folder) {Middle Click} [Open "xkcd.com"] (at top of list of feed links) xkcd.com site now opens in a new tab and FF switches to it. I want the site to open the in a new tab in the background like the feed links already do with my settings.

All Replies (2)

more options

Works for me if I middle-click a bookmark on the Bookmarks Toolbar and browser.tabs.loadBookmarksInBackground is set to true.

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Please re-read the original post. My bookmarks work fine. The site link above the feed bookmarks does not.

I confirmed that safe mode does not fix this issue.