Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

URL Autocomplete is set to true but it isn't working. How do I make Firefox autocomplete again?

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

I've recently switched laptops and on my old system, Firefox would always autocomplete my URL searches based on my bookmarks. On my new laptop, Firefox doesn't autocomplete my searches. I've looked at about:config and it's set to true.

I've recently switched laptops and on my old system, Firefox would always autocomplete my URL searches based on my bookmarks. On my new laptop, Firefox doesn't autocomplete my searches. I've looked at about:config and it's set to true.

All Replies (4)

more options

Hello do you have both TRUE ?:

browser.urlbar.autocomplete.enabled

browser.urlbar.autoFill

thank you

more options

Yes, they're both set to true.

more options

Please check IF you have in your firefox profile folder a User.js file.

The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file, to see if the problem goes away (some programs create and write in the file also).

thanks

more options

You can also check browser.urlbar.maxRichResults

You can delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)