X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Firefox 17.0 doesn't warn me when closing multiple tabs any more

Objavljeno

hi all

Having updated to Firefox 17.0 (from 16.0.2), for some reason I don't get warned when closing multiple tabs any more.

I've confirmed the relevant options are selected and am 100% certain this was working fine before updating Firefox today.

I've replicated the problem on my vista 32bit platform and on XP 32 bit too.

I also looked at the changelog for Firefox 17 but can't see any explanation for this change in behaviour, although I wonder whether this might have something to do with it "772319 No option to disable the "Close other tabs" prompt."

As I use Tab Mix Plus (add-on), I've also checked Firefox in safemode and have found the native tab warnings not working, so have concluded it's an issue with Firefox (rather than something to do with an extension).

I've checked "about:config" and "browser.tabs.warnOnClose" is set to true, as is "browser.tabs.warnOnCloseOtherTabs".

Any help would be appreciated.


Thanks,

Gary

hi all Having updated to Firefox 17.0 (from 16.0.2), for some reason I don't get warned when closing multiple tabs any more. I've confirmed the relevant options are selected and am 100% certain this was working fine before updating Firefox today. I've replicated the problem on my vista 32bit platform and on XP 32 bit too. I also looked at the changelog for Firefox 17 but can't see any explanation for this change in behaviour, although I wonder whether this might have something to do with it "772319 No option to disable the "Close other tabs" prompt." As I use Tab Mix Plus (add-on), I've also checked Firefox in safemode and have found the native tab warnings not working, so have concluded it's an issue with Firefox (rather than something to do with an extension). I've checked "about:config" and "browser.tabs.warnOnClose" is set to true, as is "browser.tabs.warnOnCloseOtherTabs". Any help would be appreciated. Thanks, Gary

Izmjenjeno od strane gazzawazza

Izabrano rješenje

weird it's finally working. so nvm i guess

Pročitajte ovaj odgovor sa objašnjenjem 0

Dodatni detalji o sistemu

Instalirani priključci

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 6.0; rv:17.0) Gecko/17.0 Firefox/17.0

Više informacija

cor-el
  • Top 10 Contributor
  • Moderator
17673 rješenja 159870 odgovora

Is this with closing a window or with closing other tabs via the right-click context menu of the Tab bar?

Is this with closing a window or with closing other tabs via the right-click context menu of the Tab bar?

Vlasnik pitanja

hi Cor-el

This is when closing a window.

I've just tested "closing other tabs" via mouse context menu and that does generate the warning.


Regards,

Gary

hi Cor-el This is when closing a window. I've just tested "closing other tabs" via mouse context menu and that does generate the warning. Regards, Gary
cor-el
  • Top 10 Contributor
  • Moderator
17673 rješenja 159870 odgovora

If you close a window and that is the only browser window then you may not get a warning because session restore might be enabled to reopen the tabs on a next start.

  • Tools > Options > General > Startup: When Firefox Starts: Show my windows and tabs from last time
If you close a window and that is the only browser window then you may not get a warning because session restore might be enabled to reopen the tabs on a next start. *Tools > Options > General > Startup: When Firefox Starts: Show my windows and tabs from last time

Vlasnik pitanja

Hi Cor-el

I'm afraid it's not that, since FF is configured to open on my homepage.

However... and apologies for this - the first thing I did was check in safemode / with addons disabled - but it appears to be a problem between FF17 and Tab Mix Plus.

If you go into About:Config with FF 17 and TMP active (even using dev builds 0.4.0.4pre.120724a and b versions), "browser.warnOnQuit" is set to false and locked on false I.e. you simply cannot change the boolean value.

However, if you disable TMP, I found "browser.warnOnQuit" still set to false (i.e. hence why the no warning on exiting multiple tabs problem was still replicated in safemode) but at least you can change the value.

The dev(s) are aware of the problem but I'm not aware of a fix date.


Regards,

Gary

Hi Cor-el I'm afraid it's not that, since FF is configured to open on my homepage. However... and apologies for this - the first thing I did was check in safemode / with addons disabled - but it appears to be a problem between FF17 and Tab Mix Plus. If you go into About:Config with FF 17 and TMP active (even using dev builds 0.4.0.4pre.120724a and b versions), "browser.warnOnQuit" is set to false and locked on false I.e. you simply cannot change the boolean value. However, if you disable TMP, I found "browser.warnOnQuit" still set to false (i.e. hence why the no warning on exiting multiple tabs problem was still replicated in safemode) but at least you can change the value. The dev(s) are aware of the problem but I'm not aware of a fix date. Regards, Gary
FFmurphy 0 rješenja 30 odgovora

Just to clarify:

"However, if you disable TMP, I found browser.warnOnQuit still set to false (i.e. hence why the no warning on exiting multiple tabs problem was still replicated in safemode) but at least you can change the value."

As soon as you re-enable TMP, browser.warnOnQuit is set from true back to false and locked again. Therefore, unfortunately, setting this preference to true in safe mode does not solve the original problem.

Is there any way to lock this preference yourself (once you've set it to true), preventing TMP from setting it back to false?

Just to clarify: ''"However, if you disable TMP, I found '''browser.warnOnQuit''' still set to false (i.e. hence why the no warning on exiting multiple tabs problem was still replicated in safemode) but at least you can change the value."'' As soon as you re-enable TMP, '''browser.warnOnQuit''' is set from ''true'' back to ''false'' and ''locked again''. Therefore, unfortunately, setting this preference to ''true'' in safe mode does not solve the original problem. Is there any way to lock this preference yourself (once you've set it to ''true''), preventing TMP from setting it back to ''false''?

Vlasnik pitanja

Hi FFMurphy

The point I was making about being able to set the WarnOnQuit config to true was that my original conclusion regarding FireFox was wrong i.e. without Tab Mix Plus being active, the warning regarding multiple tabs closing functions correctly.

As I said, the TMP devs are aware of the problem but a fix date has not been confirmed. It's been suggested on the TMP forum that we may see a new build in January. Whether a fix will be part of this build is not known either.

I'm not aware of a way to lock WarnOnQuit to true, I'm afraid.

The peculiar thing about this issue is that if you have multiple windows with multiple tabs, the warning works... until you get down to one instance of FireFox.

The other point is that the latest dev build of TMP works fine with firefox 16, so clearly something has changed with FireFox 17 (and 18 - someone has confirmed the same issue with the pre-release build of FF18) i.e. whether TMP doesn't work properly because of a bug or whether it's simply to do with something having changed in FF and TMP has to change to fall in line, I don't know.


Regards,

Gary

Hi FFMurphy The point I was making about being able to set the WarnOnQuit config to true was that my original conclusion regarding FireFox was wrong i.e. without Tab Mix Plus being active, the warning regarding multiple tabs closing functions correctly. As I said, the TMP devs are aware of the problem but a fix date has not been confirmed. It's been suggested on the TMP forum that we may see a new build in January. Whether a fix will be part of this build is not known either. I'm not aware of a way to lock WarnOnQuit to true, I'm afraid. The peculiar thing about this issue is that if you have multiple windows with multiple tabs, the warning works... until you get down to one instance of FireFox. The other point is that the latest dev build of TMP works fine with firefox 16, so clearly something has changed with FireFox 17 (and 18 - someone has confirmed the same issue with the pre-release build of FF18) i.e. whether TMP doesn't work properly because of a bug or whether it's simply to do with something having changed in FF and TMP has to change to fall in line, I don't know. Regards, Gary
FFmurphy 0 rješenja 30 odgovora

Hi Gary,

I was fully aware of what you pointed out in your previous post, but just wanted to clarify also for others following this thread that although it is possible to set the preference back to true in safe mode / with disabled TMP (like you said), this only lasts until TMP is re-eabled and therefore should not be mistaken as a solution (like I nearly but not eventually did).

Also I'm following the according thread at the TMP forum myself, being not too optimistic about another dev build resolving the issue before January either. Hence I'm back on FF16 – also due to another bug concerning FF17 creating invalid icon files when creating drag & drop internet shortcuts on the desktop of Windows XP systems including SP3, which is another story.

As for the inconsistent behavior with multiple windows (still one instance though) of FF17, I already discovered the same thing right after updating previous posts [here] and [here] assuming that this would solve the issue, but since it is at least TMP related (despite not occurring with FF versions previous to 17&18) I didn't contribute any further on this side effect here.

Thanks for the info regarding FF18, as I was about to update with a glimpse of hope, before deciding to downgrade because of the aforenamed reason.

Having skimmed through the release notes as well, not seeing any changes to warnOnQuit after FF13, but lots of trouble with warnOnCloseOtherTabs according to Bug 277079 and Bug 772319 (which you mentioned, also being discussed in the first thread I linked to above), however, I'm equally unsure about who's to blame in the end. To my notion, the impacts of both settings in the preferences weren't only inconsistent, but also didn't actually reflect the option menu choices anymore in FF17. Now having banned this version I can no longer investigate these issues to specify them in detail, of course.

Cheers, murphy

Hi Gary, I was fully aware of what you pointed out in your previous post, but just wanted to clarify ''also for others following this thread'' that although it is possible to set the preference back to true in safe mode / with disabled TMP (like you said), this only lasts until TMP is re-eabled and therefore should not be mistaken as a solution (like I nearly but not eventually did). Also I'm following the according thread at the TMP forum myself, being not too optimistic about another dev build resolving the issue before January either. Hence I'm back on FF16 – also due to another bug concerning FF17 creating invalid icon files when creating drag & drop internet shortcuts on the desktop of Windows XP systems including SP3, which is another story. As for the inconsistent behavior with multiple windows (still one instance though) of FF17, I already discovered the same thing right after updating previous posts [[https://support.mozilla.org/de/questions/939101 here]] and [[https://support.mozilla.org/de/questions/929476 here]] assuming that this would solve the issue, but since it is at least TMP related (despite not occurring with FF versions previous to 17&18) I didn't contribute any further on this side effect here. Thanks for the info regarding FF18, as I was about to update with a glimpse of hope, before deciding to downgrade because of the aforenamed reason. Having skimmed through the release notes as well, not seeing any changes to ''warnOnQuit'' after FF13, but lots of trouble with ''warnOnCloseOtherTabs'' according to Bug 277079 and Bug 772319 (which you mentioned, also being discussed in the first thread I linked to above), however, I'm equally unsure about who's to blame in the end. To my notion, the impacts of both settings in the preferences weren't only inconsistent, but also didn't actually reflect the option menu choices anymore in FF17. Now having banned this version I can no longer investigate these issues to specify them in detail, of course. Cheers, murphy
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

Korisan odgovor

I have this problem too. i have tab mix plus but in my case browser.tabs.warnOnCloseOtherTabs and browser.tabs.warnOnClose are both set to true but i still get no warnings which sucks because i accidently click on close alot.

I have this problem too. i have tab mix plus but in my case browser.tabs.warnOnCloseOtherTabs and browser.tabs.warnOnClose are both set to true but i still get no warnings which sucks because i accidently click on close alot.

Vlasnik pitanja

That's rather clever. How did you manage that (getting those configs to those settings)?!

Could you post your build versions of FF and Tab Mix Plus?

Weird that you've got your config to those settings and it still doesn't provide warnings on close...

Can you confirm what happens if you disable TMP, then try to close multiple tabs? It should warn you. If not, double-check the about:config settings already mentioned...


Cheers,

Gazza

That's rather clever. How did you manage that (getting those configs to those settings)?! Could you post your build versions of FF and Tab Mix Plus? Weird that you've got your config to those settings and it still doesn't provide warnings on close... Can you confirm what happens if you disable TMP, then try to close multiple tabs? It should warn you. If not, double-check the about:config settings already mentioned... Cheers, Gazza

Vlasnik pitanja

Can you check some of the tabmixplus about:config settings too?

What about:

"extensions.tabmix.tabs.warnOnClose" "extensions.tabmix.protectedtabs.warnOnClose" "extensions.tabmix.warnOnclose"


Cheers,

Gazza

Can you check some of the tabmixplus about:config settings too? What about: "extensions.tabmix.tabs.warnOnClose" "extensions.tabmix.protectedtabs.warnOnClose" "extensions.tabmix.warnOnclose" Cheers, Gazza
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

Firefox 17.0.1 Tab Mix Plus Dev-Build 0.4.0.4pre.120724a (i had 0.4.0.3 and 0.4.0.3.1 as well same thing) and i did nothing they say both say true and i can change the values to false and back w/o any issue. the warnings just don't appear for me since 17.0. And ik TMP causes the no warning thing but in my case it says true not false

Firefox 17.0.1 Tab Mix Plus Dev-Build 0.4.0.4pre.120724a (i had 0.4.0.3 and 0.4.0.3.1 as well same thing) and i did nothing they say both say true and i can change the values to false and back w/o any issue. the warnings just don't appear for me since 17.0. And ik TMP causes the no warning thing but in my case it says true not false

Izmjenjeno od strane NekoNekoMew

NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

All say true

All say true
cor-el
  • Top 10 Contributor
  • Moderator
17673 rješenja 159870 odgovora
Objavljeno

If you have Tab Mix Plus then that extension will override the default Firefox settings that show in your screenshot.
It is best to search for warn to see all "warn" related prefs including the ones added by TMP.

If you have Tab Mix Plus then that extension will override the default Firefox settings that show in your screenshot.<br /> It is best to search for warn to see all "warn" related prefs including the ones added by TMP.
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

Again all set to true. i

Again all set to true. i
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

It's firefox 17's fault for being incompatible. i just decided to downgrade back to 16.0.2 and hope that the developer can keep up with these ridiculous excuse for updates.

It's firefox 17's fault for being incompatible. i just decided to downgrade back to 16.0.2 and hope that the developer can keep up with these ridiculous excuse for updates.
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

Odabrano rješenje

weird it's finally working. so nvm i guess

weird it's finally working. so nvm i guess

Vlasnik pitanja

Hi NekoNekoMew

Just for your info, the about:config setting which gets locked is:

browser.warnOnQuit

The browser.tab ones are fine with me too (i.e. can be changed).

So, just to confirm, you've managed to get everything working with 17.0.1 or did you have to roll-back to FF 16 to get the warnings back?


Regards,

Gary

Hi NekoNekoMew Just for your info, the about:config setting which gets locked is: browser.warnOnQuit The browser.tab ones are fine with me too (i.e. can be changed). So, just to confirm, you've managed to get everything working with 17.0.1 or did you have to roll-back to FF 16 to get the warnings back? Regards, Gary
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

I upgraded to 17.0.1 and for a time it seemed to be warning me again; However, it stopped as of this morning and from what i can tell nothing changed. most likely the warnings were a glitch :( so now i'm not being warned again.

I upgraded to 17.0.1 and for a time it seemed to be warning me again; However, it stopped as of this morning and from what i can tell nothing changed. most likely the warnings were a glitch :( so now i'm not being warned again.
NekoNekoMew 1 rješenja 24 odgovora
Objavljeno

so I'm just going to downgrade back to 16.0.2

so I'm just going to downgrade back to 16.0.2
iamjayakumars 493 rješenja 5983 odgovora
Objavljeno

Goto Tools -> Options -> Warn me when closing multiple tabs (check/tick that)

Goto Tools -> Options -> Warn me when closing multiple tabs (check/tick that)