Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube programs won't load in Firefox

  • 11 odgovori
  • 55 ima ovaj problem
  • 10147 views
  • Posljednji odgovor poslao duncanknowles

more options

For months now, when I go to YouTube on Firefox, I get the attached message.

If I go to YouTube using Safari, no problem. I can play the videos without a hitch.

How can I fix this? I LIKE Firefox and would prefer to continue using it.

Thanks, Duncan

Priloženi snimci ekrana

Izabrano rješenje

Did you already upgrade your Firefox 44.0.2 version to the current release?

The System Details list next to the question shows that you run an older Firefox version that is no longer supported with security updates. Please update to the current Firefox 55.0.2 release.

Pročitajte ovaj odgovor sa objašnjenjem 👍 2

All Replies (11)

more options
more options

Fred, thanks for the link. I installed practically every plug in, but nothing helped. I'm not hugely tech savvy, so I appreciate your trying to point me toward a solution. Any specific steps I should take.

I operate on a MacPro with El Capitan 10.11.6.

Thanks, Duncan

more options

Try to uninstall the YouTube Flash Video Player 54.0 since this extension might not be compatible with the changed YouTube behavior. YouTube no longer can be forced to use the Shockwave Flash plugin if that was what you tried to do.

more options

Cor-el, I didn't have YouTube Flash Video Player 54 installed. So that can't be the problem. But I welcome any other ideas you have!

more options

Cor-el, I didn't have YouTube Flash Video Player 54 installed. So that can't be the problem. But I welcome any other ideas you have!

more options

That extension shows in the System Details list next to the question:

  • YouTube Flash Video Player 54.0 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898})

Izmjenjeno od strane cor-el

more options

Cor-el, Sorry to be so dense, but can we start with basics: • Your reply speaks about "that extension" What extension? Is this referring to "YouTube Flash Video Player 54.0"? • You refer to the "System Details". Where are they located? I did a search in Firefox and it indicated there were over 700 references. Which one are you referring to? • The reply says "next to the question." What question does this refer to? • There is a link included in your reply that leads to a lengthy explanation. What specifically would you like me to do there? Thanks for your clarifications and your effort to help me.

more options

Some of your system details are posted when you ask a question. No Personal Information Is Collected. Go to the top right of the page. Open Question details At the bottom of that box, press More system details


Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Look for; YouTube Flash Video Player 54.0 and disable or remove it.

more options

Fred,

Thanks so much for the detailed step-by-step actions. I did them all and disabled YouTube Flash Video Player. I then shut down Firefox and reopened it. But YouTube videos will still NOT play. This is frustrating.

Any other thoughts? I certainly welcome your help. Thank you. Duncan

more options

Odabrano rješenje

Did you already upgrade your Firefox 44.0.2 version to the current release?

The System Details list next to the question shows that you run an older Firefox version that is no longer supported with security updates. Please update to the current Firefox 55.0.2 release.

more options

Dear Cor-el (and Fred). That was the solution!!! I had assumed Firefox was up to date, and it wasn't. I had simply let it slip to where it no longer opened YouTube. So I took your advice and updated it and... YouTube now plays! Thank you, thank you, thank you. I volunteer full time with several nonprofits and when I have to do research in YouTube, I'd prefer to use Firefox on which I keep all my bookmarks. And now I can.

Thank you both again. With warmest good wishes, Duncan