How do I use the Firefox spell checker?

No one has helped translate this article yet. Join us and help get the job done!

Firefox automatically checks the spelling of words that you enter in text boxes containing more than one line. As soon as you finish typing a word, it is checked against the words in the installed dictionary. If the word is not found in the dictionary, it will be underlined in red, as in the following example:

05675f3d603e2607555817580ba1c0c2-1271792700-577-1.png

Note:
  • Automatic spell-checking is only turned on for text boxes containing more than one line, where you can enter as much text as you want.
  • Not all locales come with a dictionary installed due to licensing reasons.

Disabling automatic spell-checking

By default, Firefox is configured to automatically check spelling. You can turn it off in the OptionsPreferences window:

  1. At the top of the Firefox window, click on the Firefox button and then select OptionsAt the top of the Firefox window, click on the Tools menu and then select OptionsOn the menu bar, click on the Firefox menu and select Preferences...At the top of the Firefox window, click on the Edit menu and select Preferences

    Click the menu button New Fx Menu and choose OptionsPreferences

  2. Select the Advanced panel.
  3. Click the General tab.
  4. Uncheck Check my spelling as I type. Spell Checker - Win1
  5. Click OK to close the Options windowClick Close to close the Preferences windowClose the Preferences window
Note: Some options may not appear in the preferences window in custom builds of Firefox.

Correcting misspelled words

When spell-checking is enabled, you can easily correct misspelled words. To correct the misspelled word, right-clickhold down the Ctrl key while you click on it and select one of the suggested words at the top of the menu. 05675f3d603e2607555817580ba1c0c2-1271792700-577-3.png

If none of the suggested words is appropriate, you must manually edit it. If you are sure the word is spelled correctly, you can add it to the dictionary. To add a word to the dictionary, right-clickhold down the Ctrl key while you click on it, and select Add to Dictionary.

Note: Added words apply to all your dictionaries.

Adding dictionaries

You can install other dictionaries as necessary.

  1. Right-clickHold down the Ctrl key while you click in any text box containing more than one line.
  2. Select Languages.
  3. Select Add dictionaries....
    05675f3d603e2607555817580ba1c0c2-1271792700-577-4.png
  4. The Mozilla Add-ons Dictionaries page is displayed. To add a dictionary to your Firefox installation, click the "Install Dictionary" link next to the dictionary you want to add. The Software Installation window appears. When it is displayed, click Install Now, which should open the Add-ons window, where you'll see the dictionary being installed. Spell Checker - Win4
  5. To enable the dictionary, click the Restart Now button, in the Add-ons manager.

Switching dictionaries

After the dictionary is installed, you can switch to it, as needed. To switch to a different installed dictionary, right-clickhold down the Ctrl key while you click in a multi-line field, select Languages, then select the dictionary you want to use.
05675f3d603e2607555817580ba1c0c2-1271792700-577-6.png

Removing a word you have accidentally added

  1. Open your profile folder:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  5. Open the file persdict.dat in a text editor (such as Wordpad).
  6. In the text editor each word you've added is on a separate line. Remove the line, containing the word you wish to remove.
  7. Click the File menu, and select Save, to save your work.
Note: Removed words apply to all your dictionaries.



Share this article: http://mzl.la/LrKs1T

Da li vam je ovaj članak bio od pomoći? Molimo pričekajte...

These fine people helped write this article: Chris_Ilias, Besnik, Verdi, scoobidiver, Swarnava, thomassisson. You can help too - find out how.