Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot open attachments in Hotmail on Firefox for the last couple of weeks. It works fine on Chrome but I don't want to change browsers...Any suggestions?

  • 3 replies
  • 26 have this problem
  • 29 views
  • Last reply by cor-el

more options

Any emails that I receive in hotmail, I can't open the attachments.

It always shows this message at the top of the email:

Windows Live Hotmail was not able to complete this request. Microsoft may contact you about any issues you report.

I tried opening the same attachment in the Chrome Browser in Hotmail and it opened just fine.

Do you have a solution to this problem?

Chosen solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 👍 4

All Replies (3)

more options

Chosen Solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Thank you for your help! I cleared the cache, tried to open an attachment and it worked!

Interesting though, I had cleared my cache etc. just before this started happening.

In any case, I can open attachments now!

Thanks again!

more options

You're welcome