Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloads continuously failing.

  • 4 replies
  • 1 has this problem
  • 4 views
  • Last reply by MathU41

more options

Most notable with videos through Video Downloadhelper, but also program and driver updates. It doesn't seem to depend on the size or even site, but does seem to depend on the time. For example, a 492mb nVidia update downloaded, but a 38mb album on a slower rate will download for several minutes, then fail. Problems seem to occur across any site that takes longer to download. When using Video Downloadhelper, the error detail is "network failed" or just "crash." Only happens after my update to 66.0.5 (along with other problems) but not on the laptop still at 66.0.3

Most notable with videos through Video Downloadhelper, but also program and driver updates. It doesn't seem to depend on the size or even site, but does seem to depend on the time. For example, a 492mb nVidia update downloaded, but a 38mb album on a slower rate will download for several minutes, then fail. Problems seem to occur across any site that takes longer to download. When using Video Downloadhelper, the error detail is "network failed" or just "crash." Only happens after my update to 66.0.5 (along with other problems) but not on the laptop still at 66.0.3

Modified by MathU41

All Replies (4)

more options

Menu > Help > Restart With Add-ons Disabled.

If that helped, it could be one or more Extensions causing the problem:

Your Extensions:

  • Adblock Plus - free ad blocker 3.5.2
  • Bulk Media Downloader 0.2.1
  • Duplicate Tabs Closer 3.3.2
  • Ghostery – Privacy Ad Blocker 8.3.4
  • hotfix-update-xpi-intermediate 1.0.6
  • SoundCloud MP3 Downloader 0.2.0
  • Tab Session Manager 4.5.2
  • Undo Close Tab Button 1.7
  • Video Downloader Pro 1.3.9
  • Video DownloadHelper 7.3.5

AdBlock Plus and Ghostery. Not good to have multiple Ad Blockers. Choose one, get rid of the other. One or more Downloaders can be a problem.

Also, for troubled Websites not opening or are blank (and maybe downloading): See Deleting Site Info.


~Pj

more options

No add-ons, had already cleared history and site info. Didn't think to, after using about the same stuff since FF 32 or so. Tested with an nVidia update (492mb at 3.3mb/s) and an album (71mb at 285kb/s average). Same results. nVidia download completed, album gets about halfway and fails.


A note: In the past, when downloading something that has fully loaded, it seemed to be instant IIRC--like moving from cache to a different file. Now it starts from the beginning every time. Unsure if related.

Modified by MathU41

more options

MathU41 said

No add-ons...


The Forum reported your System Details have the Extensions I listed.


Has your Router/Modem been restarted lately?


~Pj

more options

Pj said

The Forum reported your System Details have the Extensions I listed.

Sorry, pardon my phrasing. I meant I disabled them to check. A modem restart seems to have helped a bit, at least on the smaller downloads. If nothing else, it made them a little quicker. Will try bigger ones as I can. Tough to find (or want) any albums much bigger.

Modified by MathU41