Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo keeps taking over firefox on my Mac

more options

Yahoo keeps taking over firefox on my mac. The only way I have found to stop it is to delete firefox, download it again, and reinstall. That worked well the first couple of times. Now, I need to reinstall every time I try to launch it. I also keep getting redirected to a yahoo dns solutions page saying safe search is active. The first few times I could turn off safe search. That option is gone now.

All Replies (4)

more options

What page have you set as your home page and what search engines have you nominated in the search preference settings?

Perhaps remove Yahoo completely from the search preferences, or at least untick it and if you have Yahoo set as your home page, maybe remove that too and click on "Restore to Default" for your home page. That will always open Firefox's start page.

Let us know if that works

more options

You allowed it to somehow, try to find the root of the issue, isolate it and get rid of it.

What I would do:

Check your settings, clear your caches, regardless of what they are for.

It sounds like you have a malware issue.

By any chance have you installed anything recently without reading what it does? Maybe an extension or program on your computer? I would try to delete that if you don't recognize it, but be extremely careful what you delete. If you accidentally delete a system process your operating system will not run correctly. Also, if you recently updated some sort of program on your computer that could be a compatibility issue.

I'm leaning towards an isp problem as you mentioned dns. Either that or it's yahoo themselves. I don't know, that's your pc not mine.

Anyways, goodluck and with enough determination I'm sure you can figure it out.

more options

Yes, it could be a malware issue. Running your security software might help.

Otherwise, previous history of this problem suggests the possibility of an unwanted Add-on or extension.

  • Open the Firefox menu and click on the help question mark.
  • Select from the drop-down list Restart Firefox with Add-ons Disabled. That opens Firefox's Safe Mode dialogue and will allow you to restart Firefox in Safe Mode where you can remove any offending extensions.

After Firefox has restarted in Safe Mode has the problem stopped? If so, then the issue is being caused by an Add-on or an extension, because in Safe Mode these are all disabled. Go then to your Add-on library, open it and remove any unwanted extensions, plug-ins or add-ons.

Close Firefox properly by clicking on the exit button at the bottom right corner of the Firefox menu and restart Firefox in normal mode.

If the problem persists, repeat the above action or alternatively disable your remaining extensions/add-ons one by one, until you eliminate the problem extension/add-on/plug-in.

Modified by Dingeroo

more options

yahoo dns solutions page

Who is your Internet Service Provider aka ISP? Does that ISP have a relationship with Yahoo, like for web mail?

Here's an old support thread -http://www.dslreports.com/forum/r24470196-Qwest-DSL-DNS-Issue-Redirection - about DNS redirection involving Quest and Yahoo.

And this blog posting - http://hackercodex.com/guide/how-to-stop-isp-dns-server-hijacking/ - about ISP DNS hijacking in general.

Probably way over your head, but there is probably an easy opt-out for that "service" thru your ISP.