Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Default Character Encoding stuck on UTF-8 - Firefox 7

  • 1 отговор
  • 8 имат този проблем
  • 18 изгледи
  • Последен отговор от cor-el

more options

I cannot change the Character Encoding - it is stuck on Unicode UTF-8 and I can not change it! When a web page opens I get these little boxes with "FF FD" instead of Quote marks. When I change the character encoding on that page using "View->Character Encoding" and click on the Western (ISO-8859-1), the page displays correctly. Every page opens using Unicode UTF-8 as the default.

View->Character Encoding -- shows Unicode UTF-8 as the default. View->Character Encoding->Auto-detect -- shows OFF

Tool->Options->Content->Advance->Fonts->Default Character Encoding -- shows Western (ISO-8859-1) as well as the "Allow Pages to choose their own fonts..." IS CHECKED in the check box

THE PAGES ARE NOT UTF-8!!!! The "View Page Source" IS NOT Unicode UTF-8! -- It shows <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">.

The "View Page Info" shows MetaTag - Content-Type: text/html; charset=iso-8859-1

Why can I not change the Default Character Encoding?

I would also like to point out that the Unicode UTF-8 seems to be broken because it is indicating that the QUOTE CHARACTER is an UNPRINTABLE character "FF FD"


EDIT -----

The UTF-8 is not broken. The problem as pointed out in http://en.wikipedia.org/wiki/Replacement_character#Replacement_character is that my Firefox being STUCK processing UTF-8 encoding cannot read the clearly marked iso-8859-1 data. So the UTF-8 is reinterpreting smart quotes -“ and ”- (“ and ”) as replacement (unprintable) characters.

So the real problem is why my Firefox is stuck on Unicode UTF-8

I cannot change the Character Encoding - it is stuck on Unicode UTF-8 and I can not change it! When a web page opens I get these little boxes with "FF FD" instead of Quote marks. When I change the character encoding on that page using "View->Character Encoding" and click on the Western (ISO-8859-1), the page displays correctly. Every page opens using Unicode UTF-8 as the default. View->Character Encoding -- shows Unicode UTF-8 as the default. View->Character Encoding->Auto-detect -- shows OFF Tool->Options->Content->Advance->Fonts->Default Character Encoding -- shows Western (ISO-8859-1) as well as the "Allow Pages to choose their own fonts..." IS CHECKED in the check box THE PAGES ARE NOT UTF-8!!!! The "View Page Source" IS NOT Unicode UTF-8! -- It shows <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">. The "View Page Info" shows MetaTag - Content-Type: text/html; charset=iso-8859-1 Why can I not change the Default Character Encoding? I would also like to point out that the Unicode UTF-8 seems to be broken because it is indicating that the QUOTE CHARACTER is an UNPRINTABLE character "FF FD" ----- EDIT ----- The UTF-8 is not broken. The problem as pointed out in http://en.wikipedia.org/wiki/Replacement_character#Replacement_character is that my Firefox being STUCK processing UTF-8 encoding cannot read the clearly marked iso-8859-1 data. So the UTF-8 is reinterpreting smart quotes -&ldquo; and &rdquo;- (“ and ”) as replacement (unprintable) characters. So the real problem is why my Firefox is stuck on Unicode UTF-8

Променено на от CaptainCosmic

Всички отговори (1)

more options

The real problem is that the font that is used doesn't have those characters.

Do you see the special quotes -“ and ” on this forum page?

Does it help if you disable the website fonts and set another font as the default font?

  • Tools > Options > Content : Fonts & Colors > Advanced