Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Firefox CPU usage increases dramatically while playing YouTube videos full-screen

  • 1 отговор
  • 1 има този проблем
  • 2 изгледи
  • Последен отговор от TyDraniu

more options

I'm using Firefox v 83.0 on Manjaro (Gnome) Linux. YouTube videos in theater/full-screen mode lag if resolution is higher than 360p and cause the CPU usage to burst. This happens for large web pages as well: when I scroll the page, text overlaps and everything is terribly slow. I've checked and this seems to be a Firefox related problem; videos play smoothly both on VLC and Chromium. I've tried all official troubleshooting suggestions: changing to default theme, refreshing Firefox, starting in safe-mode, disabling extensions, disabling hardware acceleration and so on, with no success. I've never had any problems with Firefox for Linux before and I wonder what could be the cause.

I attached screenshots for comparison of CPU usage for the same video playing in theater mode in Firefox and Chromium.

I'm using Firefox v 83.0 on Manjaro (Gnome) Linux. YouTube videos in theater/full-screen mode lag if resolution is higher than 360p and cause the CPU usage to burst. This happens for large web pages as well: when I scroll the page, text overlaps and everything is terribly slow. I've checked and this seems to be a Firefox related problem; videos play smoothly both on VLC and Chromium. I've tried all official troubleshooting suggestions: changing to default theme, refreshing Firefox, starting in safe-mode, disabling extensions, disabling hardware acceleration and so on, with no success. I've never had any problems with Firefox for Linux before and I wonder what could be the cause. I attached screenshots for comparison of CPU usage for the same video playing in theater mode in Firefox and Chromium.
Прикачени екранни снимки

Всички отговори (1)

more options

This error message is suspicious: "Acceleration blocked by platform". Your Firefox doesn't use GPU.

Try to enter about:config and set layers.acceleration.force-enabled = true, then restart the browser.