Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Firefox 40.0.3 Flash player works with - No Flash player installed

  • 7 отговора
  • 1 има този проблем
  • 2 изгледи
  • Последен отговор от newusermozila

more options

Hello -

Hope you well -

I was using a older version of Mozilla firefox. Now - I updated and installed the new Firefox 40.0.03.

Please NOTE: I do NOT have flash player installed. On the older version of firefox - The page used to ask me to install flash player.

When I installed the new 40.0.03 firefox -- and for eg. - when I open Firefox, it starts playing a youtube video - Even though I do NOT have flash player installed.

Does this new Firefox 40.0.03 - Have a Automatic built in flash player -- It would obviously make sense -- as I do Not have flash player installed.

How - do I disable - the Flash player built in - in the firefox?

Kindly advise --

Regards Naeem

Всички отговори (7)

more options

YouTube likely defaults to the HTML5 media player and doesn't use Flash in current Firefox releases.

What media player is used if you check this via the right-click context menu of the player area? Is that the HTML5 media player?

A Flash player will show a Flash context menu.

more options

Firefox 41.0 has been the current Release since Sept 22 from mozilla.org as the 40.0.3 was the previous.

Some sites use a HTML5 player which does not need the Flash Player Plugin installed on system to work. Some sites may even have a mix as Twitch.tv uses HTML5 for chat and controls but still has Flash player embedded (for majority of streams) until they have HTML5 for player in use also.

Firefox for any OS never came with Flash Player due to size and license/costs and such.

more options

Hi - Thanks for the info.

However -- In the previous firefox that I had -- I downloaded a firefox add-n - that is image and flash blocker. When I switched the flash off - then, it disabled the flash -> that is the youtube video did Not open.

In this case of html5 -- How do I disable it, that the video does Not open auto?

more options

You can set media.autoplay.enabled to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thanks cor-el

I put it on false -- and - now it blocks the youtube from opening.

Would you perhaps know : I have image blocker -- I set it on off -- so when I open websites, then All images are blocked (to save on data costs) But -- When I search anything on google -- then google opens images auto.

Would you know why google does this when image is blocked and all other websites don't open the images when I block it. Is this the same problem like the html5

more options

The only explanation that I know would be that Google uses JavaScript XHR to retrieve the images and that this bypasses the extension. I don't know if an extension like Adblock Plus could block such image requests.

more options

Cor-el -- I just checked the youtube -- again.

I put the thing you said - on false. It stops the video from opening.

However -- My data cost - went about 50Mb -- and the strangest thing is that the video did Not open -- But - If the video opens - then it would eat up the same data.

What is going on -- That - even though the video does Not open -- the data costs are running as If the video was opening. When I open the youtube - it just shows a youtube image - But does Not open the video