Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Where is the option “Unicode” in “Character Encoding for Legacy Content”?

  • 5 отговора
  • 10 имат този проблем
  • 8 изгледи
  • Последен отговор от YetAnotherUsername

more options

In “Character Encoding for Legacy Content” (cf. https://support.mozilla.org/en-US/kb/settings-fonts-languages-and-pop-ups) there is no option to select “Unicode (UTF-8)” for pages that do not specify a default encoding.

Even though my setting is set to “default value for the current language”, I have no clue what this default value is and where to set it. For the record, my LANG environment variable is set to “fr_FR.UTF-8”. Maybe it refers to “Languages” in the same dialog, but this option does not offer the possibility to choose the caracter encoding and is set to “en-us“.

In the end, I have pages displayed with some kind of ISO-8859-* when they are in UTF-8. Adding a html meta tag or altering the HTTP headers is not an option for me.

In “Character Encoding for Legacy Content” (cf. https://support.mozilla.org/en-US/kb/settings-fonts-languages-and-pop-ups) there is no option to select “Unicode (UTF-8)” for pages that do not specify a default encoding. Even though my setting is set to “default value for the current language”, I have no clue what this default value is and where to set it. For the record, my LANG environment variable is set to “fr_FR.UTF-8”. Maybe it refers to “Languages” in the same dialog, but this option does not offer the possibility to choose the caracter encoding and is set to “en-us“. In the end, I have pages displayed with some kind of ISO-8859-* when they are in UTF-8. Adding a html meta tag or altering the HTTP headers is not an option for me.

Всички отговори (5)

more options

Legacy Content is about 8 bit Windows and Western encoding and Unicode is not part of this. Unicode is used when the server sends this encoding or you can select it via View > Character Encoding if the wrong choice is made.

Did you check how the server is sending the pages that are shown as a Western (ISO-8859) encoding?

more options

The protocol used to access the files is not HTTP but “file:” (i.e. they are local files). The Firefox page information says it's windows-1252 encoded, but I don't know how this could be infered in a linux system using UTF-8 everywhere. How can I check that my system is sending this information (if it does)?

(The “file” comand output for the documents is “HTML document, UTF-8 Unicode text, with very long lines”, mime type is “text/html” and mime encoding “utf-8”.)

I know I can use the new button “Character Encoding” to change encoding, but I SHOULD NOT have to do it for every file. That it is a real pain in the ass is not even relevent.

If ”legacy content” is not the setting I am looking for, what is the setting to set a default encoding when none is specified?

I am not sure this will help, but Chromium and Lynx are displaying correctly the files.

more options

Променено на от Aleksej

more options
more options

Thanks for pointing me to this bug report. Somehow I managed not to find it.

Too bad there is no workaround in the comments. I guess I'll change my default browser for local files.

Променено на от YetAnotherUsername