On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot disable fullscreen animation (F11)

  • 5 cavab
  • 2 have this problem
  • 7 views
  • Last reply by cor-el

more options

Hi, I'd like to disable that annoying animation when going to fullscreen (by hitting F11). Supposedly, setting the following should work:

Go to about:config

Set: full-screen-api.transition-duration.enter 0 0 full-screen-api.transition-duration.leave 0 0 full-screen-api.transition.timeout 0 full-screen-api.warning.delay 0 full-screen-api.warning.timeout 0

Restart

However, this does not have any effect in Firefox 94.0 on Ubuntu. Is this a bug/regression? Or is there some other way to disable the animation?

Hi, I'd like to disable that annoying animation when going to fullscreen (by hitting F11). Supposedly, setting the following should work: Go to about:config Set: full-screen-api.transition-duration.enter 0 0 full-screen-api.transition-duration.leave 0 0 full-screen-api.transition.timeout 0 full-screen-api.warning.delay 0 full-screen-api.warning.timeout 0 Restart However, this does not have any effect in Firefox 94.0 on Ubuntu. Is this a bug/regression? Or is there some other way to disable the animation?

All Replies (5)

more options

PS.: I also have toolkit.cosmeticAnimations.enabled = false, to no effect as well.

more options

See:

Note that toolkit.cosmeticAnimations.enabled isn't supported for quite some time and you can reset this pref (click the trashcan).

more options

@cor-el

This option is missing from my about:config. Searching for "motion" brings up only these options:

device.sensors.motion.enabled false general.smoothScroll.msdPhysics.continuousMotionMaxDeltaMS 120 general.smoothScroll.msdPhysics.motionBeginSpringConstant 1250 layout.css.motion-path-ray.enabled false layout.css.motion-path.enabled false

more options

I'm on FF 100.0.1 64-bit.

more options

You can paste ui.prefersReducedMotion in the search bar on the about:config page and create a new Number pref by clicking the '+'. Set its value to '1' by double-clicking thprefersReducedMotionref line and click the OK button to confirm the change.