Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to enable a spell checker to work on all web pages in firefox

  • 4 cavab
  • 15 have this problem
  • 365 views
  • Last reply by gsc316

more options

i reinstalled firefox and now the spell checker dosent work,

ive tried, checking the "check my spelling" box in the options menu, that didnt work.

ive tried right clicking on a text field and ther is no option for "check my spelling"

and ive tried changing the "layout.spellcheckDefault" value to 1 and 2, no joy....anyone else had this scenario happen to them?

oh and appologies for any missspelt words in this question but im sure u can understanb. cheers

i reinstalled firefox and now the spell checker dosent work, ive tried, checking the "check my spelling" box in the options menu, that didnt work. ive tried right clicking on a text field and ther is no option for "check my spelling" and ive tried changing the "layout.spellcheckDefault" value to 1 and 2, no joy....anyone else had this scenario happen to them? oh and appologies for any missspelt words in this question but im sure u can understanb. cheers

Chosen solution

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> Advanced: General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:


It is possible that the website disables the Firefox spell checker by adding a spellcheck = "false" attribute to the text area. You can check that in the builtin Inspector.

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

Read this answer in context 👍 1

All Replies (4)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Type:’’'layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

more options

Seçilmiş Həll

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> Advanced: General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:


It is possible that the website disables the Firefox spell checker by adding a spellcheck = "false" attribute to the text area. You can check that in the builtin Inspector.

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

more options

thanx fred but ive tried that already...

more options

thanx for ur reply cor-el downloading some dictionary's and language pack seems to have worked. :)