My tab delete X turns into a 1 pixel point

I had a similar problem last year when an auto update came through. After several suggestions didn't help I opted to reinstall a previous version and upgrade that. Now it… (read more)

I had a similar problem last year when an auto update came through. After several suggestions didn't help I opted to reinstall a previous version and upgrade that. Now it's back again with the v94 update.

I've disabled ALL extensions. No help. Themes don't seem to make a difference. However, when I went to about:config and entered "toolkit.legacyUserProfileCustomizations.stylesheets" to make it true to allow chrome.css files to work it began immediately. Reset it to false and "X"s are back. Set config to TRUE and it screws up the "X"s. Again, all this is with all extensions off.

I hate the transparency of the tabs and menu bars so I need to set .css files. How else can I do it?

Asked by Doc 22 hours ago

Last reply by jscher2000 2 minutes ago

Proton and userchrome

It took years to perfect my userchrome to make FF look exactly how I want. Once 91+ came out it wasn't even a question of fixing the floating tabs and condensing the heig… (read more)

It took years to perfect my userchrome to make FF look exactly how I want. Once 91+ came out it wasn't even a question of fixing the floating tabs and condensing the height and menu spacing (though I tried all of it) but my own codes stopped working properly - I had code to set the background colour of menus/bookmark menus and when I upgrade they were the right colour but with thick white borders around them. This was more important to me than the floating tabs and I immediately downgraded to 90 where I've stayed. Can anyone help me figure out how to get MY codes to work with 91+ and/or to work together with the other fixes out there (tabs, condensed menus etc)??

Below is how my userchrome looks and attached is how my current set up looks. ANY advice is appreciated. THANK YOU.

@import url(userChrome_Fx56_bookmark_icons.css);
*/

/* Standard folder -- on Toolbar and Menus */
#PlacesToolbarItems toolbarbutton[container="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"]:not([tagContainer="true"]) > .menu-iconic-left,
/* Standard folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList) treechildren::-moz-tree-image(container), 
#editBMPanel_folderMenuList > .menulist-label-box > .menulist-icon,
#editBMPanel_folderMenuList menupopup menuitem {
  list-style-image: url(Fx56-yellow-folder.png) !important;
}

/* THIS WAS REMOVED BECAUSE IT CAUSES YELLOW FOLDER ICONS FOR BLANK 
   COLUMNS. AS A RESULT, FOLDERS ON THE RIGHT SIDE REMAIN GRAY.
  #placeContent treechildren::-moz-tree-image(container) {
    list-style-image: url(Fx56-yellow-folder.png) !important;
  }
*/

/* Live Bookmark -- on Toolbar and Menus */ /* REMOVED */

/* Smart bookmark folder -- on Toolbar and Menus */
#PlacesToolbarItems toolbarbutton[container="true"][query="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][query="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"][query="true"]:not([tagContainer="true"]) > .menu-iconic-left > .menu-iconic-icon,
/* Smart bookmark folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, query) {
  list-style-image: url(Fx56-query.png) !important;
}

/* Tag containers (preserve the built-in icon) */
#PlacesToolbarItems toolbarbutton[container="true"][tagContainer="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][tagContainer="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"][tagContainer="true"] > .menu-iconic-left > .menu-iconic-icon,
/* Smart bookmark folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, query, tagContainer) {
  list-style-image: url(chrome://browser/skin/places/tag.svg) !important;
}

/*** Top-level "container" icons (otherwise would be Standard folder color) ***/
/* Bookmarks Menu -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksMenu),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_menu________),
#editBMPanel_bmRootItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="1"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-bookmarksMenu.png) !important;
}

/* Bookmarks Toolbar -- on Menus */
#BMB_bookmarksPopup #BMB_bookmarksToolbar > .menu-iconic-left > .menu-iconic-icon,
#bookmarksMenuPopup #bookmarksToolbarFolderMenu  > .menu-iconic-left > .menu-iconic-icon,
/* Bookmarks Toolbar -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksToolbar),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_toolbar_____),
#editBMPanel_toolbarFolderItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="0"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-bookmarksToolbar.png) !important;
}

/* Other Bookmarks -- on Menus */
#BMB_bookmarksPopup #BMB_unsortedBookmarks > .menu-iconic-left > .menu-iconic-icon,
#bookmarksMenuPopup #menu_unsortedBookmarks  > .menu-iconic-left > .menu-iconic-icon,
/* Other Bookmarks -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_UnfiledBookmarks),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_unfiled_____),
#editBMPanel_unfiledRootItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="2"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-unsortedBookmarks.png) !important;
}  

/* Preserve Built-in History/Tags/All Bookmarks Icons in Library */
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_history____v), 
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(title, query, dayContainer) {
  list-style-image: url("chrome://browser/skin/places/history.svg") !important;
}
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(title, query, tagContainer),
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_tags_______v) {
  list-style-image: url("chrome://browser/skin/places/tag.svg") !important;
}
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_allbms_____v) {
  list-style-image: url(Fx56-allBookmarks.png) !important;
}


}

menupopup {
-moz-appearance: none !important;
background-color: #e7d9ad !important }


#urlbar[breakout],
#urlbar[breakout][breakout-extend] {
  --urlbar-height: 28px !important;
  --urlbar-toolbar-height: 30px !important;

  width: 100% !important;
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-input-container,
#urlbar-input-container {
  height: var(--urlbar-height) !important;
  width: 100% !important;
  padding-block: unset !important;
  padding-inline: unset !important;
  transition: none !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-background {
  box-shadow: 0 1px 4px rgba(0,0,0,.05) !important;
  animation: none !important;
}


}
/* REMOVE MEGABAR END */

Asked by M 1 week ago

Last reply by M 6 minutes ago

  • حُلّت

When clicking on a custom shortcut for Private Browsing window, Firefox opens a regular window next to it

Hello! I am using Firefox ESR in Linux Mint 18.3 32-bit. For convenience, a few years ago I've created a start menu (main menu) shortcut to quickly open a Private Browsi… (read more)

Hello! I am using Firefox ESR in Linux Mint 18.3 32-bit. For convenience, a few years ago I've created a start menu (main menu) shortcut to quickly open a Private Browsing window. Before the recent switch from ESR branch 78 to 91 this shortcut was working as intended, but now, it opens a Private Browsing window and a regular browsing window. Here, I've made a short video about this issue that should help to better explain everything https://youtu.be/ccioyh0gJxA https://youtu.be/ccioyh0gJxA To some, this might seem like a non-issue, but I'd like to have a shortcut that would allow me to launch a Private Browsing window and a Private Browsing window alone.

Asked by Firefox-VM 23 hours ago

Answered by Firefox-VM 29 minutes ago

firefox browser issue.

Have latest version of browser running on Windows 11 Pro with all updates. All websites work fine except for Houston Chronicle Paper. Contacted them and they see no prob… (read more)

Have latest version of browser running on Windows 11 Pro with all updates. All websites work fine except for Houston Chronicle Paper. Contacted them and they see no problems on there end. Suggested deleting cookie and cache which I did. Site is slow loading pages and the refresh button on top left page is always blinking. Exiting and restarting the browsing of the paper several times get me through it. Any thoughts?? Michael Lindley

Asked by mhlindley 33 minutes ago

Firefox Library background colour

Hi, I realise this sort of thing is not exactly the end of the world but I'll ask anyway. In Proton, the background of the Settings page, about:config page and the Librar… (read more)

Hi, I realise this sort of thing is not exactly the end of the world but I'll ask anyway. In Proton, the background of the Settings page, about:config page and the Library window have changed to black [with white text]. Before, everything was white background with black text...is there any way at all to go back to that, without changing the Theme that I've been using for years? The Firefox colour settings change the Settings and about:config pages background to white but then you have the glaring white high contrast etc on every web page...and it still has a black background in the Library window, regardless of what colour settings I have there. I can change all this easily with some other theme or that Firefox Color addon [which is how I got the second picture below] but if that's the only option I would rather just put up with it as it is.

First pic is how it is now, second is how it always was before Proton and I want it to be again.

Thanks

Asked by Haruna 38 minutes ago

FF94 I messed up, now I can't import password .csv file

After reading up on procedures (but failing to follow links), I decided to completely delete all my passwords. Let me back up a minute, last week I downloaded the .csv fi… (read more)

After reading up on procedures (but failing to follow links), I decided to completely delete all my passwords. Let me back up a minute, last week I downloaded the .csv file of my passwords, because after 10 or 12 years, I needed to clean them up. I had 486 saved passwords, out of which I deleted all but 123. I did not want to try that in the browser, actually I did, but after about 20 I gave up because I realized how long it would take.

So anyway, I got ready to finish up, and I deleted my browser copy, then tried to upload the corrected copy. However every time I get an error "Something went wrong try again". So as my plan was, I deleted my Chrome passwords (they should be the same), then uploaded the corrected copy. It said "Upload successful" or somethiing like that, I waited five minutes, for Chrome to finish syncing and all that, then tried to import from Chrome, it imported 3 passwords.

But now, here's the big problem, I follow the directions I have found in this site, but once I click the hamburger, the next link does not exist. When I go another way, none of the links exist. I have searched all over the settings pages, and nowhere is there the option to upload a .csv file, I can import from another browser all day, but not upload. So what's going on?

Asked by 1971robby 1 hour ago

open attachments in Thunderbird email

All of a sudden I can't open any attachments to my email. When I try to open, it sends me to download Firefox. I already have Firefox installed, and still can't open atta… (read more)

All of a sudden I can't open any attachments to my email. When I try to open, it sends me to download Firefox. I already have Firefox installed, and still can't open attachments.

Asked by durette 1 hour ago

Disconnecting from Gmail and Google.com

Only when using my Firefox in windows on my PC. After I am connected to my Gmail for a short period of time, it stops working and then I see a banner at the top that read… (read more)

Only when using my Firefox in windows on my PC. After I am connected to my Gmail for a short period of time, it stops working and then I see a banner at the top that reads that it is disconnected. It will not reconnect until I close Firefox and then reopen it. I have checked everything including a uninstall and then reinstalling Firefox. Can someone help me?

Asked by Jerry's FireFox 1 day ago

Last reply by Jerry's FireFox 2 hours ago

Unable to sign in to Microsoft account with Firefox

I am unable to sign in to the Microsoft Forum using Firefox. Edge works fine. I get a message about my account not existing (anonymised): Sorry, but we’re having trouble… (read more)

I am unable to sign in to the Microsoft Forum using Firefox. Edge works fine. I get a message about my account not existing (anonymised):


Sorry, but we’re having trouble with signing you in. AADSTS50020: User account '******@yahoo.***' from identity provider 'live.com' does not exist in tenant 'Microsoft Services' and cannot access the application '99adaf47-f643-4c0e-8117-15335c87ebda'(Microsoft Community) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account.


Troubleshooting details If you contact your administrator, send this info to them. Copy info to clipboard Copied Request Id: 269a3d29-2f6d-43f6-af76-5ccc8bcd9e01 Correlation Id: 37f9d534-7bfb-4ea5-9fba-b171e0bd8a97 Timestamp: 2021-12-02T19:41:32Z Message: AADSTS50020: User account '******@yahoo.***' from identity provider 'live.com' does not exist in tenant 'Microsoft Services' and cannot access the application '99adaf47-f643-4c0e-8117-15335c87ebda'(Microsoft Community) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account. Flag sign-in errors for review: Enable flagging If you plan on getting help for this problem, enable flagging and try to reproduce the error within 20 minutes. Flagged events make diagnostics available and are raised to admin attention.

Asked by Ed W 2 hours ago

Force redirect to HTTPS in new release to site with no security certificate

After the latest release of Firefox, it is automatically forcing https on our site EquestrianCoach.com. We do not have a security certificate at this time (yes I know we … (read more)

After the latest release of Firefox, it is automatically forcing https on our site EquestrianCoach.com. We do not have a security certificate at this time (yes I know we need one and we are working on it). Therefore we get a "Warning: Potential Security Risk Ahead" page and no one can access the site. Even if you manually try to take out the "s" it directs right back to https. I heard Firefox does this if it detects a SSL, but again, we do not have one or never did for this site. I see other sites with no ssl work fine. Is there a work around to not have Firefox do this? All the legacy Firefox browsers work fine on our site. It was just with the last release it somehow seems to think we have one and force redirects. And to clarify, it isn't just on one computer. All members who have the new Firefox have this issue. Thank you for any assistance! It is greatly appreciated!

Asked by anna53 3 hours ago

Firefox browser (88.0.1) - Warning: Potential Security Risk Ahead

When receiving the following messages when accessing a specific URL. Warning: Potential Security Risk Ahead Firefox detected a potential security threat and did not conti… (read more)

When receiving the following messages when accessing a specific URL.

Warning: Potential Security Risk Ahead Firefox detected a potential security threat and did not continue to xyz. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.

Then clicking on the Advanced... button at the bottom of the popup window.

And then clicking on the Accept the Risk and Continue button.

My question is does Firefox make any changes to Internet Options or anywhere else, including within Firefox to change configurations of any type when the Accept the Risk and Continue button is clicked on?

Thank you!

Asked by TRC 9 hours ago

Last reply by jscher2000 3 hours ago

None of my streaming services are working since the last update. What have you done to Firefox?

Why can't i use any of my streaming services? All of a sudden they are telling me I need the latest version and I have the latest version. It started with Netflix and n… (read more)

Why can't i use any of my streaming services? All of a sudden they are telling me I need the latest version and I have the latest version. It started with Netflix and now others are not working and giving me the same message. It seems your last update caused more problems than it solved.

Asked by Denine Personal 1 day ago

Last reply by cor-el 3 hours ago

  • حُلّت

uninstalled firefox due to error message that didn't go away with restart

Opening up firefox last week am a message saying something was wrong/couldn't proceed (I don't remember the exact text). I tried to delete the message, but it just came b… (read more)

Opening up firefox last week am a message saying something was wrong/couldn't proceed (I don't remember the exact text). I tried to delete the message, but it just came back every time blocking opening firefox. I tried to restart it, but the same blocking message reappeared. I then uninstalled it and all my files disappeared, of course. I've today reinstalled it, but no history, etc.. How can I get my original web files back? Do you have a 30 day grace period where any file can be restored like the one Microsoft has? Can I get my webfiles back at all? Please help. tmr W10 64bit

Asked by torrasmussen 10 hours ago

Answered by jscher2000 5 hours ago

Dropdown selection

I know this is probably an odd issue. I have a website that I use frequently and one of the drop down boxes on the website changes the selection I make automatically if I… (read more)

I know this is probably an odd issue. I have a website that I use frequently and one of the drop down boxes on the website changes the selection I make automatically if I move from one screen to the next then back again. What would cause this issue?

I have cleared everything from the browser and done a refresh. I also cleared the startup cache. The refresh corrected the issue for a few hours but then it started again. Clearing the startup cache worked for about 5 minutes then it started again.

Any suggestions would be greatly appreciated.

Thank you.

Asked by shartsfield 4 hours ago

Last reply by shartsfield 3 hours ago