Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Font incorrectly rendered in Firefox, but looks OK in private mode

more options

Over the past day or two, I've seen firefox incorrectly render fonts on a couple of websites. So far, I've only noticed two websites effected: quotientapp.com and xero.com (not the actual landing page, but rather the login page and other pages available after login https://login.xero.com/identity/user/login). This problem may extend deeper but these are the only places I've found them.

At first I thought my eyes were playing tricks on me but nope, something definitely not right. No new addons have been installed on my system. I've also deleted all local storage / cookies (via the Inspector) for these sites thinking it must be some caching issue - but no, it's still doing it.

Inspecting the font-family shows the issue (this is from the page https://go.quotientapp.com/sign-in) - have attached the images below of what I see.

I do use uBlock, but it is disengaged on Quotient and Xero (these are work related sites, they show no ads). Other add-ons I have installed include Bitwarden, Dark Reader, Firefox Multi-Account Containers and Reddit enhancement suite. I've ensured all add-ons are up to date as of this posting.

FWIW I do allow all the extensions above (with the exception of Firefox Containers which I don't allow) in private mode.

Any insights on how to get to the bottom of this?

Over the past day or two, I've seen firefox incorrectly render fonts on a couple of websites. So far, I've only noticed two websites effected: quotientapp.com and xero.com (not the actual landing page, but rather the login page and other pages available after login https://login.xero.com/identity/user/login). This problem may extend deeper but these are the only places I've found them. At first I thought my eyes were playing tricks on me but nope, something definitely not right. No new addons have been installed on my system. I've also deleted all local storage / cookies (via the Inspector) for these sites thinking it must be some caching issue - but no, it's still doing it. Inspecting the font-family shows the issue (this is from the page https://go.quotientapp.com/sign-in) - have attached the images below of what I see. I do use uBlock, but it is disengaged on Quotient and Xero (these are work related sites, they show no ads). Other add-ons I have installed include Bitwarden, Dark Reader, Firefox Multi-Account Containers and Reddit enhancement suite. I've ensured all add-ons are up to date as of this posting. FWIW I do allow all the extensions above (with the exception of Firefox Containers which I don't allow) in private mode. Any insights on how to get to the bottom of this?
Attached screenshots

الحل المُختار

SamPilgrimsTooth said

But in non-private mode, it shows Helvetica / Nimbus Sans L Bold Condensed (which is incorrect).

Your screenshots show the font-family should prefer Helvetica which is what it is doing. Private windows use Arial as a fallback due to anti-fingerprinting protections reducing the number of visible fonts. If you want to extend this to normal windows, you can enable Strict Tracking Protection.

Read this answer in context 👍 1

All Replies (7)

more options

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the down arrow at the right end.

Helpful?

more options

Thanks for the response -- there is something definitely wrong. The font family for private mode shows "Arial / Arial Bold", i.e. what it should be. But in non-private mode, it shows Helvetica / Nimbus Sans L Bold Condensed (which is incorrect).

Interestingly only these two websites (Xero and Quotient) are impacted.

I went to about:config, where I used the "Restart with all add-ons disabled" option.

I found that everything now works as expected. So, I went back to my profile with the add-ons enabled - I disabled every single one, and restarted Firefox -- the font is still incorrect.

So, in addition to disabling my extensions, exactly what does the "Restart with all add-ons disabled" option do?

There is clearly some issue within my profile - I don't want to reset it just yet as I have a terrible habit of using my history as my bookmarks so I will reserve the "nuclear" option of refreshing firefox as the last resort.

Helpful?

more options

Could be a case with fonts that are blocked by Enhanced Tracking Protection under Known fingerprinters and Suspected fingerprinters.

Helpful?

more options

I'm completely out of ideas on this one -- I created a brand new FF profile and it STILL does it!!

What else is there to try? Creating a new firefox profile is the nuclear option right? No firefox "Common" settings are shared between profiles are they?

Helpful?

more options

Bump -- I have still not managed to resolve this.

Any ideas where these "extra" fonts are coming from? I did a full rebuild of my firefox profile, tried it in a container tab, removed all extensions without success.

It still renders properly in Private mode. Below is a screenshot of the inspector "Font" section on the same page -- left side is Private mode, right side is my normal profile.

Any ideas @cor-el?

Modified by SamPilgrimsTooth

Helpful?

more options

الحل المُختار

SamPilgrimsTooth said

But in non-private mode, it shows Helvetica / Nimbus Sans L Bold Condensed (which is incorrect).

Your screenshots show the font-family should prefer Helvetica which is what it is doing. Private windows use Arial as a fallback due to anti-fingerprinting protections reducing the number of visible fonts. If you want to extend this to normal windows, you can enable Strict Tracking Protection.

Helpful?

more options

Thanks Zeroknight, your reply fixed it for me. I changed tracking protection from "Standard" to "Strict".

Perplexing that INCREASING protection to a degree where it warns you that it may break some content "fixes" this?

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.