ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Push notifications

  • 4 ردود
  • 1 has this problem
  • 81 views
  • آخر ردّ كتبه James

more options

I checked the box in privacy settings to "Block new requests asking to allow notifications". But I am constantly asked by multiple web sites if I will allow them to send me notifications. I despise the very idea of push notifications and will never use them or allow them. If this option in settings does not work, then why is it there? Is there a way to make the browser impervious to push notification requests?

I checked the box in privacy settings to "Block new requests asking to allow notifications". But I am constantly asked by multiple web sites if I will allow them to send me notifications. I despise the very idea of push notifications and will never use them or allow them. If this option in settings does not work, then why is it there? Is there a way to make the browser impervious to push notification requests?
Attached screenshots

All Replies (4)

more options

This statement is false and does not assist in troubleshooting the issue. I only attached two screenshots. The first is an example site showing the behavior I am seeing. The second is not from a site, but from Firefox settings.

After further research I found two settings in about:config that stopped additional pop ups once I changed them to False. dom.webnotifications.serviceworker.enabled dom.webnotifications.enabled

I should not have to go into about:config to stop these annoying push notification messages from coming up. If the checkbox in the Privacy Permissions setting does not work, then why is it there? This seems like a design flaw that should be rectified.

more options

A service worker is a background process that sites can create using one of their scripts. For future reference, you can open the about:serviceworkers page to review currently registered workers and disconnect any you do not want running.

But that first dialog you saw was not Firefox's built-in dialog to grant the site permission. The built-in icon/dialog are pictured in the attached screenshot composite. The one you saw is a trick dialog that leads to a download (for purposes I did not investigate). It's good that you found a way to block that trick dialog, although I don't know why totally disabling webnotifications has that effect. Maybe their script has a bug?

more options

Thanks jscher2000. I understand that the pop up is an overlay from the site and not from Firefox. My point was that thousands of sites pop up a dialog window just like that and disabling notifications in the basic Permission settings page should be all that is necessary to stop them from appearing. I support many users who cannot be taught to go into about:config to make advanced changes. This is the type of thing that needs an easy to disable button that I can direct users to, especially since I find more than 80% of users I work with do not want push notifications coming to their browsers.

Dropa, it does not matter that it is coming from the site. The issue is that the pop up should not appear at all once I check the box to block notifications in the Permissions setting page. This has been a long standing issue that would be nice to see go away forever. We need a browser smart enough to stop this, and at this time Firefox is the best hope to actually fix the problem.

more options

The article on Web Push notifications in Firefox https://support.mozilla.org/en-US/kb/push-notifications-firefox