ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions automatically restart

  • 3 ردود
  • 1 has this problem
  • 13 views
  • آخر ردّ كتبه FredMcD

more options

Today I clicked on the Ghostery button to temporarily disable it, to see if doing that would solve a problem on a Web site. (Doing so a few days ago had solved a similar problem on another site.)

But a few seconds after clicking the button to turn it off, and the button changing from blue to gray, the button automatically changed back to blue, turning Ghostery back on again.

So I tried the other extensions. (I have just a few.)

Each one behaved exactly the same way!

What has changed? What is going on?

I'll run a virus scan, but can't think someone would bother to write malware to do something that trivial.

Thanks, Bill Mathews FF 91.0.2

الحل المُختار

Thank you.

Restarting FF seems to have cured the problem.

I thought I'd done that last night. Perhaps FF needed a night's rest. :-)

Read this answer in context 👍 0

All Replies (3)

more options

Try restarting the browser.


It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Helpful?

more options

الحل المُختار

Thank you.

Restarting FF seems to have cured the problem.

I thought I'd done that last night. Perhaps FF needed a night's rest. :-)

Helpful?

more options

As do we all.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.