Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't disable private browsing

  • 7 replies
  • 1 has this problem
  • 458 views
  • آخر ردّ كتبه SgtShadow

more options

Right now, my option is set to "always use private browsing mode." This causes other problems with different extensions I'd like to use, so I'd like to turn always private browsing off.

When I uncheck "always use private browsing mode", Firefox must restart to apply the setting, but after Forefox restarts, it is still checked. I've tried multiple times. I've tried disabling my firewall and antivirus in case they were interfering somehow, but nothing works.

Any help would be greatly appreciated.

Software details: Browser Version: Firefox 62.0.3 OS: Windows 7 64-bit Firewall: COMODO Antivirus: Kaspersky

Chosen solution

You can check for problems with the prefs.js file that stores the preferences. Automatic Private Browsing mode would be this pref in the prefs.js file:

  • user_pref("browser.privatebrowsing.autostart", true);

If there is a line that set this pref to true then you can try to change its value to false or remove the line.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Read this answer in context 👍 1

All Replies (7)

more options
more options

You can also check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program (-private-window or similar).

See also:

more options

I appreciate the replies, but neither of those solutions work for me.

@Ffus3r: That setting is linked to the private browsing setting. It is currently set to "Never Remember History", but I change it to "Custom settings" in order to turn off private browsing, but upon browser restart, it's set back to "Never remember history".

@cor-el: My shortcut has no command line settings at all.

I also have no settings for this in my user.prefs file and have deleted the numbered prefs backup files.

Any other possibilities?

more options

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

I created the user.js file. There is exactly one setting in it, and it has nothing to do with private browsing or history. I could delete it, but it shouldn't be causing my issue.

Any other suggestions?

more options

Chosen Solution

You can check for problems with the prefs.js file that stores the preferences. Automatic Private Browsing mode would be this pref in the prefs.js file:

  • user_pref("browser.privatebrowsing.autostart", true);

If there is a line that set this pref to true then you can try to change its value to false or remove the line.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

PROBLEM SOLVED, THANK YOU!!

There was indeed a line in prefs.js that set my private browsing to true. Every time I tried to change the file and save it, I got a message saying the file was locked by another program. (Which is probably why changing it thru Firefox didn't take) After some hunting around, it turned out that COMODO Firewall was locking the file as part of its HIPS protection (which I had turned off, so it SHOULDN'T have been doing that). Once I disabled COMODO, I was able to change the prefs.js file, which solved my problem. Now I need to reinstall/fix COMODO since it's doing things I told it not to do.

This was a very frustrating problem. Thank you very much!!