ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I suppress the pop up notification "Firefox is full screen"?

  • 3 ردود
  • 2 have this problem
  • 1449 views
  • آخر ردّ كتبه jscher2000

more options

I know it is full screen, I want it full screen, I know how to exit full screen, I simply don't want a reminder to constantly flash up each time I access a control near the top of the screen.

Actually website support has told me it is a common complaint they have been asked multiple times, and requested I share any solution I find.

This question has been asked and answered before but the page returns 404

Thank you in anticipation.

الحل المُختار

The purpose of this is to prevent sites from fooling users with full-screen replicas of other sites or your desktop. I suppose if you are ever suspicious you can just press the Esc key.

To shorten the duration of the message or suppress it completely:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste full-s and pause while the list is filtered

(3) Double-click the full-screen-api.warning.timeout preference and enter the desired value in milliseconds:

  • 3000 = 3 seconds (default value)
  • 500 = half a second
  • 0 = none at all

I suspect you prefer zero, but now that you know where it is, you could experiment with a short flash like half a second.

Read this answer in context 👍 4

All Replies (3)

more options

الحل المُختار

The purpose of this is to prevent sites from fooling users with full-screen replicas of other sites or your desktop. I suppose if you are ever suspicious you can just press the Esc key.

To shorten the duration of the message or suppress it completely:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste full-s and pause while the list is filtered

(3) Double-click the full-screen-api.warning.timeout preference and enter the desired value in milliseconds:

  • 3000 = 3 seconds (default value)
  • 500 = half a second
  • 0 = none at all

I suspect you prefer zero, but now that you know where it is, you could experiment with a short flash like half a second.

Modified by jscher2000

more options

Thank you enormously, that's exactly what I wanted to know :)

Unfortunately it does not alter the delay or suppress the display. I followed your instructions and it accepted and retained the config thru both restart of the browser and the reboot of the machine. Therefore I assume the pop up notification must be coming from a source other than the browser, perhaps flash is the source, or the website.

Thank you.

Modified by BilboBaggins666

more options

Yes, that setting is only for when you click a button in a web page (for example, on the YouTube HTML5 player) and not for when you interact with a plugin.