Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening Firefox opens 80 to 300 tabs. How to stop it?

  • 8 replies
  • 1 has this problem
  • 520 views
  • آخر ردّ كتبه boovyeh

more options

Each time I open Firefox it immediately opens 86 to over 200 tabs. I can't find any way to return Firefox opening to normal. I am running Yosemite 10.10.2 on my Mac.

Chosen solution

boovyeh said

Each time I open Firefox it immediately opens 86 to over 200 tabs. I can't find any way to return Firefox opening to normal. I am running Yosemite 10.10.2 on my Mac.

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 👍 0

All Replies (8)

more options

Chosen Solution

boovyeh said

Each time I open Firefox it immediately opens 86 to over 200 tabs. I can't find any way to return Firefox opening to normal. I am running Yosemite 10.10.2 on my Mac.

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

If the problem didn't disappear in Safe Mode, reset your Firefox startup settings. They could be set to open those tabs:

  1. Click the Menu button (located in the top right corner of the window).
  2. Click "Options".
  3. Click the General tab.
  4. Click the "Restore to Default" button.
  5. Choose "Show my home page" next to When Firefox starts.
  6. Click the "OK" button.

Modified by user1194064

more options

What are the websites that are opening?

more options

You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

more options

If Firefox is your default browser, clicking a link in another application should launch that link in Firefox without opening either your home page or your previous session.

If you don't have a link handy, it might also work in a system search box to type or paste http://mozilla.org and press Return.

Once Firefox starts, you should be able to investigate the above actions without fighting all the tabs.

more options

Thanks, Just-A-User, but I don't get any web sites, just tabs with empty pages below.

more options

You can check for problems with the sessionstore.js file like I posted above.

more options

Thanks Cor-el and jscher. The Firefox Safe solution above worked. All is well.