ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I remove annoying click sound when opening new tab?

  • 15 ردًا
  • 6 have this problem
  • 489 views
  • آخر ردّ كتبه kayvee2262

more options

I've already goggled this and it said something about no-script (which I'm not running) and nothing else that sounded remotely close to my issue. Basically anytime I open a new tab (which I do tons of) I get the most obnoxious loud click type sound and it drives me up the walls. I can simply mute the whole browser but then many media players and the like play the audio directly through the browser instead of adobe flash or the like. I just learned it also plays the most annoying sound in the world when I use the spellcheck feature...

Any help on removing this terrible sound file from Firefox would be greatly appreciated... I would hate to have to start using chrome just to get away from this sound.

The only add-ons I use are Adblock Plus 2.6.3, Advanced SystemCare Surfing Protection 1.0 (I assume it installed itself with the actual ASC program), and Leechblock 0.6.6.

All my plugins are off by default unless I manually turn them on the add-on manager window when I start up firefox and the sound plays before I ever activate them.

الحل المُختار

Hmm...

What is the sound, exactly? To see whether it is a built-in Windows sound, could you review the sounds assigned to various actions in the Control Panel and see whether the sound you hear is one of those:

Start menu > Control Panel > Hardware and Sound category > Change system sounds > (in the dialog) Sounds tab

Also, do you use the setting that shows each tab as its own preview on the Windows Task Bar? If so, could you test showing only actual windows on the bar?

"3-bar" menu button (or Tools menu) > Options > Tabs

uncheck "Show tab previews in the Windows taskbar"

Read this answer in context 👍 1

All Replies (15)

more options

Did this start when you installed Firefox 30, in other words, Firefox 29 and earlier was fine?

In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

There are clicking sounds when in safe mode, there we're no clicking sounds in previous version of firefox.

I changed it... It started back up again and it is now playing even in safe mode when it was not before? I'm not sure what is going on at this point.

Modified by kjlwillycoyote

more options

Good news! But that strongly suggests one of your extensions is creating the sounds. If you view the Add-ons page in Safe Mode, Extensions list, and check the available Options buttons, can you find any audio or sound or notification settings you can modify? If not, I would disable Surfing Protection individually and see whether that helps.

Hold on, either your reply changed or I totally misread it.

Modified by jscher2000

more options

One of the main changes in Firefox was to switch plugins that previously would run automatically to click-to-play. In other threads, we've discovered that some plugins seem to be activated on every page and/or affect the UI of Firefox. These needs to be either set to "Always Activate" or "Never Activate", otherwise they misbehave.

I don't know whether that applies to any of your plugins, but you can experiment on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then, assuming they are not essential to your regular browsing, try changing your Google plugins to "Never Activate" and see whether that makes any difference. There might be some others you can do without for a while.

Note that you might need to launch a new window or exit and start Firefox up again before that takes effect.

more options

Just for testing I set all plugins to never activate and the clicking noise remained. I restarted firefox as suggested, no change. Is it all possible my theme applied the sound?

Out of sheer desperation I've tried the "reset firefox" option found in the troubleshooting section but it did not remove that dreadful clicking sound.

Modified by kjlwillycoyote

more options

If you have a full theme, sure, that's possible. If you have a lightweight theme that merely changes the background of the toolbar, then no, I don't think so.

Which theme is it?

more options

Theme: VinylScratch2 by SonicDragon88

I've also tried changing themes and the sound remains.

more options

These are not high probability suggestions, but:

user.js file

Can you view (right-click > Edit), rename, or delete your user.js file? This article describes how to track that down: How to fix preferences that won't save.

What this file does it override your previous session settings at startup. It doesn't exist by default, so I'm suspicious that it could have something strange in it.

Replace program folder

Here's how:

(1) If needed, download a fresh installer for Firefox 30 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox.

(3) Rename the folder

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does Firefox behave more normally?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • C:\Program Files (x86)\OldFirefox\Plugins
  • C:\Program Files (x86)\OldFirefox\browser\plugins

Check for malware

In case this is some kind of prankware (or spyware), I suggest supplementing your regular security software with the free tools listed in our support article: Troubleshoot Firefox issues caused by malware.

more options

Deleted user.js file, and replaced program folder. No change.

more options

الحل المُختار

Hmm...

What is the sound, exactly? To see whether it is a built-in Windows sound, could you review the sounds assigned to various actions in the Control Panel and see whether the sound you hear is one of those:

Start menu > Control Panel > Hardware and Sound category > Change system sounds > (in the dialog) Sounds tab

Also, do you use the setting that shows each tab as its own preview on the Windows Task Bar? If so, could you test showing only actual windows on the bar?

"3-bar" menu button (or Tools menu) > Options > Tabs

uncheck "Show tab previews in the Windows taskbar"

more options

found the sound in the sound control panel. I assume all I would need to do is direct that sound to a silent .wav file to replace the current one and I'll be good to go?

more options

Which sound is it and what actions is it assigned to? Firefox might be triggering one of those actions (for some unknown reason, but Microsoft did recently issue a bunch of updates).

more options

I changed the option under sounds to [None] and there is finally beautiful silence when i open a new tab. The program event was "menu command". I assume that slot is normally empty but the theme pack I installed for win7 must have given it a sound as I do not remember ever hearing a sound when I opened a new tab before. The sound used was a sound added by the theme pack I installed to win7.

I can not thank you enough for all the help you have provided. You sir deserve a freaking medal.

Modified by kjlwillycoyote

more options

I commend you for your seemingly infinite patience in tracking that down. If you don't mind naming names, what theme pack was it? Maybe that will help someone searching for a solution in the future.

more options

I know you said you aren't runnning NoScript so I'm really glad you were able to find the source of your noise! I'm posting because I came across this thread when I was having a similar problem that did turn out to be the NoScript issue and want to share the solution with anyone else who comes across this too... There's a "notifications" tab - when you click that, there's an "audio feedback when scripts are blocked" option about halfway down the page that's turned on by default. When I unclicked the box, it went away.