Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Opening a bookmark file (or any other file) does not work

  • 9 uphendule
  • 6 zinale nkinga
  • Igcine ukuphendulwa ngu torob

more options

I have installed firefox on 2 XP32 Pro SP3 computers. On the first one, I was able to read in my Opera bookmarks once they were saved as an html file. On the second computer, when I select the Import and Backup menu followed by Import Bookmarks from HTML…, I do not get a dialog box to select the file to import. Nothing happens. Furthermore, I have discovered that no file-related operations work with this installation - such as Open File… or Save Page As…

The only difference between the two installations that I can think of that might be relevant is that on the first computer, I installed into the default directory; on the second, I changed the name of the directory into which I installed.

So the relevant developer might want to check the effects of installation into a non-standard directory, and if this is the cause, fix how it works (or remove that option).

All Replies (9)

more options

Which security software (firewall, anti-virus) do you have?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

Thank you for your response.

I am using Online Armor and Avast 2014.9.0.2013 Firefox is set as a Trusted program in Online Armor.

[Why] would a firewall or antivirus prevent me from getting an open file dialog box?

more options

I get it - you suspect that I have a virus?

So today I ran both a deep full system scan, and a boot-time scan with Avast (took several hours). It found a few minor things, mostly in unused system partitions (my currently active system was moved to an SSD a year ago).

[the next day I ran another full system check with the online virus scanner of another security company, to double check and see if it could find some virus that Avast missed. It also found nothing signficant.]

When I look at what's running in the Process Explorer, I do not see anything that looks suspicious, though that is no guarantee of course.

Now in firefox the menu items which should produce a select file dialog box (such as Import Bookmarks from HTML…) work sometimes; other times not. For example, I start firefox, this menu is working; I connect to the internet, close firefox, open it again, and then it is not working. Then I close firefox, restart it again, and they are working etc. I do not know why.

BTW I tried it in safe mode following your suggestion before running the virus scans and the open file dialog box worked, but now that it is working intermittently I do not know if that was the reason that it worked that specific time or not.

What is the next step?

Okulungisiwe ngu johnson97

more options


I have the same problem. In my case, if I exit Online Armor everything works fine. But when I start Online Armor again, the problem is back.

I have posted the question on Emsisoft support page here.

Does it work for you when you temporary shut down Online Armor, or have you found a solution to the problem?

more options

Hi torob:

Thanks for your response. I have not found a solution to the problem.

I exited both Online Armor and Avast and the problem was still there.

Unfortunately the problem is intermittent. One time it works; another time it does not. So yesterday, for example, I could not open files etc; today I can (with both Online Armor and Avast running!).

Is the problem intermittent in your case as well? Was it coincidence that it worked when you shut down Online Armor? I would suggest trying the exiting of Online Armor a few more times, combined with exiting and restarting firefox to see if that really was the problem.

more options

In followup, as a test for my previous hypothesis (above) that the problem might have to do with my initial installation of firefox in a non-standard directory, I uninstalled it (completely), and reinstalled it in the standard directory.

The first time afterwards that I tried it the problem was gone, but the next time I tried it it was back. So the intermittent nature of the problem is unfortunately unchanged.

more options

In my case it's not intermittent, but very concrete. It works every time when I shut down Online Armor, and doesn't when I open Online Armor again.

I have tried several times, and same result every time. I have also tried Firefox Portable, to see if a setting in Firefox could be the problem, but when using Firefox Portable with default settings, the problem is the same.

A logical conclusion would be that there must be something wrong with Online Armor, but if it was a common problem I guess more people would have this problem. I have tried several search on Google to see if other has this problem, but this post was the only I could find related to Online Armor. Found some others, but then it was related to possible corrupted data files in Firefox.

But it could also be another running program / configuration which is causing the problem when Online Armor is active.

more options

Interesting. Today mine is not working again, while yesterday it was working, with Online Armor running. I wonder if it has to do with the order that startup programs are starting?

The other XP32 Pro PC that I originally described where I do not have this problem at all, is indeed running an older version of Zonealarm instead of Online Armor.

Which antivirus are you using?

more options

I also use Avast. I found out there is also problem with other function where a file open / save dialog should pop up. I was going to import a certificate, and the same happens then. I need to temporary shutdown Online Armor to be able to add it. So I guess the problem is related to when Firefox is requesting this file dialog, something blocks it. But the problem only occur in Firefox. Other programs works fine, including Thunderbird.